aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/dream/Makefile7
-rw-r--r--sysutils/bacula-bat/Makefile2
-rw-r--r--sysutils/bacula-server/Makefile1
3 files changed, 6 insertions, 4 deletions
diff --git a/audio/dream/Makefile b/audio/dream/Makefile
index 3d368ca4ec16..c5a4414e93da 100644
--- a/audio/dream/Makefile
+++ b/audio/dream/Makefile
@@ -6,7 +6,7 @@
PORTNAME= dream
PORTVERSION= 1.6.25
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio hamradio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= drm
@@ -16,7 +16,7 @@ MAINTAINER= xride@FreeBSD.org
COMMENT= Digital Radio Mondiale (DRM) software receiver
LIB_DEPENDS= fftw.2:${PORTSDIR}/math/fftw \
- qwt.4:${PORTSDIR}/x11-toolkits/qwt \
+ qwt4.4:${PORTSDIR}/x11-toolkits/qwt4 \
faad.0:${PORTSDIR}/audio/faad
BROKEN= Needs DRM enabled in FAAD
@@ -31,7 +31,8 @@ CONFIGURE_ENV= CXXFLAGS="${CXXFLAGS} -I${LOCALBASE}/include \
PLIST_FILES= bin/drm
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/include/qwt|${LOCALBASE}/include/qwt|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|/usr/include/qwt|${LOCALBASE}/include/qwt4|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-lqwt|-lqwt4|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|neaacdec.h|faad.h|g' ${WRKSRC}/common/sourcedecoders/AudioSourceDecoder.cpp
@${REINPLACE_CMD} -e 's|DRMCH_SBR_PS_STEREO|DRMCH_SBR_STEREO|g' ${WRKSRC}/common/sourcedecoders/AudioSourceDecoder.cpp
diff --git a/sysutils/bacula-bat/Makefile b/sysutils/bacula-bat/Makefile
index d89394143244..26fc86c5702c 100644
--- a/sysutils/bacula-bat/Makefile
+++ b/sysutils/bacula-bat/Makefile
@@ -10,7 +10,7 @@ PKGNAMESUFFIX= -bat
COMMENT= The network backup solution (GUI)
-LIB_DEPENDS+= qwt.5:${PORTSDIR}/x11-toolkits/qwt-devel
+LIB_DEPENDS+= qwt.5:${PORTSDIR}/x11-toolkits/qwt5
USE_QT_VER= 4
QT_COMPONENTS= qmake uic moc rcc
diff --git a/sysutils/bacula-server/Makefile b/sysutils/bacula-server/Makefile
index 87832dbe3ef4..c0c4f7ac5bb1 100644
--- a/sysutils/bacula-server/Makefile
+++ b/sysutils/bacula-server/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bacula
DISTVERSION= 2.2.8
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= bacula