aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/linux-zsnes/Makefile44
-rw-r--r--emulators/linux-zsnes/distinfo2
-rw-r--r--emulators/linux-zsnes/pkg-descr13
4 files changed, 60 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 3045349860a9..b06b65ce75b4 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -50,6 +50,7 @@
SUBDIR += linux-vmware-toolbox2
SUBDIR += linux-vmware-toolbox4
SUBDIR += linux-winetools
+ SUBDIR += linux-zsnes
SUBDIR += linux_base
SUBDIR += linux_base-6
SUBDIR += linux_base-8
diff --git a/emulators/linux-zsnes/Makefile b/emulators/linux-zsnes/Makefile
new file mode 100644
index 000000000000..3703e0de234d
--- /dev/null
+++ b/emulators/linux-zsnes/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: linux-zsnes
+# Date created: 22 June 2004
+# Whom: Travis Poppe <tlp@liquidx.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= zsnes
+PORTVERSION= 1.36
+CATEGORIES= emulators linux
+MASTER_SITES= http://newrpms.sunsite.dk/apt/redhat/en/i386/9.0/RPMS.newrpms/
+PKGNAMEPREFIX= linux-
+DISTNAME= ${PORTNAME}-${PORTVERSION}-3.i386
+EXTRACT_SUFX= .rpm
+EXTRACT_ONLY=
+
+MAINTAINER= tlp@liquidx.org
+COMMENT= Linux binary version of the x86 only SNES emulator
+
+EXTRACT_DEPENDS= rpm2cpio.pl:${PORTSDIR}/archivers/rpm2cpio
+RUN_DEPENDS= ${LINUXBASE}/lib/libc-2.3.2.so:${PORTSDIR}/emulators/linux_base-8 \
+ ${LINUXBASE}/usr/X11R6/lib/libXi.so.6:${PORTSDIR}/x11/linux-XFree86-libs \
+ ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri \
+ ${LINUXBASE}/usr/lib/libpng12.so.0:${PORTSDIR}/graphics/linux-png \
+ ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12
+
+ONLY_FOR_ARCHS= i386
+DIST_SUBDIR= rpm
+NO_BUILD= yes
+
+MANCOMPRESSED= yes
+MAN1= linux-zsnes.1
+PLIST_FILES= bin/linux-zsnes
+
+STRIP=
+
+post-extract:
+ cd ${WRKDIR}; rpm2cpio.pl ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME}${EXTRACT_SUFX} | ${CPIO} -id --quiet
+
+do-install:
+ ${INSTALL_MAN} ${WRKDIR}/usr/share/man/man1/zsnes.1.gz ${PREFIX}/man/man1/linux-zsnes.1.gz
+ ${INSTALL_PROGRAM} ${WRKDIR}/usr/bin/zsnes ${PREFIX}/bin/linux-zsnes
+
+.include <bsd.port.mk>
diff --git a/emulators/linux-zsnes/distinfo b/emulators/linux-zsnes/distinfo
new file mode 100644
index 000000000000..71c760258bce
--- /dev/null
+++ b/emulators/linux-zsnes/distinfo
@@ -0,0 +1,2 @@
+MD5 (rpm/zsnes-1.36-3.i386.rpm) = 9c83fe09286477839cc428c3857b8086
+SIZE (rpm/zsnes-1.36-3.i386.rpm) = 474922
diff --git a/emulators/linux-zsnes/pkg-descr b/emulators/linux-zsnes/pkg-descr
new file mode 100644
index 000000000000..ee64c68f90e3
--- /dev/null
+++ b/emulators/linux-zsnes/pkg-descr
@@ -0,0 +1,13 @@
+An x86 only Super Nintendo Entertainment System (SNES) Emulator,
+with higher compatibility rates than snes9x.
+
+This is the Linux binary version.
+
+Note: This port exists due to performance issues (sound) with our native
+version that remain unfixed. When these issues are fixed, this port should
+be removed.
+
+WWW: http://www.zsnes.com/
+
+- Travis Poppe
+tlp@liquidx.org