aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11/Makefile1
-rw-r--r--x11/xrestop/Makefile28
-rw-r--r--x11/xrestop/distinfo1
-rw-r--r--x11/xrestop/pkg-descr6
-rw-r--r--x11/xrestop/pkg-plist1
5 files changed, 37 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 6beffda98060..48ddb044123c 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -193,6 +193,7 @@
SUBDIR += xnodecor
SUBDIR += xprompt
SUBDIR += xproto
+ SUBDIR += xrestop
SUBDIR += xrootconsole
SUBDIR += xscreensaver
SUBDIR += xscreensaver-gnome
diff --git a/x11/xrestop/Makefile b/x11/xrestop/Makefile
new file mode 100644
index 000000000000..fda870fcbb4f
--- /dev/null
+++ b/x11/xrestop/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: xrestop
+# Date created: 25 Dec 2003
+# Whom: Alexander Nedotsukov <bland@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xrestop
+PORTVERSION= 0.2
+CATEGORIES= x11
+MASTER_SITES= http://www.freedesktop.org/Software/${PORTNAME}/
+
+MAINTAINER= bland@FreeBSD.org
+COMMENT= X11 server side resource usage statistics monitor
+
+LIB_DEPENDS= X11.6:${PORTSDIR}/x11/XFree86-4-libraries
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= gnometarget
+GNU_CONFIGURE= yes
+
+CONFIGURE_ENV= CFLAGS=-I${X11BASE}/include \
+ LDFLAGS=-L${X11BASE}/lib
+
+MAN1= xrestop.1
+
+.include <bsd.port.mk>
diff --git a/x11/xrestop/distinfo b/x11/xrestop/distinfo
new file mode 100644
index 000000000000..2a93fa0f1fd0
--- /dev/null
+++ b/x11/xrestop/distinfo
@@ -0,0 +1 @@
+MD5 (xrestop-0.2.tar.gz) = 5ff774ff9cbb5997f0fb68e712dee302
diff --git a/x11/xrestop/pkg-descr b/x11/xrestop/pkg-descr
new file mode 100644
index 000000000000..f90aaa54a98c
--- /dev/null
+++ b/x11/xrestop/pkg-descr
@@ -0,0 +1,6 @@
+Xrestop uses X-Resource extension to provide 'top' like statistics
+of each connected X11 client's server side resource usage. It is
+intendent as a developer tool aid more efficient server resource
+usage and debug server side leakage.
+
+WWW: http://www.freedesktop.org/Software/xrestop/
diff --git a/x11/xrestop/pkg-plist b/x11/xrestop/pkg-plist
new file mode 100644
index 000000000000..6ae1dbe36ca7
--- /dev/null
+++ b/x11/xrestop/pkg-plist
@@ -0,0 +1 @@
+bin/xrestop