aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emulators/p5-Acme-6502/Makefile9
-rw-r--r--palm/p5-Palm/Makefile9
-rw-r--r--security/p5-Authen-Smb/Makefile10
-rw-r--r--security/p5-Business-PayPal-EWP/Makefile3
-rw-r--r--security/p5-Crypt-CFB/Makefile7
-rw-r--r--security/p5-Crypt-Caesar/Makefile7
-rw-r--r--security/p5-Crypt-Juniper/Makefile9
-rw-r--r--security/p5-Crypt-RC4/Makefile9
-rw-r--r--security/p5-Crypt-Rabbit/Makefile7
-rw-r--r--security/p5-Crypt-Random-Source/Makefile9
-rw-r--r--security/p5-Crypt-Solitaire/Makefile9
-rw-r--r--security/p5-Digest-Haval256/Makefile7
-rw-r--r--security/p5-Digest-MurmurHash/Makefile8
-rw-r--r--security/p5-Digest-Pearson-PurePerl/Makefile7
-rw-r--r--security/p5-Snort-Rule/Makefile9
-rw-r--r--security/ppars/Makefile8
-rw-r--r--security/shimmer/Makefile9
-rw-r--r--security/signing-party/Makefile8
-rw-r--r--security/tinyca/Makefile2
19 files changed, 51 insertions, 95 deletions
diff --git a/emulators/p5-Acme-6502/Makefile b/emulators/p5-Acme-6502/Makefile
index 7023b89f80b0..9295a12c6731 100644
--- a/emulators/p5-Acme-6502/Makefile
+++ b/emulators/p5-Acme-6502/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Acme-6502
-# Date created: 2012-07-03
-# Whom: Steven Kreuzer <skreuzer@FreeBSD.org>
-#
+# Created by: Steven Kreuzer <skreuzer@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Acme-6502
PORTVERSION= 0.77
@@ -18,7 +14,8 @@ RUN_DEPENDS= p5-Term-ReadKey>=2.30:${PORTSDIR}/devel/p5-Term-ReadKey \
p5-version>=0.98:${PORTSDIR}/devel/p5-version
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Acme::6502.3 \
Acme::6502::Tube.3
diff --git a/palm/p5-Palm/Makefile b/palm/p5-Palm/Makefile
index ca7539037d3b..6ed2053e74d1 100644
--- a/palm/p5-Palm/Makefile
+++ b/palm/p5-Palm/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Palm
-# Date created: 29 April 2000
-# Whom: Andrew Arensburger <arensb+freebsd-ports@ooblick.com>
-#
+# Created by: Andrew Arensburger <arensb+freebsd-ports@ooblick.com>
# $FreeBSD$
-#
PORTNAME= p5-Palm
PORTVERSION= 1.3.0
@@ -13,7 +9,8 @@ MASTER_SITES= http://www.coldsync.org/download/
MAINTAINER= arensb@ooblick.com
COMMENT= Perl 5 modules for reading and writing Palm database files
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
WRKSRC= ${WRKDIR}/p5-Palm-1.003_000
# Just so that the .packlist conforms to reality
diff --git a/security/p5-Authen-Smb/Makefile b/security/p5-Authen-Smb/Makefile
index 7d35076ffd16..b059dd12c091 100644
--- a/security/p5-Authen-Smb/Makefile
+++ b/security/p5-Authen-Smb/Makefile
@@ -1,10 +1,5 @@
-# New ports collection makefile for: p5-Authen-Smb
-# Date created: Fri 03 January 2002
-# Whom: Mustafa Arif <ma499@doc.ic.ac.uk>
-# http://www.doc.ic.ac.uk/~ma499/
-#
+# Created by: Mustafa Arif <ma499@doc.ic.ac.uk>
# $FreeBSD$
-#
PORTNAME= Authen-Smb
PORTVERSION= 0.91
@@ -15,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ma499@doc.ic.ac.uk
COMMENT= Perl extension to authenticate against an SMB server
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Authen::Smb.3
diff --git a/security/p5-Business-PayPal-EWP/Makefile b/security/p5-Business-PayPal-EWP/Makefile
index 3142f8b7af36..6d8beb0d7833 100644
--- a/security/p5-Business-PayPal-EWP/Makefile
+++ b/security/p5-Business-PayPal-EWP/Makefile
@@ -13,7 +13,8 @@ COMMENT= Perl extension for PayPal Encrypted Website Payments
RUN_DEPENDS= p5-Net-SSLeay>=0:${PORTSDIR}/security/p5-Net-SSLeay
BUILD_DEPENDS= p5-Net-SSLeay>=0:${PORTSDIR}/security/p5-Net-SSLeay
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
USE_OPENSSL= yes
CONFIGURE_ARGS= ${OPENSSLBASE}
USE_DOS2UNIX= yes
diff --git a/security/p5-Crypt-CFB/Makefile b/security/p5-Crypt-CFB/Makefile
index 6866696a07fb..f31cc9ad05c7 100644
--- a/security/p5-Crypt-CFB/Makefile
+++ b/security/p5-Crypt-CFB/Makefile
@@ -1,6 +1,4 @@
-# New ports collection Makefile for: p5-Crypt-CFB
-# Date created: 18 Dec 2006
-# Whom: Gabor Kovesdan
+# Created by: Gabor Kovesdan
# $FreeBSD$
PORTNAME= Crypt-CFB
@@ -12,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ashish@FreeBSD.org
COMMENT= Perl extension for encrypting data in Cipher Feedback Mode
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Crypt::CFB.3
diff --git a/security/p5-Crypt-Caesar/Makefile b/security/p5-Crypt-Caesar/Makefile
index 1a544bba3aa8..b42a82efe293 100644
--- a/security/p5-Crypt-Caesar/Makefile
+++ b/security/p5-Crypt-Caesar/Makefile
@@ -1,6 +1,4 @@
-# New ports collection Makefile for: p5-Crypt-Caesar
-# Date created: 18 Dec 2006
-# Whom: Gabor Kovesdan
+# Created by: Gabor Kovesdan
# $FreeBSD$
PORTNAME= Crypt-Caesar
@@ -12,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skreuzer@FreeBSD.org
COMMENT= Perl extension for decrypting rot-N strings
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Crypt::Caesar.3
diff --git a/security/p5-Crypt-Juniper/Makefile b/security/p5-Crypt-Juniper/Makefile
index 88cb6a455507..380c42e032bb 100644
--- a/security/p5-Crypt-Juniper/Makefile
+++ b/security/p5-Crypt-Juniper/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Crypt-Juniper
-# Date created: 2009-01-29
-# Whom: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
-#
+# Created by: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
# $FreeBSD$
-#
PORTNAME= Crypt-Juniper
PORTVERSION= 0.02
@@ -17,7 +13,8 @@ COMMENT= Encrypt and decrypt Juniper $9$ secrets
TEST_DEPENDS= p5-Test-Exception>0:${PORTSDIR}/devel/p5-Test-Exception
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Crypt::Juniper.3
diff --git a/security/p5-Crypt-RC4/Makefile b/security/p5-Crypt-RC4/Makefile
index c48f345ab66d..27f7d5c96ab6 100644
--- a/security/p5-Crypt-RC4/Makefile
+++ b/security/p5-Crypt-RC4/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Crypt::RC4
-# Date created: 30 Dec 2001
-# Whom: Seamus Venasse <svenasse@polaris.ca>
-#
+# Created by: Seamus Venasse <svenasse@polaris.ca>
# $FreeBSD$
-#
PORTNAME= Crypt-RC4
PORTVERSION= 2.02
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skreuzer@FreeBSD.org
COMMENT= Perl implementation of the RC4 encryption algorithm
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Crypt::RC4.3
diff --git a/security/p5-Crypt-Rabbit/Makefile b/security/p5-Crypt-Rabbit/Makefile
index 8e0b2a66ce76..e8f3c7f19885 100644
--- a/security/p5-Crypt-Rabbit/Makefile
+++ b/security/p5-Crypt-Rabbit/Makefile
@@ -1,6 +1,4 @@
-# New ports collection Makefile for: p5-Crypt-Rabbit
-# Date created: 18 Dec 2006
-# Whom: Gabor Kovesdan
+# Created by: Gabor Kovesdan
# $FreeBSD$
PORTNAME= Crypt-Rabbit
@@ -12,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skreuzer@FreeBSD.org
COMMENT= Perl extension for Rabbit stream cipher
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Crypt::Rabbit.3
diff --git a/security/p5-Crypt-Random-Source/Makefile b/security/p5-Crypt-Random-Source/Makefile
index dbe2e4a2b357..14430a7f613d 100644
--- a/security/p5-Crypt-Random-Source/Makefile
+++ b/security/p5-Crypt-Random-Source/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Crypt::Random::Source
-# Date created: 15 March 2011
-# Whom: Dereckson <dereckson@gmail.com>
-#
+# Created by: Dereckson <dereckson@gmail.com>
# $FreeBSD$
-#
PORTNAME= Crypt-Random-Source
PORTVERSION= 0.07
@@ -39,6 +35,7 @@ MAN3= Crypt::Random::Source.3 \
Crypt::Random::Source::Weak::devurandom.3 \
Crypt::Random::Source::Weak::rand.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/security/p5-Crypt-Solitaire/Makefile b/security/p5-Crypt-Solitaire/Makefile
index 0ffebbd2a064..f1238a83daca 100644
--- a/security/p5-Crypt-Solitaire/Makefile
+++ b/security/p5-Crypt-Solitaire/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Crypt::Solitaire
-# Date created: 30 Dec 2001
-# Whom: Seamus Venasse <svenasse@polaris.ca>
-#
+# Created by: Seamus Venasse <svenasse@polaris.ca>
# $FreeBSD$
-#
PORTNAME= Crypt-Solitaire
PORTVERSION= 2.0
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skreuzer@FreeBSD.org
COMMENT= Solitaire encryption
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Crypt::Solitaire.3
diff --git a/security/p5-Digest-Haval256/Makefile b/security/p5-Digest-Haval256/Makefile
index 0f5233f656be..87409a977eb3 100644
--- a/security/p5-Digest-Haval256/Makefile
+++ b/security/p5-Digest-Haval256/Makefile
@@ -1,6 +1,4 @@
-# Ports collection Makefile for: p5-Digest-Haval256
-# Date created: 17 Dec 2005
-# Whom: Gabor Kovesdan
+# Created by: Gabor Kovesdan
# $FreeBSD$
PORTNAME= Digest-Haval256
@@ -15,7 +13,8 @@ COMMENT= Perl extension for Haval256 hash algorithm
BUILD_DEPENDS= p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64
RUN_DEPENDS= p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Digest::Haval256.3
diff --git a/security/p5-Digest-MurmurHash/Makefile b/security/p5-Digest-MurmurHash/Makefile
index 31b6f3593285..498a92b0550a 100644
--- a/security/p5-Digest-MurmurHash/Makefile
+++ b/security/p5-Digest-MurmurHash/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: Digest::MurmurHash
-# Date created: 31 Dec 2011
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= Digest-MurmurHash
PORTVERSION= 0.11
@@ -14,7 +9,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl extension for XS interface to the MurmurHash algorithm
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Digest::MurmurHash.3
diff --git a/security/p5-Digest-Pearson-PurePerl/Makefile b/security/p5-Digest-Pearson-PurePerl/Makefile
index f6915e19df5d..c99ba6c483ee 100644
--- a/security/p5-Digest-Pearson-PurePerl/Makefile
+++ b/security/p5-Digest-Pearson-PurePerl/Makefile
@@ -1,6 +1,4 @@
-# Ports collection Makefile for: p5-Digest-Pearson-PurePerl
-# Date created: 21 Dec, 2005
-# Whom: Gabor Kovesdan
+# Created by: Gabor Kovesdan
# $FreeBSD$
PORTNAME= Digest-Pearson-PurePerl
@@ -12,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ashish@FreeBSD.org
COMMENT= Perl extension for Peter K. Pearson's hash algorithm in pure Perl
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Digest::Pearson::PurePerl.3
diff --git a/security/p5-Snort-Rule/Makefile b/security/p5-Snort-Rule/Makefile
index 379645561b41..a5e684d905ec 100644
--- a/security/p5-Snort-Rule/Makefile
+++ b/security/p5-Snort-Rule/Makefile
@@ -1,9 +1,5 @@
-# ports collection makefile for: perl extension for dynamically building snort rules
-# Date created: 30 January 2008
-# Whom: Paul Schmehl <pauls@utdallas.edu>
-#
+# Created by: Paul Schmehl <pauls@utdallas.edu>
# $FreeBSD$
-#
PORTNAME= Snort-Rule
PORTVERSION= 1.07
@@ -15,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= pauls@utdallas.edu
COMMENT= Perl5 extension for dynamically building snort rules
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
PLIST_FILES= %%SITE_PERL%%/Snort/Rule.pm \
%%SITE_PERL%%/mach/auto/Snort/Rule/.packlist
diff --git a/security/ppars/Makefile b/security/ppars/Makefile
index dd0054124bf1..e869631161d0 100644
--- a/security/ppars/Makefile
+++ b/security/ppars/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ppars
-# Date created: 2004-06-29
-# Whom: Joe Barbish <fbsd_user@a1poweruser.com>
-#
+# Created by: Joe Barbish <fbsd_user@a1poweruser.com>
# $FreeBSD$
-#
PORTNAME= ppars
PORTVERSION= 1.0
@@ -16,7 +12,7 @@ COMMENT= Proactive Probing Abuse Reporting System
RUN_DEPENDS= p5-Net-Netmask>=0:${PORTSDIR}/net-mgmt/p5-Net-Netmask
-USE_PERL5= yes
+USES= perl5
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/security/shimmer/Makefile b/security/shimmer/Makefile
index 200c80c02eeb..35a0d770a26b 100644
--- a/security/shimmer/Makefile
+++ b/security/shimmer/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: shimmer
-# Date created: 2008-01-09
-# Whom: Felippe de Meirelles Motta <lippemail@gmail.com>
-#
+# Created by: Felippe de Meirelles Motta <lippemail@gmail.com>
# $FreeBSD$
-#
PORTNAME= shimmer
PORTVERSION= 0.1.0
@@ -17,7 +13,8 @@ COMMENT= Perl implementation that hides a valuable port on your server
NO_WRKSUBDIR= yes
NO_BUILD= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
PLIST_FILES= bin/shimmer \
bin/shimmerd \
diff --git a/security/signing-party/Makefile b/security/signing-party/Makefile
index 461a6ed67e81..85a8844d6dc7 100644
--- a/security/signing-party/Makefile
+++ b/security/signing-party/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: signing-party
-# Date created: 13 September 2005
-# Whom: johans
-#
+# Created by: johans
# $FreeBSD$
-#
PORTNAME= signing-party
PORTVERSION= 1.1.4
@@ -32,7 +28,7 @@ CONFLICTS_INSTALL=sig2dot-[0-9]* springgraph-[0-9]*
REINPLACE_ARGS= -i ''
USE_GMAKE= yes
-USE_PERL5= yes
+USES= perl5
SCRIPTS= caff/caff caff/pgp-clean caff/pgp-fixkey gpglist/gpglist \
gpgsigs/gpgsigs gpg-key2ps/gpg-key2ps \
diff --git a/security/tinyca/Makefile b/security/tinyca/Makefile
index bdabee6f94c9..b3d1d4fd39b7 100644
--- a/security/tinyca/Makefile
+++ b/security/tinyca/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= p5-Gtk2>=0:${PORTSDIR}/x11-toolkits/p5-Gtk2 \
p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64
USE_BZIP2= yes
-USE_PERL5= yes
+USES= perl5
USE_OPENSSL= yes
NO_BUILD= yes
DOC_FILES= INSTALL