aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--archivers/dpkg/Makefile3
-rw-r--r--audio/rosegarden/Makefile10
-rw-r--r--comms/efax-gtk/Makefile4
-rw-r--r--finance/homebank/Makefile4
-rw-r--r--graphics/podofo/Makefile12
-rw-r--r--mail/claws-mail-fancy/Makefile4
-rw-r--r--mail/claws-mail-gdata/Makefile2
-rw-r--r--mail/claws-mail-notification/Makefile4
-rw-r--r--mail/claws-mail-pdf_viewer/Makefile2
-rw-r--r--mail/claws-mail-perl/Makefile2
-rw-r--r--mail/claws-mail-pgp/Makefile2
-rw-r--r--mail/claws-mail/Makefile16
-rw-r--r--mail/claws-mail/Makefile.claws1
-rw-r--r--mail/clawsker/Makefile3
-rw-r--r--mail/libetpan/Makefile10
-rw-r--r--multimedia/bombono/Makefile12
-rw-r--r--multimedia/lives/Makefile27
-rw-r--r--polish/ekg/Makefile6
-rw-r--r--polish/ekg2/Makefile21
-rw-r--r--polish/kadu/Makefile30
-rw-r--r--polish/qnapi/Makefile8
-rw-r--r--sysutils/gsmartcontrol/Makefile21
-rw-r--r--www/netsurf/Makefile6
-rw-r--r--x11-toolkits/termit/Makefile12
24 files changed, 87 insertions, 135 deletions
diff --git a/archivers/dpkg/Makefile b/archivers/dpkg/Makefile
index 2fe76c7a07f0..af9a407a8f29 100644
--- a/archivers/dpkg/Makefile
+++ b/archivers/dpkg/Makefile
@@ -18,10 +18,9 @@ RUN_DEPENDS= gtar:${PORTSDIR}/archivers/gtar \
gpatch:${PORTSDIR}/devel/patch \
gmd5sum:${PORTSDIR}/sysutils/coreutils
-USES= gmake iconv
USE_XZ= yes
GNU_CONFIGURE= yes
-USE_PERL5= yes
+USES= gmake iconv perl5
WRKSRC= ${WRKDIR}/dpkg-${PORTVERSION}
DPKGDIR?= /var/db/dpkg
diff --git a/audio/rosegarden/Makefile b/audio/rosegarden/Makefile
index 65a55927a911..101691f84e61 100644
--- a/audio/rosegarden/Makefile
+++ b/audio/rosegarden/Makefile
@@ -13,11 +13,11 @@ LICENSE= GPLv2
BUILD_DEPENDS= dssi_osc_update:${PORTSDIR}/audio/dssi \
makedepend:${PORTSDIR}/devel/makedepend
-LIB_DEPENDS= asound:${PORTSDIR}/audio/alsa-lib \
- lirc_client:${PORTSDIR}/comms/lirc \
- fftw3:${PORTSDIR}/math/fftw3 \
- fftw3f:${PORTSDIR}/math/fftw3-float \
- lrdf:${PORTSDIR}/textproc/liblrdf
+LIB_DEPENDS= libasound.so:${PORTSDIR}/audio/alsa-lib \
+ liblirc_client.so:${PORTSDIR}/comms/lirc \
+ libfftw3.so:${PORTSDIR}/math/fftw3 \
+ libfftw3f.so:${PORTSDIR}/math/fftw3-float \
+ liblrdf.so:${PORTSDIR}/textproc/liblrdf
RUN_DEPENDS= dssi_osc_update:${PORTSDIR}/audio/dssi \
lilypond:${PORTSDIR}/print/lilypond
diff --git a/comms/efax-gtk/Makefile b/comms/efax-gtk/Makefile
index cce77241af69..8e95bde26f78 100644
--- a/comms/efax-gtk/Makefile
+++ b/comms/efax-gtk/Makefile
@@ -13,8 +13,8 @@ COMMENT= GUI frontend for efax program
LICENSE= GPLv2
-LIB_DEPENDS= sigc-1.2.5:${PORTSDIR}/devel/libsigc++12 \
- cxx-gtk-utils-2-2.2:${PORTSDIR}/x11-toolkits/c++-gtk-utils
+LIB_DEPENDS= libsigc-1.2.so:${PORTSDIR}/devel/libsigc++12 \
+ libcxx-gtk-utils-2-2.2.so:${PORTSDIR}/x11-toolkits/c++-gtk-utils
RUN_DEPENDS= ggv:${PORTSDIR}/print/ggv
USES= pkgconfig
diff --git a/finance/homebank/Makefile b/finance/homebank/Makefile
index ed554174596d..5e468a6b13ee 100644
--- a/finance/homebank/Makefile
+++ b/finance/homebank/Makefile
@@ -10,7 +10,7 @@ COMMENT= Free, easy, personal accounting for everyone
LICENSE= GPLv2
-LIB_DEPENDS= osp:${PORTSDIR}/textproc/opensp
+LIB_DEPENDS= libosp.so:${PORTSDIR}/textproc/opensp
GNU_CONFIGURE= yes
USES= desktop-file-utils gmake shared-mime-info
@@ -26,7 +26,7 @@ OPTIONS_DEFINE= DOCS OFX
OFX_DESC= OFX file format support
OPTIONS_DEFAULT=OFX
-OFX_LIB_DEPENDS= ofx:${PORTSDIR}/finance/libofx
+OFX_LIB_DEPENDS= libofx.so:${PORTSDIR}/finance/libofx
OFX_CONFIGURE_OFF= --without-ofx
.include <bsd.port.options.mk>
diff --git a/graphics/podofo/Makefile b/graphics/podofo/Makefile
index 62ff1f018d75..2e1fe87e3dd2 100644
--- a/graphics/podofo/Makefile
+++ b/graphics/podofo/Makefile
@@ -12,9 +12,9 @@ COMMENT= PDF manipulation library and tools
LICENSE= GPLv2 LGPL21
LICENSE_COMB= multi
-LIB_DEPENDS= idn:${PORTSDIR}/dns/libidn \
- freetype:${PORTSDIR}/print/freetype2 \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig
+LIB_DEPENDS= libidn.so:${PORTSDIR}/dns/libidn \
+ libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
USES= cmake
CMAKE_ARGS= -DPODOFO_BUILD_SHARED:BOOL=TRUE \
@@ -40,13 +40,13 @@ IMPOSE_CXXFLAGS= -I${LUA_INCDIR}
IMPOSE_LDFLAGS= -L${LUA_LIBDIR}
JPEG_CMAKE_ON= -DWANT_LIBJPEG:BOOL=TRUE
-JPEG_LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg
+JPEG_LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
PNG_CMAKE_ON= -DWANT_PNG:BOOL=TRUE
-PNG_LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
+PNG_LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
TIFF_CMAKE_ON= -DWANT_TIFF:BOOL=TRUE
-TIFF_LIB_DEPENDS= tiff:${PORTSDIR}/graphics/tiff
+TIFF_LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff
.include <bsd.port.options.mk>
diff --git a/mail/claws-mail-fancy/Makefile b/mail/claws-mail-fancy/Makefile
index ea535c86256c..b88f92cf94ca 100644
--- a/mail/claws-mail-fancy/Makefile
+++ b/mail/claws-mail-fancy/Makefile
@@ -6,8 +6,8 @@ PORTREVISION= 0
COMMENT= Webkit based HTML renderer plugin for Claws Mail
-LIB_DEPENDS= soup-gnome:${PORTSDIR}/devel/libsoup-gnome \
- webkitgtk:${PORTSDIR}/www/webkit-gtk2
+LIB_DEPENDS= libsoup-gnome-2.4.so:${PORTSDIR}/devel/libsoup-gnome \
+ libwebkitgtk-1.0.so:${PORTSDIR}/www/webkit-gtk2
CLAWS_PLUGINS_BUILD= fancy
diff --git a/mail/claws-mail-gdata/Makefile b/mail/claws-mail-gdata/Makefile
index e96924dc2377..77ad345292cd 100644
--- a/mail/claws-mail-gdata/Makefile
+++ b/mail/claws-mail-gdata/Makefile
@@ -6,7 +6,7 @@ PORTREVISION= 0
COMMENT= Plugin providing Google Contacts in the Tab-address completion
-LIB_DEPENDS= gdata:${PORTSDIR}/devel/libgdata
+LIB_DEPENDS= libgdata.so:${PORTSDIR}/devel/libgdata
CLAWS_PLUGINS_BUILD= gdata
diff --git a/mail/claws-mail-notification/Makefile b/mail/claws-mail-notification/Makefile
index b62a43e9c403..3ae665810b12 100644
--- a/mail/claws-mail-notification/Makefile
+++ b/mail/claws-mail-notification/Makefile
@@ -6,8 +6,8 @@ PORTREVISION= 1
COMMENT= New mail notification plugin for Claws Mail
-LIB_DEPENDS= canberra-gtk:${PORTSDIR}/audio/libcanberra \
- notify:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS= libcanberra-gtk.so:${PORTSDIR}/audio/libcanberra \
+ libnotify.so:${PORTSDIR}/devel/libnotify
CLAWS_PLUGINS_BUILD= notification
diff --git a/mail/claws-mail-pdf_viewer/Makefile b/mail/claws-mail-pdf_viewer/Makefile
index fbebe6f1935e..336bfcd8b9d5 100644
--- a/mail/claws-mail-pdf_viewer/Makefile
+++ b/mail/claws-mail-pdf_viewer/Makefile
@@ -6,7 +6,7 @@ PORTREVISION= 0
COMMENT= PDF and PostScript viewer plugin for Claws Mail
-LIB_DEPENDS= poppler-glib:${PORTSDIR}/graphics/poppler-glib
+LIB_DEPENDS= libpoppler-glib.so:${PORTSDIR}/graphics/poppler-glib
USE_GHOSTSCRIPT=yes
diff --git a/mail/claws-mail-perl/Makefile b/mail/claws-mail-perl/Makefile
index b3618dfec2e0..854815a12df0 100644
--- a/mail/claws-mail-perl/Makefile
+++ b/mail/claws-mail-perl/Makefile
@@ -6,7 +6,7 @@ PORTREVISION= 0
COMMENT= Perl filtering plugin for Claws Mail
-USE_PERL5= yes
+USES+= perl5
PLIST_FILES+= share/claws-mail/matcherrc2perlfilter.pl
diff --git a/mail/claws-mail-pgp/Makefile b/mail/claws-mail-pgp/Makefile
index 89b495d092c4..5a5ac73811b4 100644
--- a/mail/claws-mail-pgp/Makefile
+++ b/mail/claws-mail-pgp/Makefile
@@ -6,7 +6,7 @@ PORTREVISION= 0
COMMENT= PGP plugins for Claws Mail
-LIB_DEPENDS= gpgme:${PORTSDIR}/security/gpgme
+LIB_DEPENDS= libgpgme.so:${PORTSDIR}/security/gpgme
CLAWS_PLUGINS_BUILD= pgpcore pgpinline pgpmime smime
diff --git a/mail/claws-mail/Makefile b/mail/claws-mail/Makefile
index f6de105c7ec7..714ef8edaa12 100644
--- a/mail/claws-mail/Makefile
+++ b/mail/claws-mail/Makefile
@@ -6,10 +6,10 @@ CATEGORIES= mail news ipv6
COMMENT= Lightweight and very featureful GTK+ based e-mail and news client
-LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo \
- etpan:${PORTSDIR}/mail/libetpan \
- gnutls:${PORTSDIR}/security/gnutls \
- gcrypt:${PORTSDIR}/security/libgcrypt
+LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
+ libetpan.so:${PORTSDIR}/mail/libetpan \
+ libgnutls.so:${PORTSDIR}/security/gnutls \
+ libgcrypt.so:${PORTSDIR}/security/libgcrypt
RUN_DEPENDS= ${LOCALBASE}/etc/mime.types:${PORTSDIR}/misc/mime-support
USE_GNOME= gtk20
@@ -32,17 +32,17 @@ THEMES_DESC= Additional themes
OPTIONS_DEFAULT= COMPFACE ENCHANT MANUAL STARTUP THEMES
COMPFACE_CONFIGURE_ENABLE= compface
-COMPFACE_LIB_DEPENDS= compface:${PORTSDIR}/mail/faces
+COMPFACE_LIB_DEPENDS= libcompface.so:${PORTSDIR}/mail/faces
DEBUG_CONFIGURE_ON= --enable-maintainer-mode
ENCHANT_CONFIGURE_ENABLE= enchant
-ENCHANT_LIB_DEPENDS= enchant:${PORTSDIR}/textproc/enchant
+ENCHANT_LIB_DEPENDS= libenchant.so:${PORTSDIR}/textproc/enchant
IPV6_CONFIGURE_ENABLE= ipv6
JPILOT_CONFIGURE_ENABLE= jpilot
-JPILOT_LIB_DEPENDS= pisock:${PORTSDIR}/palm/pilot-link
+JPILOT_LIB_DEPENDS= libpisock.so:${PORTSDIR}/palm/pilot-link
JPILOT_RUN_DEPENDS= jpilot:${PORTSDIR}/palm/jpilot
LDAP_CONFIGURE_ENABLE= ldap
@@ -55,7 +55,7 @@ NLS_CONFIGURE_OFF= --disable-nls
NLS_USES= gettext
STARTUP_CONFIGURE_ENABLE= startup-notification
-STARTUP_LIB_DEPENDS= startup-notification-1:${PORTSDIR}/x11/startup-notification
+STARTUP_LIB_DEPENDS= libstartup-notification-1.so:${PORTSDIR}/x11/startup-notification
THEMES_RUN_DEPENDS= ${LOCALBASE}/share/claws-mail/themes/ZX-0_1.1/down_arrow.xpm:${PORTSDIR}/x11-themes/claws-mail-themes
diff --git a/mail/claws-mail/Makefile.claws b/mail/claws-mail/Makefile.claws
index c7da62baf3c9..95bd7501959b 100644
--- a/mail/claws-mail/Makefile.claws
+++ b/mail/claws-mail/Makefile.claws
@@ -11,7 +11,6 @@ LICENSE= GPLv3
USE_BZIP2= yes
USES+= gmake
GNU_CONFIGURE= yes
-MAKE_JOBS_SAFE= yes
CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE} \
--disable-dbus
diff --git a/mail/clawsker/Makefile b/mail/clawsker/Makefile
index e25bbe4192cc..fb52dc8b4186 100644
--- a/mail/clawsker/Makefile
+++ b/mail/clawsker/Makefile
@@ -15,9 +15,8 @@ RUN_DEPENDS= claws-mail>=3.9.1:${PORTSDIR}/mail/claws-mail \
p5-Gtk2>=0:${PORTSDIR}/x11-toolkits/p5-Gtk2 \
p5-Locale-gettext>=0:${PORTSDIR}/devel/p5-Locale-gettext
-USES= shebangfix
+USES= shebangfix perl5
SHEBANG_FILES= ${PORTNAME}
-USE_PERL5= yes
MAN1= clawsker.1
PORTDOCS= NEWS README
diff --git a/mail/libetpan/Makefile b/mail/libetpan/Makefile
index 8d67befc581c..1e64426955bc 100644
--- a/mail/libetpan/Makefile
+++ b/mail/libetpan/Makefile
@@ -12,9 +12,9 @@ COMMENT= Mail framework for C language
LICENSE= BSD
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
- expat:${PORTSDIR}/textproc/expat2 \
- sasl2:${PORTSDIR}/security/cyrus-sasl2
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
+ libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
USE_AUTOTOOLS= libtool autoconf
AUTOTOOLSFILES= aclocal.m4
@@ -30,8 +30,8 @@ OPTIONS_SINGLE_CRYPTO= GNUTLS OPENSSL
OPTIONS_DEFAULT= OPENSSL
GNUTLS_CONFIGURE_ON= --without-openssl --with-gnutls
-GNUTLS_LIB_DEPENDS= gnutls:${PORTSDIR}/security/gnutls \
- gcrypt:${PORTSDIR}/security/libgcrypt
+GNUTLS_LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls \
+ libgcrypt.so:${PORTSDIR}/security/libgcrypt
IPV6_CONFIGURE_ENABLE= ipv6
diff --git a/multimedia/bombono/Makefile b/multimedia/bombono/Makefile
index 75a4e5f58ed1..82e6e95fc6f3 100644
--- a/multimedia/bombono/Makefile
+++ b/multimedia/bombono/Makefile
@@ -11,12 +11,12 @@ MAINTAINER= pawel@FreeBSD.org
COMMENT= DVD authoring program
BUILD_DEPENDS= GraphicsMagick>=1.1.7:${PORTSDIR}/graphics/GraphicsMagick
-LIB_DEPENDS= gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24 \
- xml++-2.6:${PORTSDIR}/textproc/libxml++26 \
- lavfile:${PORTSDIR}/multimedia/mjpegtools \
- dvdread:${PORTSDIR}/multimedia/libdvdread \
- avcodec:${PORTSDIR}/multimedia/ffmpeg \
- boost_filesystem:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= libgtkmm-2.4.so:${PORTSDIR}/x11-toolkits/gtkmm24 \
+ libxml++-2.6.so:${PORTSDIR}/textproc/libxml++26 \
+ liblavfile.so:${PORTSDIR}/multimedia/mjpegtools \
+ libdvdread.so:${PORTSDIR}/multimedia/libdvdread \
+ libavcodec.so:${PORTSDIR}/multimedia/ffmpeg \
+ libboost_filesystem.so:${PORTSDIR}/devel/boost-libs
RUN_DEPENDS= GraphicsMagick>=1.1.7:${PORTSDIR}/graphics/GraphicsMagick \
dvda-author:${PORTSDIR}/audio/dvda-author \
enca:${PORTSDIR}/converters/enca \
diff --git a/multimedia/lives/Makefile b/multimedia/lives/Makefile
index c47e403d38dc..1c048e0341d3 100644
--- a/multimedia/lives/Makefile
+++ b/multimedia/lives/Makefile
@@ -14,18 +14,18 @@ LICENSE= GPLv3
BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:${PORTSDIR}/multimedia/v4l_compat \
${LOCALBASE}/bin/analyseplugin:${PORTSDIR}/audio/ladspa
-LIB_DEPENDS= asound:${PORTSDIR}/audio/alsa-lib \
- jack:${PORTSDIR}/audio/jack \
- pulse:${PORTSDIR}/audio/pulseaudio \
- oil:${PORTSDIR}/devel/liboil \
- visual-0.4:${PORTSDIR}/graphics/libvisual04 \
- opencv_calib3d:${PORTSDIR}/graphics/opencv \
- fftw3:${PORTSDIR}/math/fftw3 \
- fftw3f:${PORTSDIR}/math/fftw3-float \
- avcodec:${PORTSDIR}/multimedia/ffmpeg \
- dv:${PORTSDIR}/multimedia/libdv \
- mjpegutils:${PORTSDIR}/multimedia/mjpegtools \
- schroedinger:${PORTSDIR}/multimedia/schroedinger
+LIB_DEPENDS= libasound.so:${PORTSDIR}/audio/alsa-lib \
+ libjack.so:${PORTSDIR}/audio/jack \
+ libpulse.so:${PORTSDIR}/audio/pulseaudio \
+ liboil-0.3.so:${PORTSDIR}/devel/liboil \
+ libvisual-0.4.so:${PORTSDIR}/graphics/libvisual04 \
+ libopencv_calib3d.so:${PORTSDIR}/graphics/opencv \
+ libfftw3.so:${PORTSDIR}/math/fftw3 \
+ libfftw3f.so:${PORTSDIR}/math/fftw3-float \
+ libavcodec.so:${PORTSDIR}/multimedia/ffmpeg \
+ libdv.so:${PORTSDIR}/multimedia/libdv \
+ libmjpegutils.so:${PORTSDIR}/multimedia/mjpegtools \
+ libschroedinger-1.0.so:${PORTSDIR}/multimedia/schroedinger
RUN_DEPENDS= ${LOCALBASE}/bin/analyseplugin:${PORTSDIR}/audio/ladspa \
mpg123:${PORTSDIR}/audio/mpg123 \
sox:${PORTSDIR}/audio/sox \
@@ -43,12 +43,11 @@ RUN_DEPENDS= ${LOCALBASE}/bin/analyseplugin:${PORTSDIR}/audio/ladspa \
WRKSRC= ${WRKDIR}/${DISTNAME:L}
-USES= pkgconfig
+USES= pkgconfig perl5
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_CSTD= gnu89
USE_PYTHON= yes
-USE_PERL5= yes
USE_GHOSTSCRIPT_RUN= yes
USE_GNOME= gtk20
USE_LDCONFIG= yes
diff --git a/polish/ekg/Makefile b/polish/ekg/Makefile
index 4b230d8bc1e6..15199f465db4 100644
--- a/polish/ekg/Makefile
+++ b/polish/ekg/Makefile
@@ -11,8 +11,8 @@ MASTER_SITES= http://ekg.chmurka.net/
MAINTAINER= pawel@FreeBSD.org
COMMENT= Text-mode Gadu-Gadu client
-LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo \
- gadu:${PORTSDIR}/polish/libgadu
+LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
+ libgadu.so:${PORTSDIR}/polish/libgadu
GNU_CONFIGURE= yes
USES= gmake pathfix pkgconfig
@@ -33,7 +33,7 @@ OPTIONS_DEFINE= ASPELL OPENSSL
OPTIONS_DEFAULT= OPENSSL
ASPELL_CONFIGURE_ON= --enable-aspell
-ASPELL_LIB_DEPENDS= aspell:${PORTSDIR}/polish/aspell
+ASPELL_LIB_DEPENDS= libaspell.so:${PORTSDIR}/polish/aspell
OPENSSL_CONFIGURE_OFF= --without-openssl
diff --git a/polish/ekg2/Makefile b/polish/ekg2/Makefile
index f96010a47966..89edf53289ab 100644
--- a/polish/ekg2/Makefile
+++ b/polish/ekg2/Makefile
@@ -11,8 +11,8 @@ MASTER_SITES= http://pl.ekg2.org/
MAINTAINER= pawel@FreeBSD.org
COMMENT= Text-mode Gadu-Gadu, Jabber, and IRC client
-LIB_DEPENDS= gadu.3:${PORTSDIR}/polish/libgadu \
- expat.6:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= libgadu.so:${PORTSDIR}/polish/libgadu \
+ libexpat.so:${PORTSDIR}/textproc/expat2
LICENSE= GPLv2
@@ -51,18 +51,18 @@ OPTIONS_DEFAULT=ASPELL
ASPELL_CONFIGURE_ON= --with-aspell
ASPELL_CONFIGURE_OFF= --without-aspell
-ASPELL_LIB_DEPENDS= aspell:${PORTSDIR}/textproc/aspell
+ASPELL_LIB_DEPENDS= libaspell.so:${PORTSDIR}/textproc/aspell
ASPELL_RUN_DEPENDS= ${LOCALBASE}/share/aspell/pl.rws:${PORTSDIR}/polish/aspell
GPG_CONFIGURE_ON= --with-gpg
GPG_CONFIGURE_OFF= --without-gpg
-GPG_LIB_DEPENDS= gpgme:${PORTSDIR}/security/gpgme \
- gpg-error:${PORTSDIR}/security/libgpg-error
+GPG_LIB_DEPENDS= libgpgme.so:${PORTSDIR}/security/gpgme \
+ libgpg-error.so:${PORTSDIR}/security/libgpg-error
GPG_RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg
GSM_CONFIGURE_ON= --with-libgsm
GSM_CONFIGURE_OFF= --without-libgsm
-GSM_LIB_DEPENDS= gsm:${PORTSDIR}/audio/gsm
+GSM_LIB_DEPENDS= libgsm.so:${PORTSDIR}/audio/gsm
GTK2_CONFIGURE_ON= --with-gtk
GTK2_CONFIGURE_OFF= --without-gtk
@@ -72,19 +72,20 @@ NLS_USES= gettext
PERL_CONFIGURE_ON= --with-perl
PERL_CONFIGURE_OFF= --without-perl
+PERL_USES= perl5
PYTHON_CONFIGURE_ON= --with-python
PYTHON_CONFIGURE_OFF= --without-python
SQLITE_CONFIGURE_ON= --with-sqlite3
SQLITE_CONFIGURE_OFF= --without-sqlite3
-SQLITE_LIB_DEPENDS= sqlite3:${PORTSDIR}/databases/sqlite3
+SQLITE_LIB_DEPENDS= libsqlite3.so:${PORTSDIR}/databases/sqlite3
UNICODE_CONFIGURE_ON= --enable-unicode
XOSD_CONFIGURE_ON= --with-libxosd
XOSD_CONFIGURE_OFF= --without-libxosd
-XOSD_LIB_DEPENDS= xosd:${PORTSDIR}/misc/xosd
+XOSD_LIB_DEPENDS= libxosd.so:${PORTSDIR}/misc/xosd
.include <bsd.port.options.mk>
@@ -92,10 +93,6 @@ XOSD_LIB_DEPENDS= xosd:${PORTSDIR}/misc/xosd
USE_GNOME+= gtk20
.endif
-.if ${PORT_OPTIONS:MPERL}
-USE_PERL5= yes
-.endif
-
.if ${PORT_OPTIONS:MPYTHON}
USE_PYTHON= yes
.endif
diff --git a/polish/kadu/Makefile b/polish/kadu/Makefile
index 70f9f4df36f8..db5d980b811e 100644
--- a/polish/kadu/Makefile
+++ b/polish/kadu/Makefile
@@ -21,19 +21,12 @@ LICENSE= GPLv2
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash \
pl-libgadu>=1.11.1:${PORTSDIR}/polish/libgadu
-LIB_DEPENDS= mpdclient:${PORTSDIR}/audio/libmpdclient \
- sndfile:${PORTSDIR}/audio/libsndfile \
- pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
- pcre:${PORTSDIR}/devel/pcre \
- qca:${PORTSDIR}/devel/qca \
- idn:${PORTSDIR}/dns/libidn \
- png15:${PORTSDIR}/graphics/png \
- gadu:${PORTSDIR}/polish/libgadu \
- freetype:${PORTSDIR}/print/freetype2 \
- qzeitgeist:${PORTSDIR}/sysutils/qzeitgeist \
- enchant:${PORTSDIR}/textproc/enchant \
- expat:${PORTSDIR}/textproc/expat2 \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig
+LIB_DEPENDS= libmpdclient.so:${PORTSDIR}/audio/libmpdclient \
+ libsndfile.so:${PORTSDIR}/audio/libsndfile \
+ libqca.so:${PORTSDIR}/devel/qca \
+ libidn.so:${PORTSDIR}/dns/libidn \
+ libgadu.so:${PORTSDIR}/polish/libgadu \
+ libenchant.so:${PORTSDIR}/textproc/enchant
RUN_DEPENDS= qca-ossl>=2.0.0.b3:${PORTSDIR}/security/qca-ossl
# TODO enable devel/libexecinfo
# TODO ntrack and ntrack-qt (needs porting) ?
@@ -43,15 +36,14 @@ GG6_EMOTS_DISTFILE= kompatybilne_z_GG6.tar.gz
GG7_EMOTS_DISTFILE= dodatkowe_emoty_GG7.tar.gz
USE_BZIP2= yes
-USES= cmake pkgconfig gettext iconv
-USE_XORG= ice sm x11 xau xcb xdmcp xext xfixes xrender xscrnsaver
+USES= cmake pkgconfig
+USE_XORG= xscrnsaver
CMAKE_ARGS= -DKADU_VERSION:STRING="${DISTVERSION}" -DWITH_ENCHANT=ON
# Setting KADU_VERSION disables git invocation
-USE_QT4= corelib dbus declarative gui network phonon qtestlib script \
- scripttools svg webkit xml xmlpatterns linguist_build \
- moc_build qmake_build rcc_build uic_build imageformats_run \
- sql-sqlite3_run
+USE_QT4= dbus gui network phonon script scripttools webkit xml \
+ linguist_build moc_build qmake_build rcc_build uic_build \
+ imageformats_run sql-sqlite3_run
WANT_GNOME= yes
INSTALLS_ICONS= yes
diff --git a/polish/qnapi/Makefile b/polish/qnapi/Makefile
index ece7a3ed8f1e..38c5436c64fa 100644
--- a/polish/qnapi/Makefile
+++ b/polish/qnapi/Makefile
@@ -12,16 +12,8 @@ COMMENT= Qt4 based subtitle downloader
LICENSE= GPLv2
-LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
- pcre:${PORTSDIR}/devel/pcre \
- png15:${PORTSDIR}/graphics/png \
- freetype:${PORTSDIR}/print/freetype2 \
- expat:${PORTSDIR}/textproc/expat2 \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig
RUN_DEPENDS= 7z:${PORTSDIR}/archivers/p7zip
-USES= gettext iconv
-USE_XORG= ice sm x11 xau xcb xdmcp xext xrender
USE_QT4= corelib gui network xml qmake_build moc_build uic_build rcc_build
USE_KDE4= kdehier
QMAKE_ARGS= PREFIX=${PREFIX} KDE4_PREFIX=${KDE4_PREFIX}
diff --git a/sysutils/gsmartcontrol/Makefile b/sysutils/gsmartcontrol/Makefile
index 9272ca09686f..2ff17d1157b9 100644
--- a/sysutils/gsmartcontrol/Makefile
+++ b/sysutils/gsmartcontrol/Makefile
@@ -10,28 +10,13 @@ MASTER_SITES= http://artificialtime.com/${PORTNAME}/
MAINTAINER= pawel@FreeBSD.org
COMMENT= Graphical user interface for smartmontools
-LIB_DEPENDS= atkmm-1.6:${PORTSDIR}/accessibility/atkmm \
- glibmm-2.4:${PORTSDIR}/devel/glibmm \
- pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
- sigc-2.0:${PORTSDIR}/devel/libsigc++20 \
- pcre:${PORTSDIR}/devel/pcre \
- cairo:${PORTSDIR}/graphics/cairo \
- cairomm-1.0:${PORTSDIR}/graphics/cairomm \
- png15:${PORTSDIR}/graphics/png \
- freetype:${PORTSDIR}/print/freetype2 \
- expat:${PORTSDIR}/textproc/expat2 \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
- gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24 \
- pangomm-1.4:${PORTSDIR}/x11-toolkits/pangomm
+LIB_DEPENDS= libgtkmm-2.4.so:${PORTSDIR}/x11-toolkits/gtkmm24
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
smartctl:${PORTSDIR}/sysutils/smartmontools
-USE_AUTOTOOLS= libtool
-USES= pkgconfig gettext iconv
USE_BZIP2= yes
-USE_GNOME= gtk20
-USE_XORG= pixman x11 xau xcb xcomposite xcursor xdamage xdmcp xext xfixes \
- xi xinerama xrandr xrender
+USE_AUTOTOOLS= libtool
+USES= pkgconfig
INSTALLS_ICONS= yes
MAN1= gsmartcontrol.1
diff --git a/www/netsurf/Makefile b/www/netsurf/Makefile
index 94c2d48f2fef..e52ed0520ccc 100644
--- a/www/netsurf/Makefile
+++ b/www/netsurf/Makefile
@@ -15,8 +15,8 @@ LICENSE= GPLv2 MIT
LICENSE_COMB= multi
BUILD_DEPENDS= flex:${PORTSDIR}/textproc/flex
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
- mng:${PORTSDIR}/graphics/libmng
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
+ libmng.so:${PORTSDIR}/graphics/libmng
ALL_TARGET= #empty
CFLAGS+= -I${LOCALBASE}/include
@@ -33,7 +33,7 @@ DESKTOP_ENTRIES="NetSurf" "${COMMENT}" "" "${PORTNAME}" "" "true"
OPTIONS_DEFINE= GSTREAMER WEBP
-WEBP_LIB_DEPENDS= webp:${PORTSDIR}/graphics/webp
+WEBP_LIB_DEPENDS= libwebp.so:${PORTSDIR}/graphics/webp
.include <bsd.port.options.mk>
diff --git a/x11-toolkits/termit/Makefile b/x11-toolkits/termit/Makefile
index aea5ef22f7e7..ba1515bae70f 100644
--- a/x11-toolkits/termit/Makefile
+++ b/x11-toolkits/termit/Makefile
@@ -12,19 +12,9 @@ COMMENT= Small terminal emulator
LICENSE= GPLv2
-LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
- pcre:${PORTSDIR}/devel/pcre \
- cairo:${PORTSDIR}/graphics/cairo \
- png15:${PORTSDIR}/graphics/png \
- freetype:${PORTSDIR}/print/freetype2 \
- expat:${PORTSDIR}/textproc/expat2 \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig
-
USE_BZIP2= yes
-USES= cmake pkgconfig iconv
+USES= cmake pkgconfig
USE_LUA= yes
-USE_XORG= pixman x11 xau xcb xcomposite xcursor xdamage xdmcp xext \
- xfixes xi xinerama xrandr xrender
USE_GNOME= gdkpixbuf2 vte
CFLAGS+= -I${LOCALBASE}/include/vte-0.0