aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/png2ico/Makefile27
-rw-r--r--graphics/png2ico/distinfo1
-rw-r--r--graphics/png2ico/files/patch-Makefile15
-rw-r--r--graphics/png2ico/pkg-comment1
-rw-r--r--graphics/png2ico/pkg-descr3
-rw-r--r--graphics/png2ico/pkg-plist1
7 files changed, 49 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index fcbcbd7154e9..9dcbde143039 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -294,6 +294,7 @@
SUBDIR += plotutils
SUBDIR += png
SUBDIR += png2html
+ SUBDIR += png2ico
SUBDIR += pngcheck
SUBDIR += pngcrush
SUBDIR += pngquant
diff --git a/graphics/png2ico/Makefile b/graphics/png2ico/Makefile
new file mode 100644
index 000000000000..9db37235a4c5
--- /dev/null
+++ b/graphics/png2ico/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: png2ico
+# Date created: 23 Sep 2002
+# Whom: Franz Klammer <klammer@webonaut.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= png2ico
+PORTVERSION= 2002.09.03
+CATEGORIES= graphics
+MASTER_SITES= http://www.winterdrache.de/freeware/png2ico/data/
+DISTNAME= ${PORTNAME}-src-${PORTVERSION:S/./-/g}
+
+MAINTAINER= klammer@webonaut.com
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+
+MAN1= png2ico.1
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_GMAKE= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/doc/png2ico.1 ${PREFIX}/man/man1/
+
+.include <bsd.port.mk>
diff --git a/graphics/png2ico/distinfo b/graphics/png2ico/distinfo
new file mode 100644
index 000000000000..515875dcf7ab
--- /dev/null
+++ b/graphics/png2ico/distinfo
@@ -0,0 +1 @@
+MD5 (png2ico-src-2002-09-03.tar.gz) = d592067920ba8711341ddc36e9aa3f53
diff --git a/graphics/png2ico/files/patch-Makefile b/graphics/png2ico/files/patch-Makefile
new file mode 100644
index 000000000000..380bb36c95f3
--- /dev/null
+++ b/graphics/png2ico/files/patch-Makefile
@@ -0,0 +1,15 @@
+--- Makefile.old Mon Sep 23 16:45:44 2002
++++ Makefile Mon Sep 23 16:45:51 2002
+@@ -1,10 +1,10 @@
+-CPPFLAGS=-W -Wall -O2
++CPPFLAGS=-W -Wall -O2 -I/usr/local/include -L/usr/local/lib -lpng
+ DEBUG=-g
+
+ all: png2ico
+
+ png2ico: png2ico.cpp
+- g++ $(CPPFLAGS) $(DEBUG) -o $@ $< -lpng
++ g++ $(CPPFLAGS) $(DEBUG) -o $@ $<
+
+ doc/png2ico.txt: doc/png2ico.1
+ man $< |sed -e $$'s/.\b\\(.\\)/\\1/g' -e 's/\(.*\)/\1'$$'\r/' >$@
diff --git a/graphics/png2ico/pkg-comment b/graphics/png2ico/pkg-comment
new file mode 100644
index 000000000000..3244e0b59d4f
--- /dev/null
+++ b/graphics/png2ico/pkg-comment
@@ -0,0 +1 @@
+Converts PNG files to Windows icon resource files
diff --git a/graphics/png2ico/pkg-descr b/graphics/png2ico/pkg-descr
new file mode 100644
index 000000000000..d7668cc5af43
--- /dev/null
+++ b/graphics/png2ico/pkg-descr
@@ -0,0 +1,3 @@
+Converts PNG files to Windows icon resource files.
+
+WWW: http://www.winterdrache.de/freeware/png2ico/index.html
diff --git a/graphics/png2ico/pkg-plist b/graphics/png2ico/pkg-plist
new file mode 100644
index 000000000000..27cbe2364976
--- /dev/null
+++ b/graphics/png2ico/pkg-plist
@@ -0,0 +1 @@
+bin/png2ico