aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--astro/gpsd/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/astro/gpsd/Makefile b/astro/gpsd/Makefile
index 1f56a2a5cbdd..1c1dc3462e08 100644
--- a/astro/gpsd/Makefile
+++ b/astro/gpsd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gpsd
PORTVERSION= 2.90
+PORTREVISION= 1
CATEGORIES= astro geography
MASTER_SITES= ${MASTER_SITE_BERLIOS}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -68,8 +69,11 @@ SUB_FILES= pkg-message
CONFIGURE_ARGS+=--disable-garmin
.if defined(WITH_XGPS)
+CONFIGURE_ENV+= CFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${X11BASE}/lib -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lm"
CONFIGURE_ARGS+=--with-x
-USE_XORG= x11
+USE_MOTIF= yes
+USE_XORG= x11 xpm xaw7
PLIST_SUB+= X11=""
.else
CONFIGURE_ARGS+=--without-x