aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-LockFile-Simple/Makefile23
-rw-r--r--devel/p5-LockFile-Simple/distinfo1
-rw-r--r--devel/p5-LockFile-Simple/pkg-comment1
-rw-r--r--devel/p5-LockFile-Simple/pkg-descr11
-rw-r--r--devel/p5-LockFile-Simple/pkg-plist9
6 files changed, 46 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 588fbca6b7a0..babdcabba233 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -252,6 +252,7 @@
SUBDIR += p5-Locale-Maketext
SUBDIR += p5-Locale-PGetText
SUBDIR += p5-Locale-gettext
+ SUBDIR += p5-LockFile-Simple
SUBDIR += p5-PV
SUBDIR += p5-Parse-RecDescent
SUBDIR += p5-Penguin
diff --git a/devel/p5-LockFile-Simple/Makefile b/devel/p5-LockFile-Simple/Makefile
new file mode 100644
index 000000000000..8e6113dc9ec2
--- /dev/null
+++ b/devel/p5-LockFile-Simple/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: LockFile-Simple
+# Date created: Wed Jan 3 14:54:51 2001
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= LockFile-Simple
+PORTVERSION= 0.2.5
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= LockFile
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= LockFile::Simple.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-LockFile-Simple/distinfo b/devel/p5-LockFile-Simple/distinfo
new file mode 100644
index 000000000000..efe5666e84fa
--- /dev/null
+++ b/devel/p5-LockFile-Simple/distinfo
@@ -0,0 +1 @@
+MD5 (LockFile-Simple-0.2.5.tar.gz) = acf9fd6f965789a42fa5314a4be0189d
diff --git a/devel/p5-LockFile-Simple/pkg-comment b/devel/p5-LockFile-Simple/pkg-comment
new file mode 100644
index 000000000000..501dd2bd8f0a
--- /dev/null
+++ b/devel/p5-LockFile-Simple/pkg-comment
@@ -0,0 +1 @@
+Perl module implementing simple file locking
diff --git a/devel/p5-LockFile-Simple/pkg-descr b/devel/p5-LockFile-Simple/pkg-descr
new file mode 100644
index 000000000000..3752d65d8b56
--- /dev/null
+++ b/devel/p5-LockFile-Simple/pkg-descr
@@ -0,0 +1,11 @@
+The LockFile::Simple extension provides simple file locking, of
+the advisory kind, i.e. it requires cooperation between applications
+wishing to lock the same files.
+
+It is meant to be used in quick-and-dirty scripts or more elaborated
+programs that want a simple locking scheme, yet with a reasonable
+level of configuration.
+
+Author: Raphael Manfredi <Raphael_Manfredi@pobox.com>
+
+--will
diff --git a/devel/p5-LockFile-Simple/pkg-plist b/devel/p5-LockFile-Simple/pkg-plist
new file mode 100644
index 000000000000..20c9ecb772bb
--- /dev/null
+++ b/devel/p5-LockFile-Simple/pkg-plist
@@ -0,0 +1,9 @@
+lib/perl5/site_perl/%%PERL_VER%%/LockFile/Lock.pm
+lib/perl5/site_perl/%%PERL_VER%%/LockFile/Lock/Simple.pm
+lib/perl5/site_perl/%%PERL_VER%%/LockFile/Manager.pm
+lib/perl5/site_perl/%%PERL_VER%%/LockFile/Simple.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/LockFile/Simple/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/LockFile/Simple
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/LockFile
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/LockFile/Lock
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/LockFile