aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dns/Makefile1
-rw-r--r--dns/sheerdns/Makefile23
-rw-r--r--dns/sheerdns/distinfo2
-rw-r--r--dns/sheerdns/files/patch-Makefile19
-rw-r--r--dns/sheerdns/pkg-descr8
5 files changed, 53 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index f6baa2cefffb..da6c733e4dda 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -62,6 +62,7 @@
SUBDIR += py-adns
SUBDIR += py-dns
SUBDIR += rbldnsd
+ SUBDIR += sheerdns
SUBDIR += skadns
SUBDIR += sleuth
SUBDIR += staticcharge
diff --git a/dns/sheerdns/Makefile b/dns/sheerdns/Makefile
new file mode 100644
index 000000000000..b6a7c90ee148
--- /dev/null
+++ b/dns/sheerdns/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: sheerdns
+# Date created: 26 May 2004
+# Whom: bkhl
+#
+# $FreeBSD$
+#
+
+PORTNAME= sheerdns
+PORTVERSION= 1.0.1
+CATEGORIES= dns
+MASTER_SITES= http://threading.2038bug.com/sheerdns/
+
+MAINTAINER= bkhl@elektrubadur.se
+COMMENT= A light-weight, simple and fast master DNS server
+
+USE_GMAKE= yes
+
+MAN8= sheerdns.8
+PLIST_FILES= sbin/sheerdns sbin/sheerdnshash
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/dns/sheerdns/distinfo b/dns/sheerdns/distinfo
new file mode 100644
index 000000000000..2c0fed287172
--- /dev/null
+++ b/dns/sheerdns/distinfo
@@ -0,0 +1,2 @@
+MD5 (sheerdns-1.0.1.tar.gz) = abe66eabbd519e620e4679a2dabd93f1
+SIZE (sheerdns-1.0.1.tar.gz) = 22335
diff --git a/dns/sheerdns/files/patch-Makefile b/dns/sheerdns/files/patch-Makefile
new file mode 100644
index 000000000000..4a8cb2eb90c5
--- /dev/null
+++ b/dns/sheerdns/files/patch-Makefile
@@ -0,0 +1,19 @@
+--- Makefile.orig Sat Apr 12 10:04:41 2003
++++ Makefile Wed Jun 2 21:10:14 2004
+@@ -1,5 +1,5 @@
+
+-CFLAGS=-Wall -g -O0 -ansi -pedantic
++CFLAGS+=-Wall -ansi -pedantic
+
+ SRCS=$(wildcard *.c)
+
+@@ -26,7 +26,6 @@
+ groff -Tps -mandoc sheerdns.8 > sheerdns.ps
+
+ install: all
+- install sheerdnshash sheerdns /usr/sbin/
+- install sheerdns.8 /usr/share/man/man8/
+- install sheerdns.8 /usr/man/man8/
++ install sheerdnshash sheerdns ${PREFIX}/sbin/
++ install sheerdns.8 ${MANPREFIX}/man/man8/
+
diff --git a/dns/sheerdns/pkg-descr b/dns/sheerdns/pkg-descr
new file mode 100644
index 000000000000..e68c65759be2
--- /dev/null
+++ b/dns/sheerdns/pkg-descr
@@ -0,0 +1,8 @@
+sheerdns is a master DNS server whose zone records are stored on a
+One-Record-Per-File bases. Because of this, sheerdns is the simplest of any DNS
+to configure, the easiest to update, and the most efficient for networks that
+experience a lot of updates (for example master servers for dynamic IP address
+ranges). You never have to restart sheerdns; any updates are available
+immediately without having to notify the sheerdns process.
+
+WWW: http://threading.2038bug.com/sheerdns/