aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/xournal/Makefile46
-rw-r--r--graphics/xournal/distinfo2
-rw-r--r--graphics/xournal/files/patch-Makefile.in31
-rw-r--r--graphics/xournal/pkg-descr13
-rw-r--r--graphics/xournal/pkg-plist57
6 files changed, 150 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index fa5be3e94321..5f2b8d024e79 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -1007,6 +1007,7 @@
SUBDIR += xmrm
SUBDIR += xnview
SUBDIR += xoris
+ SUBDIR += xournal
SUBDIR += xpaint
SUBDIR += xpdf
SUBDIR += xpx
diff --git a/graphics/xournal/Makefile b/graphics/xournal/Makefile
new file mode 100644
index 000000000000..777d60ffc8e0
--- /dev/null
+++ b/graphics/xournal/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: xournal
+# Date created: 21 Jan 2011
+# Whom: Jan Henrik Sylvester <me@janh.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xournal
+PORTVERSION= 0.4.5
+CATEGORIES= graphics
+MASTER_SITES= SF
+
+MAINTAINER= me@janh.de
+COMMENT= A notetaking application that can annotate PDFs
+
+LIB_DEPENDS= poppler-glib.5:${PORTSDIR}/graphics/poppler-gtk
+
+LICENSE= GPLv2
+
+MAKE_JOBS_SAFE= yes
+USE_GNOME= desktopfileutils libgnomecanvas
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --docdir="${DOCSDIR}"
+INSTALLS_ICONS= yes
+INSTALL_TARGET= install desktop-install
+
+OPTIONS= GHOSTSCRIPT "Install ghostscript (PS/PDF as bitmap bg)" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_GHOSTSCRIPT)
+USE_GHOSTSCRIPT_RUN= yes
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's|$$(DESTDIR)/usr/share/|$$(DESTDIR)$$$$desktopdir/|g' \
+ -e 's|/usr/local/share|"$$(datadir)"|' \
+ ${WRKSRC}/Makefile.in
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @(cd ${WRKSRC} && ${MAKE} install-doc-local)
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/xournal/distinfo b/graphics/xournal/distinfo
new file mode 100644
index 000000000000..399877a944c6
--- /dev/null
+++ b/graphics/xournal/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xournal-0.4.5.tar.gz) = a7d7c2cb544451939779276e6e5ee5acc756bd0efb5253de15dc00bfe07755d1
+SIZE (xournal-0.4.5.tar.gz) = 425062
diff --git a/graphics/xournal/files/patch-Makefile.in b/graphics/xournal/files/patch-Makefile.in
new file mode 100644
index 000000000000..b6d09ac58616
--- /dev/null
+++ b/graphics/xournal/files/patch-Makefile.in
@@ -0,0 +1,31 @@
+--- Makefile.in.orig 2011-01-31 16:28:59.925702117 +0100
++++ Makefile.in 2011-01-31 16:36:50.591377695 +0100
+@@ -709,19 +709,21 @@
+ fi \
+ done \
+ fi; \
++ echo "*** Desktop files, icons, MIME types not installed. Run 'make desktop-install'"; \
++ echo "*** (or 'make home-desktop-install' for installation in a home directory)."
++
++install-doc-local:
+ if test -d $(srcdir)/html-doc; then \
+- $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/html-doc; \
++ $(mkinstalldirs) $(DESTDIR)$(docdir); \
+ for docfile in $(srcdir)/html-doc/*; do \
+ if test -f $$docfile; then \
+- $(INSTALL_DATA) $$docfile $(DESTDIR)$(pkgdatadir)/html-doc; \
++ $(INSTALL_DATA) $$docfile $(DESTDIR)$(docdir); \
+ fi \
+ done; \
+- if test ! -e $(DESTDIR)$(pkgdatadir)/html-doc/pixmaps; then \
+- ln -s ../pixmaps $(DESTDIR)$(pkgdatadir)/html-doc/pixmaps; \
++ if test ! -e $(DESTDIR)$(docdir)/pixmaps; then \
++ ln -s $(DESTDIR)$(pkgdatadir)/pixmaps $(DESTDIR)$(docdir)/pixmaps; \
+ fi \
+- fi; \
+- echo "*** Desktop files, icons, MIME types not installed. Run 'make desktop-install'"; \
+- echo "*** (or 'make home-desktop-install' for installation in a home directory)."
++ fi
+
+ desktop-install:
+ if test "$(datadir)" = "/usr/share"; then \
diff --git a/graphics/xournal/pkg-descr b/graphics/xournal/pkg-descr
new file mode 100644
index 000000000000..389a059f3f95
--- /dev/null
+++ b/graphics/xournal/pkg-descr
@@ -0,0 +1,13 @@
+Xournal is an application for notetaking, sketching, keeping a journal using a
+stylus. It is similar to Microsoft Windows Journal or to other alternatives such
+as Jarnal, Gournal, and NoteLab.
+
+Xournal aims to provide superior graphical quality (subpixel resolution) and
+overall functionality; however it lacks the collaborative features of Jarnal.
+Since Xournal is still in its early development stages, it may not be fully
+stable, and some features have not been implemented yet.
+
+Xournal supports annotation of PDF files through the Poppler library; PDF files,
+much like paper styles, are loaded as an immutable background image.
+
+WWW: http://xournal.sourceforge.net
diff --git a/graphics/xournal/pkg-plist b/graphics/xournal/pkg-plist
new file mode 100644
index 000000000000..c4ff3b0c691f
--- /dev/null
+++ b/graphics/xournal/pkg-plist
@@ -0,0 +1,57 @@
+bin/xournal
+share/applications/xournal.desktop
+share/icons/hicolor/scalable/apps/xournal.svg
+share/icons/hicolor/scalable/mimetypes/gnome-mime-application-x-xoj.svg
+share/icons/hicolor/scalable/mimetypes/xoj.svg
+share/mime/packages/xournal.xml
+share/mimelnk/application/x-xoj.desktop
+%%PORTDOCS%%%%DOCSDIR%%/manual.html
+%%PORTDOCS%%%%DOCSDIR%%/pixmaps
+%%PORTDOCS%%%%DOCSDIR%%/screenshot.png
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+share/xournal/pixmaps/black.png
+share/xournal/pixmaps/blue.png
+share/xournal/pixmaps/default-pen.png
+share/xournal/pixmaps/eraser.png
+share/xournal/pixmaps/fullscreen.png
+share/xournal/pixmaps/gray.png
+share/xournal/pixmaps/green.png
+share/xournal/pixmaps/hand.png
+share/xournal/pixmaps/highlighter.png
+share/xournal/pixmaps/lasso.png
+share/xournal/pixmaps/lightblue.png
+share/xournal/pixmaps/lightgreen.png
+share/xournal/pixmaps/magenta.png
+share/xournal/pixmaps/medium.png
+share/xournal/pixmaps/orange.png
+share/xournal/pixmaps/pencil.png
+share/xournal/pixmaps/rect-select.png
+share/xournal/pixmaps/recycled.png
+share/xournal/pixmaps/red.png
+share/xournal/pixmaps/ruler.png
+share/xournal/pixmaps/shapes.png
+share/xournal/pixmaps/stretch.png
+share/xournal/pixmaps/text-tool.png
+share/xournal/pixmaps/thick.png
+share/xournal/pixmaps/thin.png
+share/xournal/pixmaps/white.png
+share/xournal/pixmaps/xoj.svg
+share/xournal/pixmaps/xournal.png
+share/xournal/pixmaps/xournal.svg
+share/xournal/pixmaps/yellow.png
+@dirrm share/xournal/pixmaps
+@dirrm share/xournal
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@exec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
+@unexec %%LOCALBASE%%/bin/update-mime-database %D/share/mime
+@dirrmtry share/mimelnk/application
+@dirrmtry share/mimelnk
+@dirrmtry share/mime/packages
+@dirrmtry share/mime
+@dirrmtry share/icons/hicolor/scalable/mimetypes
+@dirrmtry share/icons/hicolor/scalable/apps
+@dirrmtry share/icons/hicolor/scalable
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrmtry share/applications