aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dns/c-ares/Makefile23
-rw-r--r--dns/c-ares/files/patch-Makefile.in16
-rw-r--r--dns/c-ares/pkg-plist4
-rw-r--r--ftp/curl/Makefile2
-rw-r--r--irc/ircproxy/Makefile2
-rw-r--r--irc/unreal/Makefile2
-rw-r--r--mail/greylite/Makefile2
-rw-r--r--net-mgmt/xymon-server/Makefile2
-rw-r--r--net/ecore-con/Makefile1
-rw-r--r--net/mosquitto/Makefile1
-rw-r--r--net/tshark/Makefile2
-rw-r--r--net/wireshark/Makefile2
-rw-r--r--security/sssd/Makefile2
13 files changed, 22 insertions, 39 deletions
diff --git a/dns/c-ares/Makefile b/dns/c-ares/Makefile
index ebbc11cc1b9f..be13a0b7a345 100644
--- a/dns/c-ares/Makefile
+++ b/dns/c-ares/Makefile
@@ -3,6 +3,7 @@
PORTNAME= c-ares
PORTVERSION= 1.10.0
+PORTREVISION= 1
CATEGORIES= dns
MASTER_SITES= http://c-ares.haxx.se/download/ \
http://obsd.isc.org/pub/OpenBSD/distfiles/ \
@@ -13,7 +14,14 @@ COMMENT= Asynchronous DNS resolver library
LICENSE= MIT
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-werror
+INSTALL_TARGET= install-strip
SSP_UNSAFE= Refuses -l in LDFLAGS
+USES= libtool pathfix
+USE_LDCONFIG= yes
+
+PROGRAMS= acountry adig ahost
OPTIONS_DEFINE= CONFIG_INFO DEBUG HIDE_SYMBOLS OPTIMIZED_CFLAGS
OPTIONS_DEFAULT= CONFIG_INFO HIDE_SYMBOLS
@@ -26,7 +34,7 @@ CONFLICTS= ares-1.*
MAKE_JOBS_UNSAFE= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCONFIG_INFO}
EXTRA_PATCHES+= ${FILESDIR}/ares-config-info.patch
@@ -51,18 +59,7 @@ CONFIGURE_ARGS+=--enable-optimize
CONFIGURE_ARGS+=--disable-optimize
.endif
-USE_LDCONFIG= yes
-SHLIB_VER= 3
-
-MAKE_ENV= SHLIB_VER="${SHLIB_VER}"
-PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
-
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--enable-shared --disable-werror
-
-PROGRAMS= acountry adig ahost
-
post-install:
${INSTALL_PROGRAM} ${PROGRAMS:S@^@${WRKSRC}/.libs/@} ${STAGEDIR}${PREFIX}/bin/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/dns/c-ares/files/patch-Makefile.in b/dns/c-ares/files/patch-Makefile.in
deleted file mode 100644
index be3b6ae37ce8..000000000000
--- a/dns/c-ares/files/patch-Makefile.in
+++ /dev/null
@@ -1,16 +0,0 @@
-Description: Place the pkgconfig file in the correct directory on FreeBSD.
-Author: Peter Pentchev <roam@FreeBSD.org>
-Forwarded: not-needed
-Last-Update: 2010-12-19
-
---- Makefile.in.orig
-+++ Makefile.in
-@@ -322,7 +322,7 @@
-
- CLEANFILES = $(PDFPAGES) $(HTMLPAGES)
- DISTCLEANFILES = ares_build.h
--pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfigdir = $(prefix)/libdata/pkgconfig
- pkgconfig_DATA = libcares.pc
- VER = -version-info 2:0:0
- # This flag accepts an argument of the form current[:revision[:age]]. So,
diff --git a/dns/c-ares/pkg-plist b/dns/c-ares/pkg-plist
index 97ea8d440b22..88eb5ccd0347 100644
--- a/dns/c-ares/pkg-plist
+++ b/dns/c-ares/pkg-plist
@@ -7,9 +7,9 @@ include/ares_rules.h
include/ares_dns.h
include/ares_version.h
lib/libcares.a
-lib/libcares.la
lib/libcares.so
-lib/libcares.so.%%SHLIB_VER%%
+lib/libcares.so.2
+lib/libcares.so.2.1.0
libdata/pkgconfig/libcares.pc
man/man3/ares_cancel.3.gz
man/man3/ares_create_query.3.gz
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 6e71ef11c2ec..bbcaff38f720 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= curl
PORTVERSION= 7.37.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= ftp www
MASTER_SITES= http://curl.haxx.se/download/ \
LOCAL/sunpoet
diff --git a/irc/ircproxy/Makefile b/irc/ircproxy/Makefile
index e71d676288e7..d618a3007492 100644
--- a/irc/ircproxy/Makefile
+++ b/irc/ircproxy/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ircproxy
PORTVERSION= 1.3.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= irc
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
diff --git a/irc/unreal/Makefile b/irc/unreal/Makefile
index 6b7007e12648..c2505a059d0d 100644
--- a/irc/unreal/Makefile
+++ b/irc/unreal/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Unreal
PORTVERSION= 3.2.10.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= irc ipv6
MASTER_SITES= http://www.unrealircd.com/downloads/
DISTNAME= ${PORTNAME}${PORTVERSION}
diff --git a/mail/greylite/Makefile b/mail/greylite/Makefile
index cdeae7a69ba0..bc476b120db6 100644
--- a/mail/greylite/Makefile
+++ b/mail/greylite/Makefile
@@ -3,7 +3,7 @@
PORTNAME= greylite
PORTVERSION= 2.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= mail
MASTER_SITES= http://mij.oltrelinux.com/net/greylite/releases/
diff --git a/net-mgmt/xymon-server/Makefile b/net-mgmt/xymon-server/Makefile
index 39a5f433bdaa..f4b115baaa68 100644
--- a/net-mgmt/xymon-server/Makefile
+++ b/net-mgmt/xymon-server/Makefile
@@ -2,7 +2,7 @@
PORTNAME= xymon
PORTVERSION= 4.3.17
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-mgmt www
MASTER_SITES= SF/xymon/Xymon/${PORTVERSION}
PKGNAMESUFFIX= -server${PKGNAMESUFFIX2}
diff --git a/net/ecore-con/Makefile b/net/ecore-con/Makefile
index db040edcc4cb..a98303c0d5f7 100644
--- a/net/ecore-con/Makefile
+++ b/net/ecore-con/Makefile
@@ -3,6 +3,7 @@
PORTNAME= con
PORTVERSION= 1.7.9
+PORTREVISION= 1
CATEGORIES= net enlightenment
MASTER_SITES= http://download.enlightenment.org/releases/ \
LOCAL/gblach/e17/
diff --git a/net/mosquitto/Makefile b/net/mosquitto/Makefile
index 40e506ec104e..9f022717d696 100644
--- a/net/mosquitto/Makefile
+++ b/net/mosquitto/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mosquitto
PORTVERSION= 1.3.2
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://mosquitto.org/files/source/
diff --git a/net/tshark/Makefile b/net/tshark/Makefile
index 00067a2c313e..a98333d6adbb 100644
--- a/net/tshark/Makefile
+++ b/net/tshark/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= tshark
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTERDIR= ${.CURDIR}/../wireshark
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index 61e0936a7dce..7d588d0624f8 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= wireshark
PORTVERSION= 1.12.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net ipv6
MASTER_SITES= http://www.wireshark.org/download/src/ \
http://ftp.uni-kl.de/pub/wireshark/src/ \
diff --git a/security/sssd/Makefile b/security/sssd/Makefile
index f3533700eb52..9769d583c4e5 100644
--- a/security/sssd/Makefile
+++ b/security/sssd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= sssd
DISTVERSION= 1.9.6
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= security
MASTER_SITES= https://fedorahosted.org/released/${PORTNAME}/ \
http://mirrors.rit.edu/zi/