aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-cookiejar/Makefile20
-rw-r--r--www/rubygem-cookiejar/distinfo2
-rw-r--r--www/rubygem-cookiejar/pkg-descr9
4 files changed, 32 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index be1f77547699..2580c6633438 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1666,6 +1666,7 @@
SUBDIR += rubygem-cgi_multipart_eof_fix
SUBDIR += rubygem-chef-server-api
SUBDIR += rubygem-chef-server-webui
+ SUBDIR += rubygem-cookiejar
SUBDIR += rubygem-cuba
SUBDIR += rubygem-davclient
SUBDIR += rubygem-domainatrix
diff --git a/www/rubygem-cookiejar/Makefile b/www/rubygem-cookiejar/Makefile
new file mode 100644
index 000000000000..bf1ef09fb23b
--- /dev/null
+++ b/www/rubygem-cookiejar/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: rubygem-cookiejar
+# Date created: 2012-06-10
+# Whom: TAKATSU Tomonari <tota@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cookiejar
+PORTVERSION= 0.3.0
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= Allows for parsing and returning cookies in Ruby HTTP client code
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-cookiejar/distinfo b/www/rubygem-cookiejar/distinfo
new file mode 100644
index 000000000000..07143795594e
--- /dev/null
+++ b/www/rubygem-cookiejar/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/cookiejar-0.3.0.gem) = f783b8eb981da58db1cb38f8a49781eefd1b84af2b8b7f3d7755cbe8c9460c3f
+SIZE (rubygem/cookiejar-0.3.0.gem) = 16896
diff --git a/www/rubygem-cookiejar/pkg-descr b/www/rubygem-cookiejar/pkg-descr
new file mode 100644
index 000000000000..d357d2916d9b
--- /dev/null
+++ b/www/rubygem-cookiejar/pkg-descr
@@ -0,0 +1,9 @@
+The Ruby CookieJar is a library to help manage client-side cookies
+in pure Ruby. It enables parsing and setting of cookie headers,
+alternating between multiple 'jars' of cookies at one time (such
+as having a set of cookies for each browser or thread), and supports
+persistence of the cookies in a JSON string.
+
+Both Netscape/RFC 2109 cookies and RFC 2965 cookies are supported.
+
+WWW: https://github.com/dwaite/cookiejar