aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/putty/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/security/putty/Makefile b/security/putty/Makefile
index 7ac47a5382ad..692d324cbe72 100644
--- a/security/putty/Makefile
+++ b/security/putty/Makefile
@@ -16,6 +16,7 @@ MAINTAINER= dinoex@FreeBSD.org
COMMENT= Secure shell and telnet client
USE_GMAKE= yes
+USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/unix
MAKEFILE= Makefile.gtk
CFLAGS+= -DBSD_PTYS -DOMIT_UTMP
@@ -33,6 +34,9 @@ MAN1+= pterm.1 putty.1 puttygen.1 puttytel.1
MAKE_ENV+= PUTTY_WITH_GTK=yes
.endif
+post-patch:
+ ${REINPLACE_CMD} -e 's,gtk-config,${GTK_CONFIG},' ${WRKSRC}/${MAKEFILE}
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000