aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/hgsvn/Makefile22
-rw-r--r--devel/hgsvn/distinfo3
-rw-r--r--devel/hgsvn/pkg-descr17
-rw-r--r--devel/hgsvn/pkg-plist3
5 files changed, 46 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1310d4984935..e19bca52f4ca 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -440,6 +440,7 @@
SUBDIR += happydoc
SUBDIR += hapy
SUBDIR += hc12mem
+ SUBDIR += hgsvn
SUBDIR += highlighterkit
SUBDIR += horde-chora
SUBDIR += hp48cc
diff --git a/devel/hgsvn/Makefile b/devel/hgsvn/Makefile
new file mode 100644
index 000000000000..7f3d8fb5cd3d
--- /dev/null
+++ b/devel/hgsvn/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: py-hgsvn
+# Date created: 2007-12-12
+# Whom: Xin LI <delphij@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hgsvn
+PORTVERSION= 0.1.4
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= delphij@FreeBSD.org
+COMMENT= A set of scripts to work locally on Subversion checkouts using Mercurial
+
+DIST_SUBDIR= python
+USE_PYTHON= 2.5+
+USE_PYDISTUTILS=yes
+PLIST_SUB= VERSION=${PORTVERSION} PYVER=${PYTHON_VERSION:S/python//}
+
+.include <bsd.port.mk>
diff --git a/devel/hgsvn/distinfo b/devel/hgsvn/distinfo
new file mode 100644
index 000000000000..d125bded5fb8
--- /dev/null
+++ b/devel/hgsvn/distinfo
@@ -0,0 +1,3 @@
+MD5 (python/hgsvn-0.1.4.tar.gz) = 22f32a681751127475de6914a7c4c058
+SHA256 (python/hgsvn-0.1.4.tar.gz) = a5ef9c38eef1da3afbdbe65515e68ba4e63a31425df09dc36581fcf246e698ac
+SIZE (python/hgsvn-0.1.4.tar.gz) = 37652
diff --git a/devel/hgsvn/pkg-descr b/devel/hgsvn/pkg-descr
new file mode 100644
index 000000000000..c7e03dcf2d3d
--- /dev/null
+++ b/devel/hgsvn/pkg-descr
@@ -0,0 +1,17 @@
+This set of scripts allows to work locally on Subversion-managed
+projects using the Mercurial distributed version control system.
+
+Why use Mercurial? You can do local (disconnected) work, pull the
+latest changes from the SVN server, manage private branches, submit
+patches to project maintainers, etc. And of course you have fast
+local operations like "hg log", "hg annotate"...
+
+Currenly two scripts are provided:
+
+ * hgimportsvn initializes an SVN checkout which is also a
+ Mercurial repository.
+ * hgpullsvn pulls the latest changes from the SVN repository,
+ and updates the Mercurial repository accordingly. It can
+ be run multiple times.
+
+WWW: http://cheeseshop.python.org/pypi/hgsvn
diff --git a/devel/hgsvn/pkg-plist b/devel/hgsvn/pkg-plist
new file mode 100644
index 000000000000..71b2663509c4
--- /dev/null
+++ b/devel/hgsvn/pkg-plist
@@ -0,0 +1,3 @@
+bin/hgimportsvn
+bin/hgpullsvn
+%%PYTHON_SITELIBDIR%%/hgsvn-%%VERSION%%-py%%PYVER%%.egg