aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/fampp/Makefile4
-rw-r--r--devel/ruby-fam/Makefile4
-rw-r--r--mail/courier/Makefile5
-rw-r--r--mail/gnubiff/Makefile5
-rw-r--r--sysutils/fileschanged/Makefile3
5 files changed, 12 insertions, 9 deletions
diff --git a/devel/fampp/Makefile b/devel/fampp/Makefile
index 25caedc271bd..4e43bafc4d50 100644
--- a/devel/fampp/Makefile
+++ b/devel/fampp/Makefile
@@ -14,13 +14,13 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A C++ wrapper for fam from SGI
-LIB_DEPENDS= fam.0:${PORTSDIR}/devel/fam
-
# This isn't required to utilize full functionality
#USE_GNOME= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
NO_BUILD= yes
+USE_FAM= yes
+WANT_FAM_SYSTEM=fam
do-install:
.for FILE in FamppEvents.hh FamppExceptions.hh fam.hh famStatic.hh handle.hh
diff --git a/devel/ruby-fam/Makefile b/devel/ruby-fam/Makefile
index dbde615b7181..e96fc8b274fb 100644
--- a/devel/ruby-fam/Makefile
+++ b/devel/ruby-fam/Makefile
@@ -16,10 +16,10 @@ DIST_SUBDIR= ruby
MAINTAINER= ports@FreeBSD.org
COMMENT= FAM bindings for Ruby
-LIB_DEPENDS= fam.0:${PORTSDIR}/devel/fam
-
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
+USE_FAM= yes
+WANT_FAM_SYSTEM=fam
INSTALL_TARGET= site-install
diff --git a/mail/courier/Makefile b/mail/courier/Makefile
index 7f3d354c7106..a229a3904182 100644
--- a/mail/courier/Makefile
+++ b/mail/courier/Makefile
@@ -15,8 +15,7 @@ MAINTAINER= yds@CoolRat.org
COMMENT= Courier SMTP IMAP POP3 HTTP mail server suite
BUILD_DEPENDS= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
-LIB_DEPENDS= fam:${PORTSDIR}/devel/fam \
- pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
RUN_DEPENDS= courierauthconfig:${PORTSDIR}/security/courier-authlib-base \
${LOCALBASE}/share/sysconftool/sysconftool:${PORTSDIR}/devel/sysconftool \
${LOCALBASE}/etc/mime.types:${PORTSDIR}/misc/mime-support \
@@ -68,6 +67,8 @@ USE_GMAKE= yes
USE_OPENSSL= yes
USE_REINPLACE= yes
USE_AUTOTOOLS= libtool:15
+USE_FAM= yes
+WANT_FAM_SYSTEM=fam
.if defined(WITH_RCORDER)
USE_RCORDER= courier.sh
diff --git a/mail/gnubiff/Makefile b/mail/gnubiff/Makefile
index 165ae5f55001..b47c2ae30c68 100644
--- a/mail/gnubiff/Makefile
+++ b/mail/gnubiff/Makefile
@@ -14,12 +14,13 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= tdb@FreeBSD.org
COMMENT= A mail notification program for Gnome
-LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
- fam.0:${PORTSDIR}/devel/fam
+LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
USE_X_PREFIX= yes
USE_GNOME= intlhack libglade2 esound
USE_GMAKE= yes
+USE_FAM= yes
+WANT_FAM_SYSTEM=fam
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
diff --git a/sysutils/fileschanged/Makefile b/sysutils/fileschanged/Makefile
index c4cdc5523fa3..de02842b911a 100644
--- a/sysutils/fileschanged/Makefile
+++ b/sysutils/fileschanged/Makefile
@@ -15,12 +15,13 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Utility that reports when files have been altered
-LIB_DEPENDS= fam.0:${PORTSDIR}/devel/fam
BUILD_DEPENDS= ${LOCALBASE}/include/argp.h:${PORTSDIR}/devel/argp-standalone \
help2man:${PORTSDIR}/misc/help2man
GNU_CONFIGURE= yes
USE_GMAKE= yes
+USE_FAM= yes
+WANT_FAM_SYSTEM=fam
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib" \
LIBS="-largp"
CONFIGURE_ARGS+=--datadir=${PREFIX}/share/doc