aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/php52-xmlrpc/Makefile14
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/php52-wddx/files/patch-config.m422
-rw-r--r--textproc/php52-wddx/files/patch-wddx.c40
-rw-r--r--textproc/php52-xsl/Makefile14
-rw-r--r--textproc/php52-xsl/files/patch-php_xsl.h11
7 files changed, 103 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 4966ab518475..2c39c16fcfe4 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -773,6 +773,7 @@
SUBDIR += php52-ldap
SUBDIR += php52-soap
SUBDIR += php52-sockets
+ SUBDIR += php52-xmlrpc
SUBDIR += phpldapadmin
SUBDIR += phpldapadmin098
SUBDIR += pimdd
diff --git a/net/php52-xmlrpc/Makefile b/net/php52-xmlrpc/Makefile
new file mode 100644
index 000000000000..46fc5a3cf531
--- /dev/null
+++ b/net/php52-xmlrpc/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php52-xmlrpc
+# Date created: 17 Apr 2010
+# Whom: Alex Keda <admin@lissyara.su>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= net
+
+MASTERDIR= ${.CURDIR}/../../lang/php52
+
+PKGNAMESUFFIX= -xmlrpc
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/Makefile b/textproc/Makefile
index 180ca20cdb6a..b7cbf8c55131 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -942,6 +942,7 @@
SUBDIR += php52-xml
SUBDIR += php52-xmlreader
SUBDIR += php52-xmlwriter
+ SUBDIR += php52-xsl
SUBDIR += po4a
SUBDIR += pocketreader
SUBDIR += pootle
diff --git a/textproc/php52-wddx/files/patch-config.m4 b/textproc/php52-wddx/files/patch-config.m4
new file mode 100644
index 000000000000..08787003b8f9
--- /dev/null
+++ b/textproc/php52-wddx/files/patch-config.m4
@@ -0,0 +1,22 @@
+--- config.m4.orig Mon Jul 26 09:05:10 2004
++++ config.m4 Mon Jul 26 09:07:46 2004
+@@ -5,6 +5,9 @@
+ PHP_ARG_ENABLE(wddx,whether to enable WDDX support,
+ [ --enable-wddx Enable WDDX support.])
+
++PHP_ARG_WITH(libxml-dir, libxml2 install dir,
++[ --with-libxml-dir=<DIR> WDDX: libxml2 install prefix], no, no)
++
+ if test "$PHP_WDDX" != "no"; then
+ if test "$ext_shared" != "yes" && test "$enable_xml" = "no"; then
+ AC_MSG_WARN(Activating XML)
+@@ -12,4 +15,9 @@
+ fi
+ AC_DEFINE(HAVE_WDDX, 1, [ ])
+ PHP_NEW_EXTENSION(wddx, wddx.c, $ext_shared)
++
++ PHP_SETUP_LIBXML(WDDX_SHARED_LIBADD, [
++ ], [
++ AC_MSG_ERROR([xml2-config not found. Please check your libxml2 installation.])
++ ])
+ fi
diff --git a/textproc/php52-wddx/files/patch-wddx.c b/textproc/php52-wddx/files/patch-wddx.c
new file mode 100644
index 000000000000..a8a6a79fe47f
--- /dev/null
+++ b/textproc/php52-wddx/files/patch-wddx.c
@@ -0,0 +1,40 @@
+--- wddx.c.orig Sun Jan 1 13:50:16 2006
++++ wddx.c Mon Jan 16 12:56:21 2006
+@@ -18,6 +18,10 @@
+
+ /* $Id: wddx.c,v 1.119.2.8 2006/01/01 12:50:16 sniper Exp $ */
+
++#ifdef HAVE_CONFIG_H
++# include "config.h"
++#endif
++
+ #include "php.h"
+
+ #if HAVE_WDDX
+@@ -223,7 +227,7 @@
+
+ #include "ext/session/php_session.h"
+
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ /* {{{ PS_SERIALIZER_ENCODE_FUNC
+ */
+ PS_SERIALIZER_ENCODE_FUNC(wddx)
+@@ -302,7 +306,7 @@
+ {
+ le_wddx = zend_register_list_destructors_ex(release_wddx_packet_rsrc, NULL, "wddx", module_number);
+
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ php_session_register_serializer("wddx",
+ PS_SERIALIZER_ENCODE_NAME(wddx),
+ PS_SERIALIZER_DECODE_NAME(wddx));
+@@ -317,7 +321,7 @@
+ PHP_MINFO_FUNCTION(wddx)
+ {
+ php_info_print_table_start();
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ php_info_print_table_header(2, "WDDX Support", "enabled" );
+ php_info_print_table_row(2, "WDDX Session Serializer", "enabled" );
+ #else
diff --git a/textproc/php52-xsl/Makefile b/textproc/php52-xsl/Makefile
new file mode 100644
index 000000000000..e7c35e59ea18
--- /dev/null
+++ b/textproc/php52-xsl/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php52-xsl
+# Date created: 17 Apr 2010
+# Whom: Alex Keda <admin@lissyara.su>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php52
+
+PKGNAMESUFFIX= -xsl
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php52-xsl/files/patch-php_xsl.h b/textproc/php52-xsl/files/patch-php_xsl.h
new file mode 100644
index 000000000000..9777187f8748
--- /dev/null
+++ b/textproc/php52-xsl/files/patch-php_xsl.h
@@ -0,0 +1,11 @@
+--- php_xsl.h.orig Sun Jan 1 13:50:17 2006
++++ php_xsl.h Tue Jan 17 16:23:10 2006
+@@ -43,7 +43,7 @@
+ #include <libexslt/exsltconfig.h>
+ #endif
+
+-#include "../dom/xml_common.h"
++#include "ext/dom/xml_common.h"
+ #include "xsl_fe.h"
+
+ #include <libxslt/extensions.h>