aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--comms/libticables2/Makefile36
-rw-r--r--comms/libticables2/distinfo4
-rw-r--r--comms/libticables2/pkg-descr2
-rw-r--r--comms/libticables2/pkg-plist3
-rw-r--r--comms/libticalcs2/Makefile39
-rw-r--r--comms/libticalcs2/distinfo4
-rw-r--r--comms/libticalcs2/pkg-descr3
-rw-r--r--comms/libticalcs2/pkg-plist12
-rw-r--r--comms/tilp2/Makefile46
-rw-r--r--comms/tilp2/distinfo4
-rw-r--r--comms/tilp2/pkg-plist31
-rw-r--r--converters/libticonv/Makefile18
-rw-r--r--converters/libticonv/distinfo4
-rw-r--r--converters/libticonv/pkg-descr3
-rw-r--r--converters/libticonv/pkg-plist3
-rw-r--r--devel/libtifiles2/Makefile37
-rw-r--r--devel/libtifiles2/distinfo4
-rw-r--r--devel/libtifiles2/pkg-descr3
-rw-r--r--devel/libtifiles2/pkg-plist3
-rw-r--r--emulators/tiemu3/Makefile14
-rw-r--r--emulators/tilem/Makefile7
21 files changed, 136 insertions, 144 deletions
diff --git a/comms/libticables2/Makefile b/comms/libticables2/Makefile
index f60a3ad155c1..cef175711bfc 100644
--- a/comms/libticables2/Makefile
+++ b/comms/libticables2/Makefile
@@ -1,43 +1,37 @@
-# New ports collection makefile for: libticables2
-# Date created: 11 October 2006
-# Whom: Tijl Coosemans <tijl@ulyssis.org>
-#
# $FreeBSD$
-#
PORTNAME= libticables2
-PORTVERSION= 1.3.3
+PORTVERSION= 1.3.4
CATEGORIES= comms
-MASTER_SITES= SF/tilp/tilp2-linux/tilp2-1.16
+MASTER_SITES= SF/tilp/tilp2-linux/tilp2-1.17
MAINTAINER= tijl@coosemans.org
COMMENT= TI calculator link cables library
LICENSE= GPLv2
-USE_AUTOTOOLS= libtool
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= glib20 gnomehack pkgconfig
+USE_GNOME= glib20
USE_LDCONFIG= yes
+USE_PKGCONFIG= build
+USES= pathfix
-.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
-PLIST_SUB= NLS=""
-.else
-CONFIGURE_ARGS= --disable-nls
-PLIST_SUB= NLS="@comment "
-.endif
+OPTIONS_DEFINE= NLS
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LIBUSB_CFLAGS=" " LIBUSB_LIBS="-lusb"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if ${OSVERSION} >= 800069
-CONFIGURE_ENV+= LIBUSB_CFLAGS=" " LIBUSB_LIBS="-lusb"
+.if ${PORT_OPTIONS:MNLS}
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
.else
-LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/comms/libticables2/distinfo b/comms/libticables2/distinfo
index 8309551caf62..2e331c7f27e4 100644
--- a/comms/libticables2/distinfo
+++ b/comms/libticables2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libticables2-1.3.3.tar.bz2) = e31ffc2324884aeec37b0cc220e62c78a44c43ab874a933939bfe80c4e84071e
-SIZE (libticables2-1.3.3.tar.bz2) = 495883
+SHA256 (libticables2-1.3.4.tar.bz2) = 45cae91ad9ee1cc2ebc0f5865923ff77f1e0adf0793d3010eeb802efc140e5b0
+SIZE (libticables2-1.3.4.tar.bz2) = 920163
diff --git a/comms/libticables2/pkg-descr b/comms/libticables2/pkg-descr
index c3db26007c74..6a728b582cde 100644
--- a/comms/libticables2/pkg-descr
+++ b/comms/libticables2/pkg-descr
@@ -1,4 +1,4 @@
-The ticables library is a library to handle the various TI calculator
+A library to transfer raw data across various types of TI calculator
link cables.
WWW: http://tilp.info/
diff --git a/comms/libticables2/pkg-plist b/comms/libticables2/pkg-plist
index 56a806444411..38761b916933 100644
--- a/comms/libticables2/pkg-plist
+++ b/comms/libticables2/pkg-plist
@@ -2,10 +2,9 @@ include/tilp2/export1.h
include/tilp2/stdints1.h
include/tilp2/ticables.h
include/tilp2/timeout.h
-lib/libticables2.a
lib/libticables2.la
lib/libticables2.so
-lib/libticables2.so.5
+lib/libticables2.so.6
libdata/pkgconfig/ticables2.pc
%%NLS%%share/locale/fr/LC_MESSAGES/libticables2.mo
@dirrmtry include/tilp2
diff --git a/comms/libticalcs2/Makefile b/comms/libticalcs2/Makefile
index 7b8f5651c33a..f42148ef158f 100644
--- a/comms/libticalcs2/Makefile
+++ b/comms/libticalcs2/Makefile
@@ -1,39 +1,40 @@
-# New ports collection makefile for: libticalcs2
-# Date created: 11 October 2006
-# Whom: Tijl Coosemans <tijl@ulyssis.org>
-#
# $FreeBSD$
-#
PORTNAME= libticalcs2
-PORTVERSION= 1.1.7
+PORTVERSION= 1.1.8
CATEGORIES= comms
-MASTER_SITES= SF/tilp/tilp2-linux/tilp2-1.16
+MASTER_SITES= SF/tilp/tilp2-linux/tilp2-1.17
MAINTAINER= tijl@coosemans.org
COMMENT= TI calculator library
LICENSE= GPLv2
-LIB_DEPENDS= ticables2.5:${PORTSDIR}/comms/libticables2 \
- ticonv.6:${PORTSDIR}/converters/libticonv \
- tifiles2.8:${PORTSDIR}/devel/libtifiles2
+LIB_DEPENDS= ticables2:${PORTSDIR}/comms/libticables2 \
+ ticonv:${PORTSDIR}/converters/libticonv \
+ tifiles2:${PORTSDIR}/devel/libtifiles2
-USE_AUTOTOOLS= libtool
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= glib20 gnomehack pkgconfig
+USE_GNOME= glib20
USE_LDCONFIG= yes
+USE_PKGCONFIG= build
+USES= pathfix
-.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
-PLIST_SUB= NLS=""
-.else
-CONFIGURE_ARGS= --disable-nls
-PLIST_SUB= NLS="@comment "
-.endif
+OPTIONS_DEFINE= NLS
+GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
.include <bsd.port.mk>
diff --git a/comms/libticalcs2/distinfo b/comms/libticalcs2/distinfo
index 1c3686bbcba4..8f193fb08aa5 100644
--- a/comms/libticalcs2/distinfo
+++ b/comms/libticalcs2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libticalcs2-1.1.7.tar.bz2) = e16c79033c0eafa4ccda7fc56d018565bba1dfb70dd0b4c5f681bafe32a52ab0
-SIZE (libticalcs2-1.1.7.tar.bz2) = 525111
+SHA256 (libticalcs2-1.1.8.tar.bz2) = a8286f8a2552bcad96beab99ce254e67b3dc1a03eb9d82f8de4bdf7b8efc3496
+SIZE (libticalcs2-1.1.8.tar.bz2) = 524151
diff --git a/comms/libticalcs2/pkg-descr b/comms/libticalcs2/pkg-descr
index a503771efb59..ae7e37fe714b 100644
--- a/comms/libticalcs2/pkg-descr
+++ b/comms/libticalcs2/pkg-descr
@@ -1,4 +1,3 @@
-The ticalcs library is a library to communicate with various TI
-calculators.
+A library to communicate with TI calculators.
WWW: http://tilp.info/
diff --git a/comms/libticalcs2/pkg-plist b/comms/libticalcs2/pkg-plist
index 6c6943e7653c..58e68b9c36ee 100644
--- a/comms/libticalcs2/pkg-plist
+++ b/comms/libticalcs2/pkg-plist
@@ -1,14 +1,22 @@
+include/tilp2/cmd73.h
+include/tilp2/dbus_pkt.h
+include/tilp2/dusb_cmd.h
+include/tilp2/dusb_rpkt.h
+include/tilp2/dusb_vpkt.h
include/tilp2/export3.h
include/tilp2/keys73.h
+include/tilp2/keys83.h
include/tilp2/keys83p.h
+include/tilp2/keys86.h
include/tilp2/keys89.h
include/tilp2/keys92p.h
+include/tilp2/nsp_cmd.h
+include/tilp2/nsp_vpkt.h
include/tilp2/stdints3.h
include/tilp2/ticalcs.h
-lib/libticalcs2.a
lib/libticalcs2.la
lib/libticalcs2.so
-lib/libticalcs2.so.10
+lib/libticalcs2.so.11
libdata/pkgconfig/ticalcs2.pc
%%NLS%%share/locale/fr/LC_MESSAGES/libticalcs2.mo
@dirrmtry include/tilp2
diff --git a/comms/tilp2/Makefile b/comms/tilp2/Makefile
index 6934d6f2e408..8047429bb9d3 100644
--- a/comms/tilp2/Makefile
+++ b/comms/tilp2/Makefile
@@ -1,13 +1,7 @@
-# New ports collection makefile for: tilp2
-# Date created: 11 October 2006
-# Whom: Tijl Coosemans <tijl@ulyssis.org>
-#
# $FreeBSD$
-#
PORTNAME= tilp2
-PORTVERSION= 1.16
-PORTREVISION= 1
+PORTVERSION= 1.17
CATEGORIES= comms
MASTER_SITES= SF/tilp/tilp2-linux/${DISTNAME}
@@ -16,33 +10,39 @@ COMMENT= TI Linking Program
LICENSE= GPLv2
-LIB_DEPENDS= ticables2.5:${PORTSDIR}/comms/libticables2 \
- tifiles2.8:${PORTSDIR}/devel/libtifiles2 \
- ticalcs2.10:${PORTSDIR}/comms/libticalcs2 \
- ticonv.6:${PORTSDIR}/converters/libticonv
+LIB_DEPENDS= ticables2:${PORTSDIR}/comms/libticables2 \
+ tifiles2:${PORTSDIR}/devel/libtifiles2 \
+ ticalcs2:${PORTSDIR}/comms/libticalcs2 \
+ ticonv:${PORTSDIR}/converters/libticonv
-USE_AUTOTOOLS= libtool
USE_BZIP2= yes
USE_GMAKE= yes
-USE_PKGCONFIG= yes
-USE_GNOME= gtk20 libglade2
+USE_GNOME= gtk20
+USE_PKGCONFIG= build
-.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
-PLIST_SUB= NLS=""
-.else
-CONFIGURE_ARGS= --disable-nls
-PLIST_SUB= NLS="@comment "
-.endif
+OPTIONS_DEFINE= NLS
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --without-kde
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS+= --without-kde
-MAN1= tilp.1
+MAN1= tilp.1
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
post-patch:
+ @${REINPLACE_CMD} -e 's,^ USE_NLS=yes$$,,' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|-D.*_DISABLE_DEPRECATED||g' \
${WRKSRC}/configure ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e 's,/usr,${LOCALBASE},' ${WRKSRC}/src/bookmark.c
.include <bsd.port.mk>
diff --git a/comms/tilp2/distinfo b/comms/tilp2/distinfo
index 93f608d6ef9e..646fa5a4d3a1 100644
--- a/comms/tilp2/distinfo
+++ b/comms/tilp2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tilp2-1.16.tar.bz2) = 8064c045d90f734d10c0c3baa9d61f46ac6c6c1af3fc3c96255c4d6cb27a325d
-SIZE (tilp2-1.16.tar.bz2) = 2837735
+SHA256 (tilp2-1.17.tar.bz2) = 0bc744463450843c0f1e9deebf45af84a282304aff37865077ca7146d54ff6e7
+SIZE (tilp2-1.17.tar.bz2) = 892549
diff --git a/comms/tilp2/pkg-plist b/comms/tilp2/pkg-plist
index 75905b38fde8..0f53855d5deb 100644
--- a/comms/tilp2/pkg-plist
+++ b/comms/tilp2/pkg-plist
@@ -5,20 +5,24 @@ share/mime/packages/tilp.xml
%%DATADIR%%/COPYING
%%DATADIR%%/Manpage.txt
%%DATADIR%%/RELEASE
+%%DATADIR%%/builder/action.ui
+%%DATADIR%%/builder/backupdbox.ui
+%%DATADIR%%/builder/clist_rbm.ui
+%%DATADIR%%/builder/clock.ui
+%%DATADIR%%/builder/ctree_rbm.ui
+%%DATADIR%%/builder/device.ui
+%%DATADIR%%/builder/entrydbox.ui
+%%DATADIR%%/builder/manpage.ui
+%%DATADIR%%/builder/options.ui
+%%DATADIR%%/builder/pbar1.ui
+%%DATADIR%%/builder/pbar2.ui
+%%DATADIR%%/builder/pbar3.ui
+%%DATADIR%%/builder/pbar4.ui
+%%DATADIR%%/builder/pbar5.ui
+%%DATADIR%%/builder/release.ui
+%%DATADIR%%/builder/screenopts.ui
+%%DATADIR%%/builder/screenshot.ui
%%DATADIR%%/builder/tilp.ui
-%%DATADIR%%/glade/action-2.glade
-%%DATADIR%%/glade/clist_rbm-2.glade
-%%DATADIR%%/glade/clock-2.glade
-%%DATADIR%%/glade/ctree_rbm-2.glade
-%%DATADIR%%/glade/device-2.glade
-%%DATADIR%%/glade/manpage-2.glade
-%%DATADIR%%/glade/options-2.glade
-%%DATADIR%%/glade/pbars-2.glade
-%%DATADIR%%/glade/release-2.glade
-%%DATADIR%%/glade/screenopts-2.glade
-%%DATADIR%%/glade/screenshot-2.glade
-%%DATADIR%%/glade/tilp-2.glade
-%%DATADIR%%/glade/user_boxes-2.glade
%%DATADIR%%/help/FAQ.html
%%DATADIR%%/help/Image12.png
%%DATADIR%%/help/Image13.png
@@ -121,7 +125,6 @@ share/mime/packages/tilp.xml
@dirrm %%DATADIR%%/pixmaps
@dirrm %%DATADIR%%/icons
@dirrm %%DATADIR%%/help
-@dirrm %%DATADIR%%/glade
@dirrm %%DATADIR%%/builder
@dirrm %%DATADIR%%
@dirrmtry share/mime/packages
diff --git a/converters/libticonv/Makefile b/converters/libticonv/Makefile
index 4333b437cac5..b72574161bec 100644
--- a/converters/libticonv/Makefile
+++ b/converters/libticonv/Makefile
@@ -1,27 +1,21 @@
-# New ports collection makefile for: libticonv
-# Date created: 5 October 2006
-# Whom: Tijl Coosemans <tijl@ulyssis.org>
-#
# $FreeBSD$
-#
PORTNAME= libticonv
-PORTVERSION= 1.1.3
+PORTVERSION= 1.1.4
CATEGORIES= converters
-MASTER_SITES= SF/tilp/tilp2-linux/tilp2-1.16
+MASTER_SITES= SF/tilp/tilp2-linux/tilp2-1.17
MAINTAINER= tijl@coosemans.org
COMMENT= TI calculator character set library
LICENSE= GPLv2
-USE_AUTOTOOLS= libtool
+GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= glib20 gnomehack pkgconfig
+USE_GNOME= glib20
USE_LDCONFIG= yes
-USE_ICONV= yes
-
-CPPFLAGS+= -I${LOCALBASE}/include
+USE_PKGCONFIG= build
+USES= pathfix
.include <bsd.port.mk>
diff --git a/converters/libticonv/distinfo b/converters/libticonv/distinfo
index fc08f4df85f3..cdaad77b7662 100644
--- a/converters/libticonv/distinfo
+++ b/converters/libticonv/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libticonv-1.1.3.tar.bz2) = 330f8f649bc20e19b1d51372a107c132b088aa64561998abd9d336ca8672814a
-SIZE (libticonv-1.1.3.tar.bz2) = 343870
+SHA256 (libticonv-1.1.4.tar.bz2) = 1faecc71311bd95c94792cc72dd0844e7881a65156b006f045bb417eddd45183
+SIZE (libticonv-1.1.4.tar.bz2) = 344616
diff --git a/converters/libticonv/pkg-descr b/converters/libticonv/pkg-descr
index 66b49eeb566b..d0a7ab38c882 100644
--- a/converters/libticonv/pkg-descr
+++ b/converters/libticonv/pkg-descr
@@ -1,4 +1,3 @@
-The ticonv library is a library to work with the various TI
-calculator character sets.
+A library to work with character sets used on TI calculators.
WWW: http://tilp.info/
diff --git a/converters/libticonv/pkg-plist b/converters/libticonv/pkg-plist
index 83226a04c1fe..f99e99c47552 100644
--- a/converters/libticonv/pkg-plist
+++ b/converters/libticonv/pkg-plist
@@ -2,9 +2,8 @@ include/tilp2/charset.h
include/tilp2/export4.h
include/tilp2/stdints4.h
include/tilp2/ticonv.h
-lib/libticonv.a
lib/libticonv.la
lib/libticonv.so
-lib/libticonv.so.6
+lib/libticonv.so.7
libdata/pkgconfig/ticonv.pc
@dirrmtry include/tilp2
diff --git a/devel/libtifiles2/Makefile b/devel/libtifiles2/Makefile
index d03457c55e72..210b53b90f79 100644
--- a/devel/libtifiles2/Makefile
+++ b/devel/libtifiles2/Makefile
@@ -1,37 +1,42 @@
-# New ports collection makefile for: libtifiles2
-# Date created: 11 October 2006
-# Whom: Tijl Coosemans <tijl@ulyssis.org>
-#
# $FreeBSD$
-#
PORTNAME= libtifiles2
-PORTVERSION= 1.1.5
+PORTVERSION= 1.1.6
CATEGORIES= devel
-MASTER_SITES= SF/tilp/tilp2-linux/tilp2-1.16
+MASTER_SITES= SF/tilp/tilp2-linux/tilp2-1.17
MAINTAINER= tijl@coosemans.org
COMMENT= TI calculator file types library
LICENSE= GPLv2
-LIB_DEPENDS= ticonv.6:${PORTSDIR}/converters/libticonv
+LIB_DEPENDS= ticonv:${PORTSDIR}/converters/libticonv
-USE_AUTOTOOLS= libtool
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= glib20 gnomehack pkgconfig
+USE_GNOME= glib20
USE_LDCONFIG= yes
+USE_PKGCONFIG= build
+USES= pathfix
-.if !defined(WITHOUT_NLS)
+OPTIONS_DEFINE= NLS
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= ARCHIVE_CFLAGS=" " ARCHIVE_LIBS="-larchive"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
-PLIST_SUB= NLS=""
+PLIST_SUB+= NLS=""
.else
-CONFIGURE_ARGS= --disable-nls
-PLIST_SUB= NLS="@comment "
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+post-patch:
+ @${REINPLACE_CMD} 's,libarchive,,' ${WRKSRC}/tifiles2.pc.in
.include <bsd.port.mk>
diff --git a/devel/libtifiles2/distinfo b/devel/libtifiles2/distinfo
index 9b33c6e08eeb..7e8af1877981 100644
--- a/devel/libtifiles2/distinfo
+++ b/devel/libtifiles2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libtifiles2-1.1.5.tar.bz2) = 4e701c98863c778c3f6fa465e426af23df88c9feee6fc9a9ca224a629a91e274
-SIZE (libtifiles2-1.1.5.tar.bz2) = 460500
+SHA256 (libtifiles2-1.1.6.tar.bz2) = ec4d6acd1d135ee04256d04a5e1512c1ccaf82ad01e48f5e24d5c4da31ce898f
+SIZE (libtifiles2-1.1.6.tar.bz2) = 390447
diff --git a/devel/libtifiles2/pkg-descr b/devel/libtifiles2/pkg-descr
index 9f559c1db45f..27b1d6efe006 100644
--- a/devel/libtifiles2/pkg-descr
+++ b/devel/libtifiles2/pkg-descr
@@ -1,4 +1,3 @@
-The tifiles library is a library to handle the various TI calculator
-file formats.
+A library to handle TI calculator file formats.
WWW: http://tilp.info/
diff --git a/devel/libtifiles2/pkg-plist b/devel/libtifiles2/pkg-plist
index c128b2075e54..08120b9a48d7 100644
--- a/devel/libtifiles2/pkg-plist
+++ b/devel/libtifiles2/pkg-plist
@@ -17,10 +17,9 @@ include/tilp2/types92p.h
include/tilp2/typesnsp.h
include/tilp2/typesv2.h
include/tilp2/typesxx.h
-lib/libtifiles2.a
lib/libtifiles2.la
lib/libtifiles2.so
-lib/libtifiles2.so.8
+lib/libtifiles2.so.9
libdata/pkgconfig/tifiles2.pc
%%NLS%%share/locale/fr/LC_MESSAGES/libtifiles2.mo
@dirrmtry include/tilp2
diff --git a/emulators/tiemu3/Makefile b/emulators/tiemu3/Makefile
index 610c9fcfd978..824fabf0f198 100644
--- a/emulators/tiemu3/Makefile
+++ b/emulators/tiemu3/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: tiemu3
-# Date created: 13 Aug 2007
-# Whom: Naram Qashat <cyberbotx@cyberbotx.com>
-#
+# Created by: Naram Qashat <cyberbotx@cyberbotx.com>
# $FreeBSD$
-#
PORTNAME= tiemu3
PORTVERSION= 3.03
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= emulators
MASTER_SITES= SF/gtktiemu/tiemu-linux/TIEmu%20${DISTVERSION}
DISTNAME= tiemu-${DISTVERSION}
@@ -16,9 +12,9 @@ EXTRACT_SUFX= -nogdb.tar.gz
MAINTAINER= cyberbotx@cyberbotx.com
COMMENT= TI89(ti)/92(+)/V200 hand-helds emulator
-LIB_DEPENDS= ticalcs2.10:${PORTSDIR}/comms/libticalcs2 \
- ticables2.5:${PORTSDIR}/comms/libticables2 \
- tifiles2.8:${PORTSDIR}/devel/libtifiles2
+LIB_DEPENDS= ticalcs2:${PORTSDIR}/comms/libticalcs2 \
+ ticables2:${PORTSDIR}/comms/libticables2 \
+ tifiles2:${PORTSDIR}/devel/libtifiles2
USE_AUTOTOOLS= libtool
USE_GMAKE= yes
diff --git a/emulators/tilem/Makefile b/emulators/tilem/Makefile
index fe78ee619c4a..fa075becf96b 100644
--- a/emulators/tilem/Makefile
+++ b/emulators/tilem/Makefile
@@ -1,12 +1,9 @@
-# New ports collection makefile for: TilEm (TI Linux Emulator)
-# Date created: 5 Sep 2006
-# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
-#
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= tilem
PORTVERSION= 2.0
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= SF