aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/kxstitch/Makefile26
-rw-r--r--graphics/kxstitch/distinfo5
-rw-r--r--graphics/kxstitch/pkg-descr11
4 files changed, 43 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 523ee9049433..df0d168279e8 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -408,6 +408,7 @@
SUBDIR += kphotoalbum
SUBDIR += krita
SUBDIR += kudu
+ SUBDIR += kxstitch
SUBDIR += l2p
SUBDIR += largetifftools
SUBDIR += laternamagica
diff --git a/graphics/kxstitch/Makefile b/graphics/kxstitch/Makefile
new file mode 100644
index 000000000000..b2c591112cd5
--- /dev/null
+++ b/graphics/kxstitch/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= kxstitch
+DISTVERSION= 2.1.1
+MASTER_SITES= KDE/stable/${PORTNAME}/${DISTVERSION}
+CATEGORIES= graphics kde
+
+PATCH_SITES= https://github.com/KDE/${PORTNAME}/commit/
+PATCHFILES= 9db3fcf9cd367681c0864238dc5009a604f3896c.patch:-p1
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Cross stitch pattern editor
+
+LIB_DEPENDS= libMagick++-6.so:graphics/ImageMagick6 \
+ libMagickCore-6.so:graphics/ImageMagick6
+
+USES= cmake desktop-file-utils kde:5 qt:5 tar:xz
+USE_KDE= auth bookmarks codecs completion config configwidgets coreaddons \
+ i18n itemviews jobwidgets kio service solid sonnet textwidgets \
+ widgetsaddons xmlgui
+USE_QT= concurrent core dbus gui network printsupport widgets x11extras \
+ xml \
+ buildtools_build qmake_build
+USE_XORG= ice sm x11 xext
+
+.include <bsd.port.mk>
diff --git a/graphics/kxstitch/distinfo b/graphics/kxstitch/distinfo
new file mode 100644
index 000000000000..4a4da2211f09
--- /dev/null
+++ b/graphics/kxstitch/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1558812636
+SHA256 (kxstitch-2.1.1.tar.xz) = a194f366223f8eee7d93b2ace9c464c8ed968d5e928175bc4f49fbba9b4d8e15
+SIZE (kxstitch-2.1.1.tar.xz) = 1726364
+SHA256 (9db3fcf9cd367681c0864238dc5009a604f3896c.patch) = a9d3be5ca529ff1dcd86b96deb438ceafe949cc2917c4333d722cb50ed40504c
+SIZE (9db3fcf9cd367681c0864238dc5009a604f3896c.patch) = 983
diff --git a/graphics/kxstitch/pkg-descr b/graphics/kxstitch/pkg-descr
new file mode 100644
index 000000000000..19b2642655ac
--- /dev/null
+++ b/graphics/kxstitch/pkg-descr
@@ -0,0 +1,11 @@
+KXStitch is a cross stitch pattern editor by KDE.
+Features
+
+ * Importing images
+ * Multiple floss palettes
+ * Multiple stitch types
+ * Pattern libraries
+ * Reads PCStitch files
+ * Flexible printing options
+
+WWW: https://kde.org/applications/graphics/kxstitch/