aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/ghc/Makefile13
-rw-r--r--math/isabelle/Makefile10
-rw-r--r--textproc/sgmlformat/Makefile12
3 files changed, 17 insertions, 18 deletions
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index 104c1c48e637..ec53ae67f256 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -24,7 +24,13 @@ BOOT_DIST4= ghc-${PORTVERSION}-i386-unknown-freebsd4-boot${EXTRACT_SUFX}:boot
BOOT_DIST5= ghc-${PORTVERSION}-i386-unknown-freebsd5-boot${EXTRACT_SUFX}:boot
BOOT_DIST= ghc-${PORTVERSION}-i386-unknown-freebsd6-boot${EXTRACT_SUFX}:boot
+USE_AUTOTOOLS= autoconf:259:env
USE_BZIP2= yes
+LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4
+
+USE_PERL5= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
OPTIONS= PROFILE "Compile for profiling as well" on
@@ -45,13 +51,6 @@ IGNORE= unsupported at the moment
IGNORE= unsupported at the moment
.endif
-USE_AUTOTOOLS= autoconf:259:env
-LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4
-
-USE_PERL5= yes
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-
PLIST_SUB+= GHC_VERSION=${PORTVERSION}
.if defined(WITHOUT_PROFILE)
PLIST_SUB+= PROFILE="@comment "
diff --git a/math/isabelle/Makefile b/math/isabelle/Makefile
index 7e6bf775bd2d..0adbceed0557 100644
--- a/math/isabelle/Makefile
+++ b/math/isabelle/Makefile
@@ -24,6 +24,11 @@ COMMENT= A generic proof assistant
OPTIONS= SMLNJ "Use SML/NJ (devel) instead of the faster Poly/ML" Off
+USE_PERL5= yes
+RUN_DEPENDS+= proofgeneral:${PORTSDIR}/math/proofgeneral
+
+DOCFILES= Contents *.pdf *.eps *.ps *.dvi
+
.include <bsd.port.pre.mk>
.if defined(WITH_SMLNJ)
@@ -39,11 +44,6 @@ ML_DBASE= ""
ML_PLATFORM= ""
.endif
-USE_PERL5= yes
-RUN_DEPENDS+= proofgeneral:${PORTSDIR}/math/proofgeneral
-
-DOCFILES= Contents *.pdf *.eps *.ps *.dvi
-
.if defined(WITH_SMLNJ)
PLIST_SUB= HEAPSUBDIR=${ML_SYSTEM}_${ML_PLATFORM}
BUILD_DEPENDS+= smlnj-devel>=110.65:${PORTSDIR}/lang/sml-nj-devel
diff --git a/textproc/sgmlformat/Makefile b/textproc/sgmlformat/Makefile
index 5351d579d607..bc9e3099bb83 100644
--- a/textproc/sgmlformat/Makefile
+++ b/textproc/sgmlformat/Makefile
@@ -16,6 +16,12 @@ MASTER_SITE_SUBDIR= kuriyama
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Generates groff and HTML from linuxdoc and docbook SGML documents
+USE_PERL5_RUN= yes
+
+MAN1= instant.1 sgmlfmt.1
+MAN5= transpec.5
+MANCOMPRESSED= yes
+
# There are two ports that satisfy the nsgmls requirement.
# Jade is preferred.
@@ -33,12 +39,6 @@ RUN_DEPENDS= nsgmls:${PORTSDIR}/textproc/jade
RUN_DEPENDS+= ${PREFIX}/share/sgml/linuxdoc:${PORTSDIR}/textproc/linuxdoc \
${PREFIX}/share/sgml/docbook:${PORTSDIR}/textproc/docbook
-USE_PERL5_RUN= yes
-
-MAN1= instant.1 sgmlfmt.1
-MAN5= transpec.5
-MANCOMPRESSED= yes
-
.if defined(WITH_OPENJADE)
post-patch:
@${REINPLACE_CMD} -e 's,nsgmls,onsgmls,g' ${WRKSRC}/sgmlfmt/sgmlfmt.pl