aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/libtorrent-rasterbar/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/net-p2p/libtorrent-rasterbar/Makefile b/net-p2p/libtorrent-rasterbar/Makefile
index 0eed76b1e639..10879f067ca0 100644
--- a/net-p2p/libtorrent-rasterbar/Makefile
+++ b/net-p2p/libtorrent-rasterbar/Makefile
@@ -13,15 +13,15 @@ COMMENT?= C++ library implementing a BitTorrent client
LICENSE= BSD
-LIB_DEPENDS= libboost_date_time.so:${PORTSDIR}/devel/boost-libs \
+LIB_DEPENDS?= libboost_date_time.so:${PORTSDIR}/devel/boost-libs \
libGeoIP.so:${PORTSDIR}/net/GeoIP
-USES= compiler:c++11-lang pathfix pkgconfig iconv
+USES= compiler:c++11-lib pathfix pkgconfig iconv
USE_OPENSSL= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFIGURE_ARGS+= --disable-debug \
+CONFIGURE_ARGS= --disable-debug \
--disable-static \
--enable-dht \
--enable-encryption \
@@ -69,6 +69,7 @@ post-install:
${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${STAGEDIR}${DOCSDIR2}
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/examples/|} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/examples/|} \
+ ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>