aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test-YAML-Valid/Makefile26
-rw-r--r--devel/p5-Test-YAML-Valid/distinfo3
-rw-r--r--devel/p5-Test-YAML-Valid/pkg-descr3
-rw-r--r--devel/p5-Test-YAML-Valid/pkg-plist7
5 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 283850672be2..7df7c4cb6105 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1534,6 +1534,7 @@
SUBDIR += p5-Test-Warn
SUBDIR += p5-Test-XML
SUBDIR += p5-Test-XML-Valid
+ SUBDIR += p5-Test-YAML-Valid
SUBDIR += p5-Test-use-ok
SUBDIR += p5-Text-LevenshteinXS
SUBDIR += p5-Text-vFile-asData
diff --git a/devel/p5-Test-YAML-Valid/Makefile b/devel/p5-Test-YAML-Valid/Makefile
new file mode 100644
index 000000000000..520aa578d013
--- /dev/null
+++ b/devel/p5-Test-YAML-Valid/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: devel/p5-Test-YAML-Valid
+# Date created: 10 April 2007
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-YAML-Valid
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Test for valid YAML
+
+RUN_DEPENDS= p5-YAML>=0.60:${PORTSDIR}/textproc/p5-YAML \
+ p5-Test-Simple>0:${PORTSDIR}/devel/p5-Test-Simple
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::YAML::Valid.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-YAML-Valid/distinfo b/devel/p5-Test-YAML-Valid/distinfo
new file mode 100644
index 000000000000..1c5f5a700e18
--- /dev/null
+++ b/devel/p5-Test-YAML-Valid/distinfo
@@ -0,0 +1,3 @@
+MD5 (Test-YAML-Valid-0.03.tar.gz) = ef76bf8995f8165253d58a29d77da8e8
+SHA256 (Test-YAML-Valid-0.03.tar.gz) = c5944ce73c3e697e3ad465ab08448db6368b019b8f3908755dbff90862814230
+SIZE (Test-YAML-Valid-0.03.tar.gz) = 26435
diff --git a/devel/p5-Test-YAML-Valid/pkg-descr b/devel/p5-Test-YAML-Valid/pkg-descr
new file mode 100644
index 000000000000..e90f525cccc4
--- /dev/null
+++ b/devel/p5-Test-YAML-Valid/pkg-descr
@@ -0,0 +1,3 @@
+This module lets you easily test the validity of YAML.
+
+WWW: http://search.cpan.org/dist/Test-YAML-Valid/
diff --git a/devel/p5-Test-YAML-Valid/pkg-plist b/devel/p5-Test-YAML-Valid/pkg-plist
new file mode 100644
index 000000000000..c3ab5d87c45d
--- /dev/null
+++ b/devel/p5-Test-YAML-Valid/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Test/YAML/Valid.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/YAML/Valid/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/YAML/Valid
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/YAML
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test
+@dirrmtry %%SITE_PERL%%/Test/YAML
+@dirrmtry %%SITE_PERL%%/Test