aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.ruby.mk2
-rw-r--r--lang/ruby20/Makefile21
-rw-r--r--lang/ruby20/distinfo4
3 files changed, 15 insertions, 12 deletions
diff --git a/Mk/bsd.ruby.mk b/Mk/bsd.ruby.mk
index 5f64586efa0d..a2b92c2cad12 100644
--- a/Mk/bsd.ruby.mk
+++ b/Mk/bsd.ruby.mk
@@ -174,7 +174,7 @@ RUBY?= ${LOCALBASE}/bin/${RUBY_NAME}
RUBY_RELVERSION= 2.0.0
RUBY_PORTREVISION= 0
RUBY_PORTEPOCH= 1
-RUBY_PATCHLEVEL= 647
+RUBY_PATCHLEVEL= 648
RUBY20= "" # PLIST_SUB helpers
. elif ${RUBY_VER} == 2.1
diff --git a/lang/ruby20/Makefile b/lang/ruby20/Makefile
index 367bda6d9472..a1f8241d7fc6 100644
--- a/lang/ruby20/Makefile
+++ b/lang/ruby20/Makefile
@@ -15,6 +15,8 @@ COMMENT?= Object-oriented interpreted scripting language
LICENSE= BSD2CLAUSE RUBY
LICENSE_COMB= dual
+LICENSE_FILE_BSD2CLAUSE=${WRKSRC}/BSDL
+LICENSE_FILE_RUBY= ${WRKSRC}/COPYING
# Using LIB_DEPENDS finds the libffi from gcc which causes problems
BUILD_DEPENDS= libffi>=0:${PORTSDIR}/devel/libffi
@@ -34,10 +36,9 @@ GNU_CONFIGURE= yes
# Keep this, else ruby will fail to load libraries dependent of libpthread.
LIBS+= -lpthread -L${LOCALBASE}/lib
MAKE_ENV= LC_ALL=C
-USE_AUTOTOOLS= autoconf
USE_LDCONFIG= yes
USE_OPENSSL= yes
-USES= cpe execinfo tar:bzip2
+USES= autoreconf cpe execinfo tar:xz
WRKSRC= ${RUBY_WRKSRC}
RUBY_VER= 2.0
@@ -45,6 +46,9 @@ USE_RUBY= yes
RUBY_NO_BUILD_DEPENDS= yes
RUBY_NO_RUN_DEPENDS= yes
+NOT_FOR_ARCHS= ia64
+NOT_FOR_ARCHS_REASON_ia64= does not build
+
OPTIONS_DEFINE= CAPIDOCS DEBUG DOCS EXAMPLES RDOC
OPTIONS_DEFAULT= RDOC LIBEDIT
OPTIONS_SINGLE= EDIT
@@ -58,9 +62,8 @@ READLINE_DESC= Use libreadline
CAPIDOCS_BUILD_DEPENDS= doxygen>0:${PORTSDIR}/devel/doxygen \
dot:${PORTSDIR}/graphics/graphviz
CAPIDOCS_CONFIGURE_ENABLE= install-capi
-LIBEDIT_BUILD_DEPENDS= libedit>=0:${PORTSDIR}/devel/libedit
LIBEDIT_CONFIGURE_ON= --enable-libedit --with-libedit-prefix=${LOCALBASE}
-LIBEDIT_RUN_DEPENDS= libedit>=0:${PORTSDIR}/devel/libedit
+LIBEDIT_USES= libedit
RDOC_CONFIGURE_ENABLE= install-rdoc
READLINE_BUILD_DEPENDS= readline>=0:${PORTSDIR}/devel/readline
READLINE_CONFIGURE_ON= --disable-libedit --with-readline-prefix=${LOCALBASE}
@@ -139,20 +142,20 @@ post-patch:
# Remove modules we don't want
#
.for d in win32ole
- ${RM} -rf ${BUILD_WRKSRC}/ext/${d}
+ @${RM} -rf ${BUILD_WRKSRC}/ext/${d}
.endfor
# We get rake from ports.
.for d in bin/rake doc/rake lib/rake test/rake man/rake.1 lib/rake.rb
- ${RM} -rf ${BUILD_WRKSRC}/${d}
+ @${RM} -rf ${BUILD_WRKSRC}/${d}
.endfor
# We get the gem executable from ports.
- ${RM} ${BUILD_WRKSRC}/bin/gem
+ @${RM} ${BUILD_WRKSRC}/bin/gem
#
# Prepare modules we are wanting to build via external ports
#
.for d in gdbm tk
- ${MV} ${BUILD_WRKSRC}/ext/${d} ${WRKDIR}/
+ @${MV} ${BUILD_WRKSRC}/ext/${d} ${WRKDIR}/
.endfor
post-build:
@@ -167,7 +170,7 @@ post-build:
@${RB_SET_CONF_VAR} "INSTALL_DATA" "ENV['RB_USER_INSTALL'] ? '${INSTALL} ${COPY} -m ${SHAREMODE}' : '${INSTALL_DATA}'"
post-build-CAPIDOCS-on:
- ${FIND} ${WRKSRC}/doc -type d -empty -delete
+ @${FIND} ${WRKSRC}/doc -type d -empty -delete
pre-install:
${MKDIR} ${STAGEDIR}${RUBY_SITEARCHLIBDIR}
diff --git a/lang/ruby20/distinfo b/lang/ruby20/distinfo
index d28a7099f567..b3e53daf50ce 100644
--- a/lang/ruby20/distinfo
+++ b/lang/ruby20/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ruby/ruby-2.0.0-p647.tar.bz2) = 3c3782e313d1ec3ed06c104eafd133cc54ff5183b991786ece9e957fd6cf1cb9
-SIZE (ruby/ruby-2.0.0-p647.tar.bz2) = 10785285
+SHA256 (ruby/ruby-2.0.0-p648.tar.xz) = 22fe97739110ba9171b13fc4dcd1a92e767f16769de3593ee41ef1283d218402
+SIZE (ruby/ruby-2.0.0-p648.tar.xz) = 8303584