aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--misc/Makefile1
-rw-r--r--misc/instant-server/Makefile35
-rw-r--r--misc/instant-server/distinfo1
-rw-r--r--misc/instant-server/pkg-comment1
-rw-r--r--misc/instant-server/pkg-descr1
-rw-r--r--misc/instant-server/pkg-message3
-rw-r--r--misc/instant-server/pkg-plist0
7 files changed, 42 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 1d1e97fd3f4e..baa4a1cb8a09 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -70,6 +70,7 @@
SUBDIR += hello
SUBDIR += heyu
SUBDIR += histring
+ SUBDIR += instant-server
SUBDIR += instant-workstation
SUBDIR += iselect
SUBDIR += jargon
diff --git a/misc/instant-server/Makefile b/misc/instant-server/Makefile
new file mode 100644
index 000000000000..26f5bb7e4fa1
--- /dev/null
+++ b/misc/instant-server/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: instant-server
+# Date created: 12 February 2001
+# Whom: grog
+#
+# $FreeBSD$
+#
+
+PORTNAME= instant-server
+PORTVERSION= 1.0
+CATEGORIES= misc
+MASTER_SITES= ftp://ftp.lemis.com/pub/
+MASTER_SITE_SUBDIR= pub/instant-server
+
+MAINTAINER= grog@lemis.com
+
+RUN_DEPENDS= ${LOCALBASE}/sbin/postfix:${PORTSDIR}/mail/postfix \
+ cvsupd-bin:${PORTSDIR}/net/cvsupd-bin \
+ isc-dhcp3:${PORTSDIR}/net/isc-dhcp3 \
+ samba:${PORTSDIR}/net/samba \
+ traceroute:${PORTSDIR}/net/traceroute \
+ cnews:${PORTSDIR}/news/cnews \
+ apache13:${PORTSDIR}/www/apache13 \
+ squid23:${PORTSDIR}/www/squid23
+
+# Don't let stupid programs ask for configuration.
+
+BATCH= YES
+NO_WRKSUBDIR= YES
+
+# comms/hylafax irc/ircd-hybrid
+
+postinstall:
+ cd ${PORTSDIR}/mail/postfix; make replace
+
+.include <bsd.port.mk>
diff --git a/misc/instant-server/distinfo b/misc/instant-server/distinfo
new file mode 100644
index 000000000000..c833304cd150
--- /dev/null
+++ b/misc/instant-server/distinfo
@@ -0,0 +1 @@
+MD5 (instant-server-1.0.tar.gz) = 3d416bfb3be5e83b6fd5d6ecd4801bc5
diff --git a/misc/instant-server/pkg-comment b/misc/instant-server/pkg-comment
new file mode 100644
index 000000000000..3ce49aa835e4
--- /dev/null
+++ b/misc/instant-server/pkg-comment
@@ -0,0 +1 @@
+Instant server installs a typical set of ports for a server
diff --git a/misc/instant-server/pkg-descr b/misc/instant-server/pkg-descr
new file mode 100644
index 000000000000..7ebcd79aab6b
--- /dev/null
+++ b/misc/instant-server/pkg-descr
@@ -0,0 +1 @@
+instant server installs a typical set of ports for a server
diff --git a/misc/instant-server/pkg-message b/misc/instant-server/pkg-message
new file mode 100644
index 000000000000..2b7478fa8d00
--- /dev/null
+++ b/misc/instant-server/pkg-message
@@ -0,0 +1,3 @@
+This package does not include online documentation. You will find PDF
+documents in English and German in the directory
+/usr/local/share/doc/sceptre.
diff --git a/misc/instant-server/pkg-plist b/misc/instant-server/pkg-plist
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/misc/instant-server/pkg-plist