aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/helium/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/lang/helium/Makefile b/lang/helium/Makefile
index b8bc7c1ec1a8..1778ee0851b5 100644
--- a/lang/helium/Makefile
+++ b/lang/helium/Makefile
@@ -7,6 +7,7 @@
PORTNAME= helium
PORTVERSION= 1.1
+PORTREVISION= 1
CATEGORIES= lang haskell
MASTER_SITES= http://www.cs.uu.nl/helium/distr/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
@@ -14,16 +15,17 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= obraun@FreeBSD.org
COMMENT= Functional programming compiler for a subset of Haskell
+.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 500035
+BROKEN= does not compile
+.endif
+
BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_REINPLACE= yes
USE_GMAKE= yes
-post-patch:
- @${REINPLACE_CMD} -e '/#include "math.h"/d' \
- ${WRKSRC}/lvm/src/runtime/core/primfloat.c
-
do-configure:
@(cd ${WRKSRC}/lvm/src/ && ./configure)
@(cd ${WRKSRC}/heliumNT/ && ./configure)
@@ -36,4 +38,4 @@ do-install:
@(cd ${WRKSRC}/heliumNT/src && ${GMAKE} install)
@${CAT} ${PKGMESSAGE} | ${SED} -e 's,%%PREFIX%%,${PREFIX},g'
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>