aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/dbus/Makefile9
-rw-r--r--devel/dbus/distinfo4
-rw-r--r--devel/dbus/files/dbus.in2
-rw-r--r--devel/dbus/files/dbus.sh2
-rw-r--r--devel/dbus/files/patch-dbus_dbus-sysdeps-util.c11
-rw-r--r--devel/dbus/files/patch-tools_Makefile.in12
-rw-r--r--devel/dbus/files/patch-tools_run-with-tmp-session-bus.sh8
-rw-r--r--devel/dbus/pkg-plist11
-rw-r--r--devel/py-dbus/Makefile4
9 files changed, 43 insertions, 20 deletions
diff --git a/devel/dbus/Makefile b/devel/dbus/Makefile
index a5ad70bb845a..bd02a4e70326 100644
--- a/devel/dbus/Makefile
+++ b/devel/dbus/Makefile
@@ -6,14 +6,14 @@
#
PORTNAME= dbus
-PORTVERSION= 0.23.2
-PORTREVISION= 1
+PORTVERSION= 0.32
CATEGORIES?= devel gnome
MASTER_SITES= http://dbus.freedesktop.org/releases/
MAINTAINER?= gnome@FreeBSD.org
COMMENT?= A message bus system for inter-application communication
+BUILD_DEPENDS?= bash:${PORTSDIR}/shells/bash
LIB_DEPENDS?= expat.5:${PORTSDIR}/textproc/expat2
USE_GNOME?= gnomehack gtk20 libxml2
@@ -21,6 +21,7 @@ USE_GMAKE= yes
USE_LIBTOOL_VER=15
INSTALLS_SHLIB= yes
USE_RC_SUBR= yes
+USE_REINPLACE= yes
CONFIGURE_ARGS?=--enable-gtk \
--disable-python \
--disable-gcj \
@@ -40,7 +41,7 @@ OPTIONS= QT "Enable Qt client support" off
PLIST_SUB= VERSION="1.0"
RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
-MAN1= dbus-cleanup-sockets.1 dbus-daemon-1.1 dbus-launch.1 \
+MAN1= dbus-cleanup-sockets.1 dbus-daemon.1 dbus-launch.1 \
dbus-monitor.1 dbus-send.1
.endif
@@ -59,6 +60,8 @@ PLIST_SUB+= QT="@comment "
post-patch:
@${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
${FILESDIR}/dbus.sh > ${WRKSRC}/dbus.sh
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
+ ${WRKSRC}/tools/run-with-tmp-session-bus.sh
post-install:
.if !defined(PACKAGE_BUILDING)
diff --git a/devel/dbus/distinfo b/devel/dbus/distinfo
index e13b387b6b87..a03694afe5bf 100644
--- a/devel/dbus/distinfo
+++ b/devel/dbus/distinfo
@@ -1,2 +1,2 @@
-MD5 (dbus-0.23.2.tar.gz) = 654a2207203636dca0007de384cf0893
-SIZE (dbus-0.23.2.tar.gz) = 1285494
+MD5 (dbus-0.32.tar.gz) = 3b4f941487764dedf2517da64e194a1c
+SIZE (dbus-0.32.tar.gz) = 1428682
diff --git a/devel/dbus/files/dbus.in b/devel/dbus/files/dbus.in
index 9717b6a05da9..a9b4ff8085fd 100644
--- a/devel/dbus/files/dbus.in
+++ b/devel/dbus/files/dbus.in
@@ -19,7 +19,7 @@ dbus_flags=${dbus_flags-"--system"}
name=dbus
rcvar=`set_rcvar`
-command="%%PREFIX%%/bin/dbus-daemon-1"
+command="%%PREFIX%%/bin/dbus-daemon"
pidfile="/var/run/${name}.pid"
stop_postcmd=stop_postcmd
diff --git a/devel/dbus/files/dbus.sh b/devel/dbus/files/dbus.sh
index 9717b6a05da9..a9b4ff8085fd 100644
--- a/devel/dbus/files/dbus.sh
+++ b/devel/dbus/files/dbus.sh
@@ -19,7 +19,7 @@ dbus_flags=${dbus_flags-"--system"}
name=dbus
rcvar=`set_rcvar`
-command="%%PREFIX%%/bin/dbus-daemon-1"
+command="%%PREFIX%%/bin/dbus-daemon"
pidfile="/var/run/${name}.pid"
stop_postcmd=stop_postcmd
diff --git a/devel/dbus/files/patch-dbus_dbus-sysdeps-util.c b/devel/dbus/files/patch-dbus_dbus-sysdeps-util.c
new file mode 100644
index 000000000000..7d726aef87d4
--- /dev/null
+++ b/devel/dbus/files/patch-dbus_dbus-sysdeps-util.c
@@ -0,0 +1,11 @@
+--- dbus/dbus-sysdeps-util.c.orig Sat Apr 2 15:29:28 2005
++++ dbus/dbus-sysdeps-util.c Sat Apr 2 15:29:45 2005
+@@ -142,7 +142,7 @@ _dbus_become_daemon (const DBusString *p
+ return FALSE;
+ }
+
+- if (!_dbus_string_append_int (&pid, _dbus_getpid ()) ||
++ if (!_dbus_string_append_int (&pid, child_pid) ||
+ !_dbus_string_append (&pid, "\n"))
+ {
+ _dbus_string_free (&pid);
diff --git a/devel/dbus/files/patch-tools_Makefile.in b/devel/dbus/files/patch-tools_Makefile.in
index 8144c8a9888b..c13b0ce17e17 100644
--- a/devel/dbus/files/patch-tools_Makefile.in
+++ b/devel/dbus/files/patch-tools_Makefile.in
@@ -1,11 +1,11 @@
---- tools/Makefile.in.orig Mon Jan 24 19:22:29 2005
-+++ tools/Makefile.in Mon Jan 24 19:22:47 2005
-@@ -314,7 +314,7 @@
+--- tools/Makefile.in.orig Sat Apr 2 14:50:00 2005
++++ tools/Makefile.in Sat Apr 2 14:50:40 2005
+@@ -335,7 +335,7 @@
sharedstatedir = @sharedstatedir@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
--INCLUDES = -I$(top_srcdir) $(DBUS_CLIENT_CFLAGS) $(DBUS_GLIB_CFLAGS) $(DBUS_X_CFLAGS) $(DBUS_GTK_CFLAGS) -DDBUS_LOCALEDIR=\"$(prefix)/@DATADIRNAME@/locale\"
-+INCLUDES = -I$(top_srcdir) $(DBUS_CLIENT_CFLAGS) $(DBUS_GLIB_CFLAGS) $(DBUS_X_CFLAGS) $(DBUS_GTK_CFLAGS) -DDBUS_LOCALEDIR=\"$(prefix)/share/locale\"
+-INCLUDES = -I$(top_srcdir) $(DBUS_CLIENT_CFLAGS) $(DBUS_GLIB_CFLAGS) $(DBUS_X_CFLAGS) $(DBUS_GTK_THREADS_CFLAGS) -DDBUS_LOCALEDIR=\"$(prefix)/@DATADIRNAME@/locale\"
++INCLUDES = -I$(top_srcdir) $(DBUS_CLIENT_CFLAGS) $(DBUS_GLIB_CFLAGS) $(DBUS_X_CFLAGS) $(DBUS_GTK_THREADS_CFLAGS) -DDBUS_LOCALEDIR=\"$(prefix)/share/locale\"
@HAVE_GLIB_FALSE@GLIB_TOOLS =
@HAVE_GLIB_TRUE@GLIB_TOOLS = dbus-monitor
- @HAVE_GTK_FALSE@GTK_TOOLS =
+ @HAVE_GLIB_TRUE@nodist_libdbus_glib_HEADERS = dbus-glib-bindings.h
diff --git a/devel/dbus/files/patch-tools_run-with-tmp-session-bus.sh b/devel/dbus/files/patch-tools_run-with-tmp-session-bus.sh
new file mode 100644
index 000000000000..ab5d6bc38a44
--- /dev/null
+++ b/devel/dbus/files/patch-tools_run-with-tmp-session-bus.sh
@@ -0,0 +1,8 @@
+--- tools/run-with-tmp-session-bus.sh.orig Sat Apr 2 14:52:51 2005
++++ tools/run-with-tmp-session-bus.sh Sat Apr 2 14:53:05 2005
+@@ -1,4 +1,4 @@
+-#! /bin/bash
++#! %%LOCALBASE%%/bin/bash
+
+ SCRIPTNAME=$0
+ WRAPPED_SCRIPT=$1
diff --git a/devel/dbus/pkg-plist b/devel/dbus/pkg-plist
index 9f152406a5aa..fea04a649c2e 100644
--- a/devel/dbus/pkg-plist
+++ b/devel/dbus/pkg-plist
@@ -1,6 +1,6 @@
+bin/dbus-binding-tool
bin/dbus-cleanup-sockets
-bin/dbus-daemon-1
-bin/dbus-glib-tool
+bin/dbus-daemon
bin/dbus-launch
bin/dbus-monitor
bin/dbus-send
@@ -12,6 +12,7 @@ include/dbus-%%VERSION%%/dbus/dbus-address.h
include/dbus-%%VERSION%%/dbus/dbus-bus.h
include/dbus-%%VERSION%%/dbus/dbus-connection.h
include/dbus-%%VERSION%%/dbus/dbus-errors.h
+include/dbus-%%VERSION%%/dbus/dbus-glib-bindings.h
include/dbus-%%VERSION%%/dbus/dbus-glib-error-enum.h
include/dbus-%%VERSION%%/dbus/dbus-glib-lowlevel.h
include/dbus-%%VERSION%%/dbus/dbus-glib.h
@@ -28,13 +29,13 @@ include/dbus-%%VERSION%%/dbus/dbus.h
include/dbus-%%VERSION%%/include/dbus/dbus-arch-deps.h
lib/libdbus-1.a
lib/libdbus-1.so
-lib/libdbus-1.so.0
+lib/libdbus-1.so.1
lib/libdbus-glib-1.a
lib/libdbus-glib-1.so
-lib/libdbus-glib-1.so.0
+lib/libdbus-glib-1.so.1
%%QT%%lib/libdbus-qt-1.a
%%QT%%lib/libdbus-qt-1.so
-%%QT%%lib/libdbus-qt-1.so.0
+%%QT%%lib/libdbus-qt-1.so.1
libdata/pkgconfig/dbus-1.pc
libdata/pkgconfig/dbus-glib-1.pc
@exec mkdir -p %D/share/dbus-1/services
diff --git a/devel/py-dbus/Makefile b/devel/py-dbus/Makefile
index d6b0a8c1c5aa..11e024fc464e 100644
--- a/devel/py-dbus/Makefile
+++ b/devel/py-dbus/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
#
-PORTREVISION= 1
+PORTREVISION= 0
CATEGORIES= devel gnome python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,7 +13,7 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= Python interface to the D-BUS messaging system
BUILD_DEPENDS= pyrexc:${PORTSDIR}/devel/pyrex
-LIB_DEPENDS= dbus-1.0:${PORTSDIR}/devel/dbus
+LIB_DEPENDS= dbus-1.1:${PORTSDIR}/devel/dbus
RUN_DEPENDS= pyrexc:${PORTSDIR}/devel/pyrex
MASTERDIR= ${.CURDIR}/../dbus