aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/thttpd/Makefile2
-rw-r--r--www/thttpd/pkg-plist8
2 files changed, 5 insertions, 5 deletions
diff --git a/www/thttpd/Makefile b/www/thttpd/Makefile
index 0c3b2a297d9c..a6aa596a14ee 100644
--- a/www/thttpd/Makefile
+++ b/www/thttpd/Makefile
@@ -63,7 +63,7 @@ do-install:
@if [ ! -f ${PREFIX}/etc/rc.d/thttpd.sh ]; then \
${ECHO} "Installing ${PREFIX}/etc/rc.d/thttpd.sh startup file."; \
${INSTALL_SCRIPT} -m 751 ${FILESDIR}/thttpd.sh ${PREFIX}/etc/rc.d/thttpd.sh; \
- ${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${PREFIX}/etc/rc.d/thttpd.sh; \
+ ${REINPLACE_CMD} -i '' -e 's|%%PREFIX%%|${PREFIX}|g' ${PREFIX}/etc/rc.d/thttpd.sh; \
fi
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/thttpd
diff --git a/www/thttpd/pkg-plist b/www/thttpd/pkg-plist
index e6c366e7f6b2..fa27c02a1829 100644
--- a/www/thttpd/pkg-plist
+++ b/www/thttpd/pkg-plist
@@ -10,7 +10,7 @@ www/cgi-bin/phf
www/cgi-bin/redirect
www/cgi-bin/ssi
%%PORTDOCS%%@dirrm share/doc/thttpd
-@dirrm www/cgi-bin
-@dirrm www/data
-@dirrm www/logs
-@dirrm www
+@unexec rmdir %D/www/cgi-bin 2> /dev/null || true
+@unexec rmdir %D/www/data 2> /dev/null || true
+@unexec rmdir %D/www/logs 2> /dev/null || true
+@unexec rmdir %D/www 2> /dev/null || true