aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/linux-enemyterritory-omni-bot-0660/Makefile13
-rw-r--r--games/linux-enemyterritory-omni-bot-0660/pkg-plist4
2 files changed, 10 insertions, 7 deletions
diff --git a/games/linux-enemyterritory-omni-bot-0660/Makefile b/games/linux-enemyterritory-omni-bot-0660/Makefile
index 386ee0147aa6..5f34404dbf94 100644
--- a/games/linux-enemyterritory-omni-bot-0660/Makefile
+++ b/games/linux-enemyterritory-omni-bot-0660/Makefile
@@ -7,6 +7,7 @@
PORTNAME= omni-bot
PORTVERSION= 0.660
+PORTREVISION= 1
CATEGORIES= games linux
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= alepulver
@@ -18,15 +19,16 @@ COMMENT= Omni-Bot is a bot for Enemy Territory
RUN_DEPENDS= et:${PORTSDIR}/games/linux-enemyterritory
-CONFLICTS= linux-enemyterritory-omni-bot-0.[7-9]*
-NO_LATEST_LINK= yes
+VERSTR= ${PORTVERSION:C/([0-9])\.([0-9]+)/\1\2/}
+PKGNAMESUFFIX= -${VERSTR}
+PLIST_SUB= VERSTR="${VERSTR}"
USE_ZIP= yes
USE_LINUX= yes
NO_WRKSUBDIR= yes
-DATADIR= ${PREFIX}/lib/enemyterritory/${PORTNAME}
-DOCSDIR= ${PREFIX}/share/doc/enemyterritory-${PORTNAME}
+DATADIR= ${PREFIX}/lib/enemyterritory/${PORTNAME}-${VERSTR}
+DOCSDIR= ${PREFIX}/share/doc/enemyterritory-${PORTNAME}-${VERSTR}
do-build:
.for f in et etded
@@ -37,7 +39,8 @@ do-build:
do-install:
.for f in et etded
- ${INSTALL_SCRIPT} ${WRKSRC}/${f}-${PORTNAME} ${PREFIX}/bin
+ ${MV} ${WRKSRC}/${f}-${PORTNAME} ${WRKSRC}/${f}-${PORTNAME}-${VERSTR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f}-${PORTNAME}-${VERSTR} ${PREFIX}/bin
.endfor
${MKDIR} ${DATADIR}
${INSTALL_PROGRAM} ${WRKSRC}/omni-bot/omnibot_et.so ${DATADIR}
diff --git a/games/linux-enemyterritory-omni-bot-0660/pkg-plist b/games/linux-enemyterritory-omni-bot-0660/pkg-plist
index 90bfe387a19d..cfd8116372c3 100644
--- a/games/linux-enemyterritory-omni-bot-0660/pkg-plist
+++ b/games/linux-enemyterritory-omni-bot-0660/pkg-plist
@@ -1,5 +1,5 @@
-bin/et-omni-bot
-bin/etded-omni-bot
+bin/et-omni-bot-%%VERSTR%%
+bin/etded-omni-bot-%%VERSTR%%
%%DATADIR%%/et/nav/et_custom.zip
%%DATADIR%%/et/nav/et_official.zip
%%DATADIR%%/et/scripts/ammo_goal.gm