aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/p5-EasyTCP/Makefile2
-rw-r--r--net/p5-Frontier-RPC/Makefile4
-rw-r--r--net/p5-Net-MAC-Vendor/Makefile4
-rw-r--r--net/p5-Net-Patricia/Makefile6
-rw-r--r--net/p5-Net-Pcap/Makefile2
-rw-r--r--net/p5-Net-SCP/Makefile4
-rw-r--r--net/p5-Net-SDP/Makefile2
-rw-r--r--net/p5-Net-SSH-Perl/Makefile24
-rw-r--r--net/p5-POE-Component-ControlPort/Makefile6
-rw-r--r--net/p5-POE-Component-Pcap/Makefile6
-rw-r--r--net/p5-POE-Component-Spread/Makefile4
-rw-r--r--net/p5-SOAP-Amazon-S3/Makefile8
-rw-r--r--net/p5-SOAP-Data-Builder/Makefile2
-rw-r--r--net/p5-Spread-Message/Makefile2
-rw-r--r--net/p5-XPC/Makefile6
15 files changed, 41 insertions, 41 deletions
diff --git a/net/p5-EasyTCP/Makefile b/net/p5-EasyTCP/Makefile
index abc8380a49f9..5e6ee11f2d1c 100644
--- a/net/p5-EasyTCP/Makefile
+++ b/net/p5-EasyTCP/Makefile
@@ -16,7 +16,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Easily create TCP/IP clients and servers
-BUILD_DEPENDS= ${SITE_PERL}/Crypt/RSA.pm:${PORTSDIR}/security/p5-Crypt-RSA
+BUILD_DEPENDS= p5-Crypt-RSA>=0:${PORTSDIR}/security/p5-Crypt-RSA
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/net/p5-Frontier-RPC/Makefile b/net/p5-Frontier-RPC/Makefile
index 0867544c6fc8..b530f335fff5 100644
--- a/net/p5-Frontier-RPC/Makefile
+++ b/net/p5-Frontier-RPC/Makefile
@@ -17,8 +17,8 @@ DISTNAME= ${PORTNAME}-0.07b4
MAINTAINER= perl@FreeBSD.org
COMMENT= Frontier::RPC implements UserLand Software's XML RPC
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
- ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww
+BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
PERL_CONFIGURE= yes
diff --git a/net/p5-Net-MAC-Vendor/Makefile b/net/p5-Net-MAC-Vendor/Makefile
index 62d86d637101..644d8029ea75 100644
--- a/net/p5-Net-MAC-Vendor/Makefile
+++ b/net/p5-Net-MAC-Vendor/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Look up the vendor for a MAC
-BUILD_DEPENDS= ${SITE_PERL}/LWP/Simple.pm:${PORTSDIR}/www/p5-libwww
-RUN_DEPENDS= ${SITE_PERL}/LWP/Simple.pm:${PORTSDIR}/www/p5-libwww
+BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
MAN3= Net::MAC::Vendor.3
diff --git a/net/p5-Net-Patricia/Makefile b/net/p5-Net-Patricia/Makefile
index 2bb5a267245f..af079e678d29 100644
--- a/net/p5-Net-Patricia/Makefile
+++ b/net/p5-Net-Patricia/Makefile
@@ -14,9 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl module for fast IP address lookups
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/version.pm:${PORTSDIR}/devel/p5-version \
- ${SITE_PERL}/Net/CIDR/Lite.pm:${PORTSDIR}/net/p5-Net-CIDR-Lite \
- ${SITE_PERL}/${PERL_ARCH}/Socket6.pm:${PORTSDIR}/net/p5-Socket6
+RUN_DEPENDS= p5-version>=0:${PORTSDIR}/devel/p5-version \
+ p5-Net-CIDR-Lite>=0:${PORTSDIR}/net/p5-Net-CIDR-Lite \
+ p5-Socket6>=0:${PORTSDIR}/net/p5-Socket6
PERL_CONFIGURE= YES
diff --git a/net/p5-Net-Pcap/Makefile b/net/p5-Net-Pcap/Makefile
index 21b30754f79f..2e2742f920b9 100644
--- a/net/p5-Net-Pcap/Makefile
+++ b/net/p5-Net-Pcap/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Interface to pcap(3) LBL packet capture library
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/IO/Interface.pm:${PORTSDIR}/net/p5-IO-Interface
+RUN_DEPENDS= p5-IO-Interface>=0:${PORTSDIR}/net/p5-IO-Interface
TEST_DEPENDS= p5-Socket>=0:${PORTSDIR}/net/p5-Socket \
p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
diff --git a/net/p5-Net-SCP/Makefile b/net/p5-Net-SCP/Makefile
index 97cfbb4eb2d3..bdc1090681f3 100644
--- a/net/p5-Net-SCP/Makefile
+++ b/net/p5-Net-SCP/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl5 module to access and use scp protocol
-BUILD_DEPENDS= ${SITE_PERL}/Net/SSH.pm:${PORTSDIR}/net/p5-Net-SSH \
- ${SITE_PERL}/String/ShellQuote.pm:${PORTSDIR}/textproc/p5-String-ShellQuote \
+BUILD_DEPENDS= p5-Net-SSH>=0:${PORTSDIR}/net/p5-Net-SSH \
+ p5-String-ShellQuote>=0:${PORTSDIR}/textproc/p5-String-ShellQuote \
p5-IO>=0:${PORTSDIR}/devel/p5-IO
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/net/p5-Net-SDP/Makefile b/net/p5-Net-SDP/Makefile
index 2324a97a814a..8bb6e59c515e 100644
--- a/net/p5-Net-SDP/Makefile
+++ b/net/p5-Net-SDP/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Session Description Protocol (RFC 2327) packet parser/generator
-BUILD_DEPENDS= ${SITE_PERL}/LWP/Simple.pm:${PORTSDIR}/www/p5-libwww
+BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_MODBUILD= yes
diff --git a/net/p5-Net-SSH-Perl/Makefile b/net/p5-Net-SSH-Perl/Makefile
index 08d18a8cf8c5..fc37700d0c88 100644
--- a/net/p5-Net-SSH-Perl/Makefile
+++ b/net/p5-Net-SSH-Perl/Makefile
@@ -15,17 +15,17 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl5 module implements both the SSH1 and SSH2 protocols
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/String/CRC32.pm:${PORTSDIR}/devel/p5-String-CRC32 \
- ${SITE_PERL}/${PERL_ARCH}/Math/GMP.pm:${PORTSDIR}/math/p5-Math-GMP \
- ${SITE_PERL}/Digest/HMAC_MD5.pm:${PORTSDIR}/security/p5-Digest-HMAC \
- ${SITE_PERL}/Digest/HMAC_SHA1.pm:${PORTSDIR}/security/p5-Digest-HMAC \
- ${SITE_PERL}/Crypt/DSA.pm:${PORTSDIR}/security/p5-Crypt-DSA \
- ${SITE_PERL}/Crypt/DH.pm:${PORTSDIR}/security/p5-Crypt-DH \
- ${SITE_PERL}/${PERL_ARCH}/Math/Pari.pm:${PORTSDIR}/math/p5-Math-Pari \
- ${SITE_PERL}/Convert/PEM.pm:${PORTSDIR}/converters/p5-Convert-PEM \
- ${SITE_PERL}/${PERL_ARCH}/Crypt/IDEA.pm:${PORTSDIR}/security/p5-Crypt-IDEA \
- ${SITE_PERL}/Digest/BubbleBabble.pm:${PORTSDIR}/security/p5-Digest-BubbleBabble \
- ${SITE_PERL}/Crypt/RSA.pm:${PORTSDIR}/security/p5-Crypt-RSA
+BUILD_DEPENDS= p5-String-CRC32>=0:${PORTSDIR}/devel/p5-String-CRC32 \
+ p5-Math-GMP>=0:${PORTSDIR}/math/p5-Math-GMP \
+ p5-Digest-HMAC>=0:${PORTSDIR}/security/p5-Digest-HMAC \
+ p5-Digest-HMAC>=0:${PORTSDIR}/security/p5-Digest-HMAC \
+ p5-Crypt-DSA>=0:${PORTSDIR}/security/p5-Crypt-DSA \
+ p5-Crypt-DH>=0:${PORTSDIR}/security/p5-Crypt-DH \
+ p5-Math-Pari>=0:${PORTSDIR}/math/p5-Math-Pari \
+ p5-Convert-PEM>=0:${PORTSDIR}/converters/p5-Convert-PEM \
+ p5-Crypt-IDEA>=0:${PORTSDIR}/security/p5-Crypt-IDEA \
+ p5-Digest-BubbleBabble>=0:${PORTSDIR}/security/p5-Digest-BubbleBabble \
+ p5-Crypt-RSA>=0:${PORTSDIR}/security/p5-Crypt-RSA
RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Net::SSH::Perl.3 \
@@ -78,7 +78,7 @@ GMP_DESC= Use the optimized Math::BigInt::GMP backend
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MGMP}
-GMP_DEPEND= ${SITE_PERL}/${PERL_ARCH}/Math/BigInt/GMP.pm:${PORTSDIR}/math/p5-Math-BigInt-GMP
+GMP_DEPEND= p5-Math-BigInt-GMP>=0:${PORTSDIR}/math/p5-Math-BigInt-GMP
BUILD_DEPENDS+= ${GMP_DEPEND}
RUN_DEPENDS+= ${GMP_DEPEND}
.endif
diff --git a/net/p5-POE-Component-ControlPort/Makefile b/net/p5-POE-Component-ControlPort/Makefile
index 0c0c37b091f6..02f80f2c21d5 100644
--- a/net/p5-POE-Component-ControlPort/Makefile
+++ b/net/p5-POE-Component-ControlPort/Makefile
@@ -15,10 +15,10 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Network control port for POE applications
RUN_DEPENDS= p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
- ${SITE_PERL}/${PERL_ARCH}/Authen/Libwrap.pm:${PORTSDIR}/security/p5-Authen-Libwrap \
- ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE
+ p5-Authen-Libwrap>=0:${PORTSDIR}/security/p5-Authen-Libwrap \
+ p5-POE>=0:${PORTSDIR}/devel/p5-POE
BUILD_DEPENDS= ${RUN_DEPENDS}
-BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+BUILD_DEPENDS+= p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
PERL_CONFIGURE= yes
diff --git a/net/p5-POE-Component-Pcap/Makefile b/net/p5-POE-Component-Pcap/Makefile
index a59354bdf70b..16ed24923bf2 100644
--- a/net/p5-POE-Component-Pcap/Makefile
+++ b/net/p5-POE-Component-Pcap/Makefile
@@ -14,9 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= POE component for non-blocking use of Net::Pcap
-BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
- ${SITE_PERL}/${PERL_ARCH}/Net/Pcap.pm:${PORTSDIR}/net/p5-Net-Pcap \
- ${SITE_PERL}/NetPacket/Ethernet.pm:${PORTSDIR}/net/p5-NetPacket
+BUILD_DEPENDS= p5-POE>=0:${PORTSDIR}/devel/p5-POE \
+ p5-Net-Pcap>=0:${PORTSDIR}/net/p5-Net-Pcap \
+ p5-NetPacket>=0:${PORTSDIR}/net/p5-NetPacket
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/net/p5-POE-Component-Spread/Makefile b/net/p5-POE-Component-Spread/Makefile
index 1082c6ac04d9..d05679d1ec4f 100644
--- a/net/p5-POE-Component-Spread/Makefile
+++ b/net/p5-POE-Component-Spread/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Handle Spread communications in POE
-BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
- ${SITE_PERL}/${PERL_ARCH}/Spread.pm:${PORTSDIR}/net/spread
+BUILD_DEPENDS= p5-POE>=0:${PORTSDIR}/devel/p5-POE \
+ spread>=0:${PORTSDIR}/net/spread
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_MODBUILD= YES
diff --git a/net/p5-SOAP-Amazon-S3/Makefile b/net/p5-SOAP-Amazon-S3/Makefile
index 73e21b6cb4b0..39990c8381f5 100644
--- a/net/p5-SOAP-Amazon-S3/Makefile
+++ b/net/p5-SOAP-Amazon-S3/Makefile
@@ -15,10 +15,10 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
MAINTAINER= perl@FreeBSD.org
COMMENT= A module for interfacing with Amazon S3 through SOAP
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Time/Piece.pm:${PORTSDIR}/devel/p5-Time-Piece \
- ${SITE_PERL}/Digest/HMAC_SHA1.pm:${PORTSDIR}/security/p5-Digest-HMAC \
- ${SITE_PERL}/SOAP/MySOAP.pm:${PORTSDIR}/net/p5-SOAP-MySOAP \
- ${SITE_PERL}/XML/MyXML.pm:${PORTSDIR}/textproc/p5-XML-MyXML
+RUN_DEPENDS= p5-Time-Piece>=0:${PORTSDIR}/devel/p5-Time-Piece \
+ p5-Digest-HMAC>=0:${PORTSDIR}/security/p5-Digest-HMAC \
+ p5-SOAP-MySOAP>=0:${PORTSDIR}/net/p5-SOAP-MySOAP \
+ p5-XML-MyXML>=0:${PORTSDIR}/textproc/p5-XML-MyXML
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/net/p5-SOAP-Data-Builder/Makefile b/net/p5-SOAP-Data-Builder/Makefile
index 105ba90e3552..b7b02d80ccb3 100644
--- a/net/p5-SOAP-Data-Builder/Makefile
+++ b/net/p5-SOAP-Data-Builder/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= A wrapper simplifying SOAP::Data and SOAP::Serialiser
-BUILD_DEPENDS= ${SITE_PERL}/SOAP/Lite.pm:${PORTSDIR}/net/p5-SOAP-Lite
+BUILD_DEPENDS= p5-SOAP-Lite>=0:${PORTSDIR}/net/p5-SOAP-Lite
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/net/p5-Spread-Message/Makefile b/net/p5-Spread-Message/Makefile
index fbe852157022..813ab4e0b62e 100644
--- a/net/p5-Spread-Message/Makefile
+++ b/net/p5-Spread-Message/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Provide messaging using the Spread toolkit
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Spread.pm:${PORTSDIR}/net/spread
+BUILD_DEPENDS= spread>=0:${PORTSDIR}/net/spread
RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Spread::Message.3
diff --git a/net/p5-XPC/Makefile b/net/p5-XPC/Makefile
index e97f8f9e528a..b7096a6be1f4 100644
--- a/net/p5-XPC/Makefile
+++ b/net/p5-XPC/Makefile
@@ -17,9 +17,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= XML Procedure Call (XPC)
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
- ${SITE_PERL}/HTTP/Daemon.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes