aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/flobopuyo/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/games/flobopuyo/Makefile b/games/flobopuyo/Makefile
index 78b9841cc391..db4d897d7e4e 100644
--- a/games/flobopuyo/Makefile
+++ b/games/flobopuyo/Makefile
@@ -19,7 +19,12 @@ COMMENT= Clone of the famous PuyoPuyo
USE_BISON= yes
USE_GMAKE= yes
USE_SDL= sdl mixer image
-USE_GCC= 3.4+
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64" && ${OSVERSION} >= 700000
+BROKEN= Doesn't build
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}|' ${WRKSRC}/Makefile
@@ -29,4 +34,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|^INSTALL_DATADIR=.*$$|INSTALL_DATADIR=${DATADIR}|' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|^INSTALL_BINDIR=.*$$|INSTALL_BINDIR=${PREFIX}/bin|' ${WRKSRC}/Makefile
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>