aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--science/glens/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/science/glens/Makefile b/science/glens/Makefile
index 1b65ff7ded7e..33fb1c7167ab 100644
--- a/science/glens/Makefile
+++ b/science/glens/Makefile
@@ -26,6 +26,12 @@ CONFIGURE_ARGS= --with-glui=${X11BASE}
CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "alpha"
+BROKEN= "Does not compile on alpha"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
's|-O6||g ; \
@@ -37,4 +43,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/cfg/*.cgf ${EXAMPLESDIR}/cfg
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>