aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--palm/synce-gnomevfs/Makefile4
-rw-r--r--palm/synce-gvfs/Makefile4
-rw-r--r--palm/synce-kde/Makefile11
-rw-r--r--palm/synce-multisync/Makefile14
4 files changed, 25 insertions, 8 deletions
diff --git a/palm/synce-gnomevfs/Makefile b/palm/synce-gnomevfs/Makefile
index 7b7dad5f65a0..285076965828 100644
--- a/palm/synce-gnomevfs/Makefile
+++ b/palm/synce-gnomevfs/Makefile
@@ -22,6 +22,10 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-librapi=${LOCALBASE} \
--with-libsynce=${LOCALBASE}
+BROKEN= No longer supported by developers
+DEPRECATED= ${BROKEN}
+EXPIRATION_DATE= 2008-08-24
+
USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
diff --git a/palm/synce-gvfs/Makefile b/palm/synce-gvfs/Makefile
index 7b7dad5f65a0..285076965828 100644
--- a/palm/synce-gvfs/Makefile
+++ b/palm/synce-gvfs/Makefile
@@ -22,6 +22,10 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-librapi=${LOCALBASE} \
--with-libsynce=${LOCALBASE}
+BROKEN= No longer supported by developers
+DEPRECATED= ${BROKEN}
+EXPIRATION_DATE= 2008-08-24
+
USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
diff --git a/palm/synce-kde/Makefile b/palm/synce-kde/Makefile
index e5d2750b6f7c..a34186cb9e7f 100644
--- a/palm/synce-kde/Makefile
+++ b/palm/synce-kde/Makefile
@@ -6,23 +6,26 @@
PORTNAME= synce-kde
PORTVERSION= 0.9.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= palm
-MASTER_SITES= SF
-MASTER_SITE_SUBDIR= synce
+MASTER_SITES= SF/synce
MAINTAINER= ports@FreeBSD.org
COMMENT= SynCE KDE Utilities
LIB_DEPENDS+= synce.0:${PORTSDIR}/palm/synce-libsynce \
rapi.2:${PORTSDIR}/palm/synce-librapi2 \
- rra.0:${PORTSDIR}/palm/synce-rra \
+ rra.0:${PORTSDIR}/palm/synce-librra \
dynamite.0:${PORTSDIR}/archivers/libdynamite \
orange.0:${PORTSDIR}/archivers/liborange \
unshield.0:${PORTSDIR}/archivers/unshield
RUN_DEPENDS+= synce-serial-start:${PORTSDIR}/palm/synce-serial
+BROKEN= No longer supported by developers
+DEPRECATED= ${BROKEN}
+EXPIRATION_DATE= 2008-08-24
+
USE_KDELIBS_VER=3
USE_GMAKE= yes
USE_ICONV= yes
diff --git a/palm/synce-multisync/Makefile b/palm/synce-multisync/Makefile
index 5b92bb37bde7..5aca7a62cb2e 100644
--- a/palm/synce-multisync/Makefile
+++ b/palm/synce-multisync/Makefile
@@ -7,15 +7,15 @@
PORTNAME= synce-multisync_plugin
PORTVERSION= 0.9.0
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= palm deskutils
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= synce
+MASTER_SITES= SF/synce
MAINTAINER= ports@FreeBSD.org
COMMENT= SynCE synchronisation plugin for Multisync
-LIB_DEPENDS= rra.0:${PORTSDIR}/palm/synce-rra
+LIB_DEPENDS= rra.0:${PORTSDIR}/palm/synce-librra \
+ synce.0:${PORTSDIR}/palm/synce-libsynce
BUILD_DEPENDS= multisync:${PORTSDIR}/deskutils/multisync
RUN_DEPENDS= multisync:${PORTSDIR}/deskutils/multisync
@@ -26,6 +26,12 @@ CONFIGURE_ARGS+= --with-librapi=${LOCALBASE} \
--with-libsynce=${LOCALBASE} \
--with-librra=${LOCALBASE} \
--with-multisync-include=${LOCALBASE}/include/multisync
+CONFIGURE_ENV+= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+BROKEN= No longer supported by developers
+DEPRECATED= ${BROKEN}
+EXPIRATION_DATE= 2008-08-24
post-patch:
@${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure