aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/Makefile1
-rw-r--r--mail/gdesklets-sensor-psi_popmail/Makefile43
-rw-r--r--mail/gdesklets-sensor-psi_popmail/distinfo1
-rw-r--r--mail/gdesklets-sensor-psi_popmail/files/patch-Install_popmail_Sensor.bin19
-rw-r--r--mail/gdesklets-sensor-psi_popmail/pkg-descr3
-rw-r--r--mail/gdesklets-sensor-psi_popmail/pkg-message8
-rw-r--r--mail/gdesklets-sensor-psi_popmail/pkg-plist5
7 files changed, 80 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 0b5e7642160b..6f04bbd265f8 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -83,6 +83,7 @@
SUBDIR += ftrack
SUBDIR += gbuffy
SUBDIR += gdesklets-imapmail
+ SUBDIR += gdesklets-sensor-psi_popmail
SUBDIR += gensig
SUBDIR += getmail
SUBDIR += gkrellmmailwatch
diff --git a/mail/gdesklets-sensor-psi_popmail/Makefile b/mail/gdesklets-sensor-psi_popmail/Makefile
new file mode 100644
index 000000000000..a6375c69f98f
--- /dev/null
+++ b/mail/gdesklets-sensor-psi_popmail/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: gdesklets-sensor-psi_popmail
+# Date created: 21 September 2003
+# Whom: Franz Klammer <klammer@webonaut.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= popmail
+PORTVERSION= 0.1.4
+CATEGORIES= mail gnome
+MASTER_SITES= http://gdesklets.gnomedesktop.org/files/
+PKGNAMEPREFIX= gdesklets-sensor-psi_
+DISTNAME= PsiSensorPackage-${DISTVERSION}
+
+MAINTAINER= klammer@webonaut.com
+COMMENT= Popmail Sensor from the Psi Sensor Package
+
+RUN_DEPENDS= ${X11BASE}/libdata/pkgconfig/gdesklets-core.pc:${PORTSDIR}/deskutils/gdesklets
+
+USE_BZIP2= yes
+USE_PYTHON= yes
+USE_X_PREFIX= yes
+
+DISTVERSION= 20031028
+NAME= popmail
+DATADIR= ${PREFIX}/share/gnome
+WRKSRC= ${WRKDIR}/${NAME}-${PORTVERSION}
+
+do-build:
+ @${WRKSRC}/Install_${NAME}_Sensor.bin --nomsg ${WRKSRC}
+ @${FIND} ${WRKSRC} -name '*.orig' -delete
+
+do-install:
+ @${MKDIR} ${DATADIR}/gdesklets/Sensors/${NAME}
+ @${INSTALL_DATA} ${WRKSRC}/${NAME}/*.py ${DATADIR}/gdesklets/Sensors/${NAME}/
+ @${INSTALL_DATA} ${WRKSRC}/README ${DATADIR}/gdesklets/Sensors/${NAME}/
+
+post-install:
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${DATADIR}/gdesklets/Sensors/${NAME}
+ @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${DATADIR}/gdesklets/Sensors/${NAME}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/mail/gdesklets-sensor-psi_popmail/distinfo b/mail/gdesklets-sensor-psi_popmail/distinfo
new file mode 100644
index 000000000000..bf4d02f7d5c7
--- /dev/null
+++ b/mail/gdesklets-sensor-psi_popmail/distinfo
@@ -0,0 +1 @@
+MD5 (PsiSensorPackage-20031028.tar.bz2) = 24c891e1d0f66426040b4e4fb618f9f5
diff --git a/mail/gdesklets-sensor-psi_popmail/files/patch-Install_popmail_Sensor.bin b/mail/gdesklets-sensor-psi_popmail/files/patch-Install_popmail_Sensor.bin
new file mode 100644
index 000000000000..b7d716a3e8c1
--- /dev/null
+++ b/mail/gdesklets-sensor-psi_popmail/files/patch-Install_popmail_Sensor.bin
@@ -0,0 +1,19 @@
+--- Install_popmail_Sensor.bin.orig Wed Nov 19 18:34:09 2003
++++ Install_popmail_Sensor.bin Wed Nov 19 18:34:26 2003
+@@ -75,15 +75,9 @@
+ else:
+ cmd = "mkdir -p %(destination)s; cd %(destination)s; " \
+ "LANG=C tar -xzvf %(tmp)s 2>&1"
+- fail, out = commands.getstatusoutput(cmd % vars())
++ commands.getstatusoutput(cmd % vars())
+ os.unlink(tmp)
+
+- if (fail):
+- if (no_message): print ERROR_TAR + out
+- else: message(ERROR_TAR + out, "error")
+- sys.exit(1)
+-
+- print out
+ if (not list_only):
+ if (no_message): print SUCCESS
+ else: message(SUCCESS, "info")
diff --git a/mail/gdesklets-sensor-psi_popmail/pkg-descr b/mail/gdesklets-sensor-psi_popmail/pkg-descr
new file mode 100644
index 000000000000..97cb9e831f0e
--- /dev/null
+++ b/mail/gdesklets-sensor-psi_popmail/pkg-descr
@@ -0,0 +1,3 @@
+popmail Sensor from the Psi Sensor Package.
+
+WWW: http://gdesklets.gnomedesktop.org/
diff --git a/mail/gdesklets-sensor-psi_popmail/pkg-message b/mail/gdesklets-sensor-psi_popmail/pkg-message
new file mode 100644
index 000000000000..72b972746eee
--- /dev/null
+++ b/mail/gdesklets-sensor-psi_popmail/pkg-message
@@ -0,0 +1,8 @@
+##
+To view the README, do the command following:
+
+ cat ${PREFIX}/share/gnome/gdesklets/Sensors/popmail/README
+
+This is just a sensor, to actually see the data it collects, you have to install
+an appropriate display plugin.
+##
diff --git a/mail/gdesklets-sensor-psi_popmail/pkg-plist b/mail/gdesklets-sensor-psi_popmail/pkg-plist
new file mode 100644
index 000000000000..92328e5943cd
--- /dev/null
+++ b/mail/gdesklets-sensor-psi_popmail/pkg-plist
@@ -0,0 +1,5 @@
+share/gnome/gdesklets/Sensors/popmail/__init__.py
+share/gnome/gdesklets/Sensors/popmail/__init__.pyc
+share/gnome/gdesklets/Sensors/popmail/__init__.pyo
+share/gnome/gdesklets/Sensors/popmail/README
+@dirrm share/gnome/gdesklets/Sensors/popmail