aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/robot/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/graphics/robot/Makefile b/graphics/robot/Makefile
index e5def3a40096..6323aad55647 100644
--- a/graphics/robot/Makefile
+++ b/graphics/robot/Makefile
@@ -18,18 +18,14 @@ COMMENT= Graph plotting and data analysis program using OpenLook
BUILD_DEPENDS= fsplit:${PORTSDIR}/devel/fortran-utils
LIB_DEPENDS= xview.3:${PORTSDIR}/x11-toolkits/xview
+BROKEN= "Broken pkg-plist"
+
USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
MAKE_ENV+= OPENWINHOME=${X11BASE}
WEB_BROWSER?= mozilla
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502000
-BROKEN= "Broken pkg-plist"
-.endif
-
pre-build:
@${REINPLACE_CMD} -e 's+netscape+${WEB_BROWSER}+ ' \
${WRKSRC}/Robot/Makefile
@@ -51,4 +47,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/Demos/*.rob ${EXAMPLESDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>