aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/bacula-bat/Makefile47
-rw-r--r--sysutils/bacula-bat/pkg-descr13
-rw-r--r--sysutils/bacula-bat/pkg-plist2
4 files changed, 63 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 4845f43e1923..a1fdd940607e 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -36,6 +36,7 @@
SUBDIR += ataidle
SUBDIR += atitvout
SUBDIR += autopsy
+ SUBDIR += bacula-bat
SUBDIR += bacula-client
SUBDIR += bacula-client-devel
SUBDIR += bacula-docs
diff --git a/sysutils/bacula-bat/Makefile b/sysutils/bacula-bat/Makefile
new file mode 100644
index 000000000000..217c0433eaa3
--- /dev/null
+++ b/sysutils/bacula-bat/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: bacula-bat
+# Date created: 18 Sep 2007
+# Whom: Dan Langille <dan@langille.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bacula
+PKGNAMESUFFIX= -bat
+
+COMMENT= The network backup solution (GUI)
+
+WITH_BAT= yes
+
+USE_QT_VER= 4
+QT_COMPONENTS= qmake
+pre-install:
+# override master
+
+post-install:
+# override master
+
+do-install:
+# Install config files and preserve existing ones
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/qt-console/bat ${PREFIX}/sbin
+ ${INSTALL_SCRIPT} ${WRKSRC}/src/qt-console/bat.conf ${PREFIX}/etc/bat.conf.sample
+ ${INSTALL_MAN} ${WRKSRC}/manpages/bat.1 ${PREFIX}/man/man1/bat.1.gz
+
+MAN1=bat.1
+
+MAKE_ARGS= -E MAN1
+MAKE_ENV= MAN1="${MAN1}"
+
+MAKE_ENV+= MAKEOBJDIRPREFIX=/
+
+LIB_DEPENDS+= qwt.5:${PORTSDIR}/x11-toolkits/qwt-devel
+
+PLIST=${.CURDIR}/pkg-plist
+
+CONFIGURE_ARGS+= --enable-bat \
+ --with-qwt={$PREFIX}/lib \
+ --disable-build-dird \
+ --disable-build-stored \
+ --enable-client-only
+
+MASTERDIR= ${.CURDIR}/../../sysutils/bacula-server
+.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/bacula-bat/pkg-descr b/sysutils/bacula-bat/pkg-descr
new file mode 100644
index 000000000000..91e157ffc8b8
--- /dev/null
+++ b/sysutils/bacula-bat/pkg-descr
@@ -0,0 +1,13 @@
+bat is the GUI inteface for Bacula.
+
+Bacula is a set of computer programs that permit you (or the system
+administrator) to manage backup, recovery, and verification of
+computer data across a network of computers of different kinds.
+In technical terms, it is a network Client/Server based backup program.
+Bacula is relatively easy to use and efficient, while offering many
+advanced storage management features that make it easy to find and
+recover lost or damaged files. Due to its modular design, Bacula is
+scalable from small single computer systems to systems consisting of
+hundreds of computers located over a large network.
+
+WWW: http://www.bacula.org/
diff --git a/sysutils/bacula-bat/pkg-plist b/sysutils/bacula-bat/pkg-plist
new file mode 100644
index 000000000000..5305bc35901d
--- /dev/null
+++ b/sysutils/bacula-bat/pkg-plist
@@ -0,0 +1,2 @@
+etc/bat.conf.sample
+sbin/bat