aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/nip2/Makefile52
-rw-r--r--graphics/nip2/distinfo4
-rw-r--r--graphics/nip2/files/extra-patch-src-parser.h11
-rw-r--r--graphics/nip2/files/patch-src-graphwindow.c2
-rw-r--r--graphics/nip2/files/patch-tests57
-rw-r--r--graphics/nip2/files/run-nip2.sh.in10
-rw-r--r--graphics/nip2/pkg-plist183
-rw-r--r--graphics/vips/Makefile49
-rw-r--r--graphics/vips/distinfo4
-rw-r--r--graphics/vips/files/nodoc-patch26
-rw-r--r--graphics/vips/files/patch-libsrc-conversion-im_tiff2vips.c15
-rw-r--r--graphics/vips/files/patch-libsrc-conversion-im_vips2tiff.c15
-rw-r--r--graphics/vips/files/patch-v4l8
-rw-r--r--graphics/vips/pkg-plist49
14 files changed, 274 insertions, 211 deletions
diff --git a/graphics/nip2/Makefile b/graphics/nip2/Makefile
index 1b9553aec2f7..bb182ff3a485 100644
--- a/graphics/nip2/Makefile
+++ b/graphics/nip2/Makefile
@@ -2,44 +2,60 @@
# $FreeBSD$
PORTNAME= nip2
-PORTVERSION= 7.26.3
-PORTREVISION= 3
+PORTVERSION= 7.40.1
CATEGORIES= graphics
MASTER_SITES= http://www.vips.ecs.soton.ac.uk/supported/${PORTVERSION:R}/
MAINTAINER= mi@aldan.algebra.com
COMMENT= Graphical user interface for VIPS
-LIB_DEPENDS= libvips.so:${PORTSDIR}/graphics/vips \
- gsl:${PORTSDIR}/math/gsl \
+OPTIONS_DEFINE= DOCS
+LIB_DEPENDS= libvips.so:${PORTSDIR}/graphics/vips \
+ libgoffice-*.so:${PORTSDIR}/devel/goffice \
+ libgsl.so:${PORTSDIR}/math/gsl \
+ libgvc.so:${PORTSDIR}/graphics/graphviz \
xml2:${PORTSDIR}/textproc/libxml2
+BUILD_DEPENDS= xgettext:${PORTSDIR}/devel/gettext
-USES= bison gmake pkgconfig
+USES= bison dos2unix gettext gmake pkgconfig
USE_GNOME= gnomemimedata glib20 gtk20
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --mandir=${PREFIX}/man
+CONFIGURE_ENV+= XGETTEXT=${LOCALBASE}/bin/xgettext \
+ LIBGVC_LIBS="-L${LOCALBASE}/lib/graphviz -lgvc" \
+ LIBGVC_CFLAGS="-I${LOCALBASE}/include/graphviz"
+DOS2UNIX_GLOB= *.def
+SUB_FILES= run-nip2.sh
# This port has no man-pages. It installs a number of HTML files,
# which are available through the GUI's Help. For this reason, they
# are always installed, regardless of the NOPORTDOCS setting.
-NO_STAGE= yes
-# The PDF version of the documentation is another story:
-.if defined(NOPORTDOCS)
-EXTRACT_AFTER_ARGS= --exclude nipguide --exclude pdf
-.endif
# Somehow vendor's configure misses these:
MAKE_ENV+= UPDATE_MIME_DATABASE=update-mime-database \
UPDATE_DESKTOP_DATABASE=update-desktop-database
MAN1= nip2.1
-.include <bsd.port.options.mk>
-
-.if ${OSVERSION} >= 1000013
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src-parser.h
-.endif
+post-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/run-nip2.sh \
+ ${STAGEDIR}/${PREFIX}/bin/
post-patch:
- @${REINPLACE_CMD} -e 's|n_bytes|x_n_bytes|g' -e 's|text_size|x_text_size|g' \
- ${WRKSRC}/src/gtkitementry.c
+ ${REINPLACE_CMD} -e 's|/bin/bash|/bin/sh|g' \
+ ${WRKSRC}/test/scripts/*
+
+test check: build
+ #
+ # Checks currently require ImageMagick's convert to be available
+ # and aren't enabled by default. They take a long time -- tail
+ # the log-file:
+ # ${WRKSRC}/test/test_all.sh.log
+ #
+ ${GMAKE} -C ${WRKSRC} check
+
+.include <bsd.port.pre.mk>
+
+.if ! ${PORT_OPTIONS:MDOCS}
+EXTRACT_AFTER_ARGS+= --exclude nipguide.pdf --exclude pdf
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/nip2/distinfo b/graphics/nip2/distinfo
index ffc79630175f..94343f98fdef 100644
--- a/graphics/nip2/distinfo
+++ b/graphics/nip2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nip2-7.26.3.tar.gz) = 94d842ffb6ba1d210ce7358c62f4f4cfa52c5663a2deb03f662aba29a0bee9d8
-SIZE (nip2-7.26.3.tar.gz) = 8681267
+SHA256 (nip2-7.40.1.tar.gz) = 67b46e6e6b488c6ed4e9212100d59ddeee34fac0977cc0c32aa0a21f29653a4d
+SIZE (nip2-7.40.1.tar.gz) = 9628285
diff --git a/graphics/nip2/files/extra-patch-src-parser.h b/graphics/nip2/files/extra-patch-src-parser.h
deleted file mode 100644
index 99565d9e1796..000000000000
--- a/graphics/nip2/files/extra-patch-src-parser.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/parser.h.orig 2011-01-25 19:44:07.000000000 +0300
-+++ src/parser.h 2013-11-28 04:22:09.853554221 +0400
-@@ -54,7 +54,7 @@
- */
- void yyerror( const char *sub, ... )
- __attribute__((format(printf, 1, 2)));
--extern int yyleng; /* lex stuff */
-+extern size_t yyleng; /* lex stuff */
-
- /* Lex gathers tokens here for workspace.c
- */
diff --git a/graphics/nip2/files/patch-src-graphwindow.c b/graphics/nip2/files/patch-src-graphwindow.c
index e8c5c6e1c528..e20fa3a7f689 100644
--- a/graphics/nip2/files/patch-src-graphwindow.c
+++ b/graphics/nip2/files/patch-src-graphwindow.c
@@ -1,4 +1,4 @@
---- src/graphwindow.c.orig 2011-01-25 19:44:07.000000000 +0300
+--- src/graphwindow.c 2011-01-25 19:44:07.000000000 +0300
+++ src/graphwindow.c 2013-11-28 03:48:15.996694984 +0400
@@ -260,7 +260,7 @@
diff --git a/graphics/nip2/files/patch-tests b/graphics/nip2/files/patch-tests
new file mode 100644
index 000000000000..3b5160656ef9
--- /dev/null
+++ b/graphics/nip2/files/patch-tests
@@ -0,0 +1,57 @@
+--- test/scripts/test_threading.sh 2013-08-19 16:56:45.000000000 -0400
++++ test/scripts/test_threading.sh 2014-07-01 11:54:10.000000000 -0400
+@@ -1,3 +1,3 @@
+-#!/bin/bash
++#!/bin/sh
+
+ # set -x
+@@ -28,14 +28,14 @@
+ vips im_abs $tmp/t8.v $tmp/t9.v
+ max=`vips im_max $tmp/t9.v`
+- if [[ $max > 0 ]]; then
++ if [ $max -gt 0 ]; then
+ break
+ fi
+ done
+- if [[ $max > 0 ]]; then
++ if [ $max -gt 0 ]; then
+ break
+ fi
+ done
+
+-if [[ $max > 0 ]]; then
++if [ $max -gt 0 ]; then
+ echo error, max == $max
+ exit 1
+@@ -43,3 +43,2 @@
+ echo all threading tests passed
+ fi
+-
+--- test/scripts/test_seq.sh 2014-06-23 15:17:21.000000000 -0400
++++ test/scripts/test_seq.sh 2014-07-01 12:38:53.000000000 -0400
+@@ -1,3 +1,3 @@
+-#!/bin/bash
++#!/bin/sh
+
+ # set -x
+@@ -18,5 +18,5 @@
+ rm -f $tmp/x.png
+ vipsthumbnail $huge -o $tmp/x.png
+-if ! vipsheader $tmp/x.png &> /dev/null ; then
++if ! vipsheader $tmp/x.png ; then
+ echo "vipsthumbnail failed in basic mode"
+ exit 1
+@@ -33,5 +33,5 @@
+ rm -f $tmp/x.png
+ vipsthumbnail $huge -o $tmp/x.png
+-if ! vipsheader $tmp/x.png &> /dev/null ; then
++if ! vipsheader $tmp/x.png ; then
+ echo "vipsthumbnail made a temp"
+ exit 1
+@@ -42,5 +42,5 @@
+ rm -f $tmp/x.png
+ vips shrink $huge $tmp/x.png 230 230
+-if ! vipsheader $tmp/x.png &> /dev/null; then
++if ! vipsheader $tmp/x.png ; then
+ echo "shrink made a temp"
+ exit 1
diff --git a/graphics/nip2/files/run-nip2.sh.in b/graphics/nip2/files/run-nip2.sh.in
new file mode 100644
index 000000000000..85aa89fa83de
--- /dev/null
+++ b/graphics/nip2/files/run-nip2.sh.in
@@ -0,0 +1,10 @@
+#!/bin/sh
+if [ -z "$VIPSHOME" ]
+then
+ export VIPSHOME=%%PREFIX%%
+fi
+if [ -z "$GDK_USE_XFT" ]
+then
+ export GDK_USE_XFT=1
+fi
+exec %%PREFIX%%/bin/nip2 "$@"
diff --git a/graphics/nip2/pkg-plist b/graphics/nip2/pkg-plist
index ace380096c30..994d4e051bd0 100644
--- a/graphics/nip2/pkg-plist
+++ b/graphics/nip2/pkg-plist
@@ -51,6 +51,8 @@ share/nip2/data/stock-led-blue-18.png
share/nip2/data/stock-led-cyan-18.png
share/nip2/data/stock-led-yellow-18.png
share/nip2/data/stock-led-off-18.png
+share/nip2/start/_magick.def
+share/nip2/start/Magick.def
share/nip2/start/Math.def
share/nip2/start/Image.def
share/nip2/start/Colour.def
@@ -194,7 +196,6 @@ share/nip2/compat/7.24/Image.def
share/nip2/compat/7.24/Math.def
share/nip2/compat/7.24/Matrix.def
share/nip2/compat/7.24/Object.def
-share/nip2/compat/7.24/Preferences.ws
share/nip2/compat/7.24/Tasks.def
share/nip2/compat/7.24/Widgets.def
share/nip2/compat/7.24/_Object.def
@@ -206,6 +207,60 @@ share/nip2/compat/7.24/_list.def
share/nip2/compat/7.24/_predicate.def
share/nip2/compat/7.24/_stdenv.def
share/nip2/compat/7.24/_types.def
+share/nip2/compat/7.26/Math.def
+share/nip2/compat/7.26/Image.def
+share/nip2/compat/7.26/Colour.def
+share/nip2/compat/7.26/Tasks.def
+share/nip2/compat/7.26/Object.def
+share/nip2/compat/7.26/Filter.def
+share/nip2/compat/7.26/Matrix.def
+share/nip2/compat/7.26/Widgets.def
+share/nip2/compat/7.26/Histogram.def
+share/nip2/compat/7.26/_joe_extra.def
+share/nip2/compat/7.26/_joe_utilities.def
+share/nip2/compat/7.26/_convert.def
+share/nip2/compat/7.26/_generate.def
+share/nip2/compat/7.26/_list.def
+share/nip2/compat/7.26/_predicate.def
+share/nip2/compat/7.26/_stdenv.def
+share/nip2/compat/7.26/_Object.def
+share/nip2/compat/7.26/_types.def
+share/nip2/compat/7.28/Math.def
+share/nip2/compat/7.28/Image.def
+share/nip2/compat/7.28/Colour.def
+share/nip2/compat/7.28/Tasks.def
+share/nip2/compat/7.28/Object.def
+share/nip2/compat/7.28/Filter.def
+share/nip2/compat/7.28/Matrix.def
+share/nip2/compat/7.28/Widgets.def
+share/nip2/compat/7.28/Histogram.def
+share/nip2/compat/7.28/_joe_extra.def
+share/nip2/compat/7.28/_joe_utilities.def
+share/nip2/compat/7.28/_convert.def
+share/nip2/compat/7.28/_generate.def
+share/nip2/compat/7.28/_list.def
+share/nip2/compat/7.28/_predicate.def
+share/nip2/compat/7.28/_stdenv.def
+share/nip2/compat/7.28/_Object.def
+share/nip2/compat/7.28/_types.def
+share/nip2/compat/7.38/Math.def
+share/nip2/compat/7.38/Image.def
+share/nip2/compat/7.38/Colour.def
+share/nip2/compat/7.38/Tasks.def
+share/nip2/compat/7.38/Object.def
+share/nip2/compat/7.38/Filter.def
+share/nip2/compat/7.38/Matrix.def
+share/nip2/compat/7.38/Widgets.def
+share/nip2/compat/7.38/Histogram.def
+share/nip2/compat/7.38/_joe_extra.def
+share/nip2/compat/7.38/_joe_utilities.def
+share/nip2/compat/7.38/_convert.def
+share/nip2/compat/7.38/_generate.def
+share/nip2/compat/7.38/_list.def
+share/nip2/compat/7.38/_predicate.def
+share/nip2/compat/7.38/_stdenv.def
+share/nip2/compat/7.38/_Object.def
+share/nip2/compat/7.38/_types.def
share/nip2/data/examples/1_point_mosaic/1pt_mosaic.ws
share/nip2/data/examples/1_point_mosaic/cd1.1.jpg
share/nip2/data/examples/1_point_mosaic/cd1.2.jpg
@@ -224,6 +279,8 @@ share/nip2/data/examples/2_point_mosaic/example_im_04.jpg
share/nip2/data/examples/2_point_mosaic/example_im_05.jpg
share/nip2/data/examples/2_point_mosaic/example_im_06.jpg
share/nip2/data/examples/2_point_mosaic/full_image.jpg
+share/nip2/data/stock-padlock-closed-22.png
+share/nip2/data/stock-alert-22.png
@dirrm share/nip2/data/examples/2_point_mosaic
@dirrm share/nip2/compat/7.8
@dirrm share/nip2/compat/7.9
@@ -232,6 +289,9 @@ share/nip2/data/examples/2_point_mosaic/full_image.jpg
@dirrm share/nip2/compat/7.14
@dirrm share/nip2/compat/7.16
@dirrm share/nip2/compat/7.24
+@dirrm share/nip2/compat/7.26
+@dirrm share/nip2/compat/7.28
+@dirrm share/nip2/compat/7.38
@dirrm share/nip2/compat
@dirrm share/nip2/data/examples/businesscard
@dirrm share/nip2/data/examples/clone
@@ -245,91 +305,82 @@ share/nip2/data/examples/2_point_mosaic/full_image.jpg
@dirrm share/nip2/rc
@dirrm share/nip2/start
@dirrm share/nip2
-%%DOCSDIR%%/html/figs/ir1.jpg
-%%DOCSDIR%%/html/figs/ir2.jpg
-%%DOCSDIR%%/html/figs/ir3.jpg
-%%DOCSDIR%%/html/figs/ir4.jpg
-%%DOCSDIR%%/html/figs/ir5.jpg
-%%DOCSDIR%%/html/figs/ir6.jpg
%%DOCSDIR%%/html/figs/ir7.jpg
+%%DOCSDIR%%/html/figs/ir5.jpg
%%DOCSDIR%%/html/figs/ir8a.jpg
-%%DOCSDIR%%/html/figs/ir9.jpg
-%%DOCSDIR%%/html/figs/mos2.png
-%%DOCSDIR%%/html/figs/scr21a.png
-%%DOCSDIR%%/html/figs/scr22.png
-%%DOCSDIR%%/html/figs/scr23.jpg
-%%DOCSDIR%%/html/figs/scr24.jpg
-%%DOCSDIR%%/html/figs/scr25.jpg
-%%DOCSDIR%%/html/figs/scr26.png
-%%DOCSDIR%%/html/figs/snap1.jpg
-%%DOCSDIR%%/html/figs/snap10.jpg
-%%DOCSDIR%%/html/figs/snap11.jpg
+%%DOCSDIR%%/html/figs/toolkit2.jpg
+%%DOCSDIR%%/html/figs/snap9.jpg
+%%DOCSDIR%%/html/figs/snap7a.jpg
%%DOCSDIR%%/html/figs/snap12.jpg
-%%DOCSDIR%%/html/figs/snap13.jpg
-%%DOCSDIR%%/html/figs/snap14.jpg
-%%DOCSDIR%%/html/figs/snap15.jpg
+%%DOCSDIR%%/html/figs/scr21a.png
+%%DOCSDIR%%/html/figs/ir3.jpg
%%DOCSDIR%%/html/figs/snap16.jpg
%%DOCSDIR%%/html/figs/snap2.jpg
-%%DOCSDIR%%/html/figs/snap3.jpg
+%%DOCSDIR%%/html/figs/snap13.jpg
+%%DOCSDIR%%/html/figs/snap14.jpg
%%DOCSDIR%%/html/figs/snap4.jpg
-%%DOCSDIR%%/html/figs/snap5.jpg
%%DOCSDIR%%/html/figs/snap6.jpg
-%%DOCSDIR%%/html/figs/snap7.jpg
-%%DOCSDIR%%/html/figs/snap7a.jpg
-%%DOCSDIR%%/html/figs/snap8.jpg
-%%DOCSDIR%%/html/figs/snap9.jpg
%%DOCSDIR%%/html/figs/toolkit.jpg
-%%DOCSDIR%%/html/figs/toolkit2.jpg
+%%DOCSDIR%%/html/figs/snap15.jpg
+%%DOCSDIR%%/html/figs/ir2.jpg
+%%DOCSDIR%%/html/figs/snap7.jpg
+%%DOCSDIR%%/html/figs/snap10.jpg
+%%DOCSDIR%%/html/figs/snap11.jpg
+%%DOCSDIR%%/html/figs/ir4.jpg
+%%DOCSDIR%%/html/figs/snap1.jpg
+%%DOCSDIR%%/html/figs/snap5.jpg
+%%DOCSDIR%%/html/figs/snap3.jpg
%%DOCSDIR%%/html/figs/toolkit3.jpg
-%%DOCSDIR%%/html/nipguide.css
-%%DOCSDIR%%/html/nipguide.html
-%%DOCSDIR%%/html/nipguide37.html
-%%DOCSDIR%%/html/nipguideap1.html
-%%DOCSDIR%%/html/nipguidech1.html
-%%DOCSDIR%%/html/nipguidech2.html
-%%DOCSDIR%%/html/nipguidech3.html
-%%DOCSDIR%%/html/nipguidech4.html
+%%DOCSDIR%%/html/figs/snap8.jpg
+%%DOCSDIR%%/html/nipguidese33.html
+%%DOCSDIR%%/html/nipguidese24.html
+%%DOCSDIR%%/html/nipguidese21.html
%%DOCSDIR%%/html/nipguidech5.html
+%%DOCSDIR%%/html/nipguidese31.html
%%DOCSDIR%%/html/nipguidech6.html
-%%DOCSDIR%%/html/nipguideli1.html
+%%DOCSDIR%%/html/nipguidese4.html
%%DOCSDIR%%/html/nipguideli2.html
-%%DOCSDIR%%/html/nipguideli3.html
-%%DOCSDIR%%/html/nipguidese1.html
-%%DOCSDIR%%/html/nipguidese10.html
-%%DOCSDIR%%/html/nipguidese11.html
-%%DOCSDIR%%/html/nipguidese12.html
-%%DOCSDIR%%/html/nipguidese13.html
-%%DOCSDIR%%/html/nipguidese14.html
-%%DOCSDIR%%/html/nipguidese15.html
-%%DOCSDIR%%/html/nipguidese16.html
-%%DOCSDIR%%/html/nipguidese17.html
-%%DOCSDIR%%/html/nipguidese18.html
-%%DOCSDIR%%/html/nipguidese19.html
+%%DOCSDIR%%/html/nipguidese8.html
%%DOCSDIR%%/html/nipguidese2.html
%%DOCSDIR%%/html/nipguidese20.html
-%%DOCSDIR%%/html/nipguidese21.html
-%%DOCSDIR%%/html/nipguidese22.html
-%%DOCSDIR%%/html/nipguidese23.html
-%%DOCSDIR%%/html/nipguidese24.html
+%%DOCSDIR%%/html/nipguidese6.html
+%%DOCSDIR%%/html/nipguidese16.html
+%%DOCSDIR%%/html/nipguide37.html
+%%DOCSDIR%%/html/nipguidese18.html
+%%DOCSDIR%%/html/nipguidese30.html
+%%DOCSDIR%%/html/nipguidese34.html
+%%DOCSDIR%%/html/nipguidese29.html
+%%DOCSDIR%%/html/nipguide.html
+%%DOCSDIR%%/html/nipguidech1.html
+%%DOCSDIR%%/html/nipguideli1.html
+%%DOCSDIR%%/html/nipguidese11.html
%%DOCSDIR%%/html/nipguidese25.html
+%%DOCSDIR%%/html/nipguide.css
+%%DOCSDIR%%/html/nipguidese9.html
+%%DOCSDIR%%/html/nipguidese3.html
+%%DOCSDIR%%/html/nipguidese22.html
+%%DOCSDIR%%/html/nipguidese15.html
%%DOCSDIR%%/html/nipguidese26.html
+%%DOCSDIR%%/html/nipguidese23.html
%%DOCSDIR%%/html/nipguidese27.html
+%%DOCSDIR%%/html/nipguideap1.html
+%%DOCSDIR%%/html/nipguidese1.html
+%%DOCSDIR%%/html/nipguidese5.html
+%%DOCSDIR%%/html/nipguidese12.html
%%DOCSDIR%%/html/nipguidese28.html
-%%DOCSDIR%%/html/nipguidese29.html
-%%DOCSDIR%%/html/nipguidese3.html
-%%DOCSDIR%%/html/nipguidese30.html
-%%DOCSDIR%%/html/nipguidese31.html
-%%DOCSDIR%%/html/nipguidese32.html
-%%DOCSDIR%%/html/nipguidese33.html
-%%DOCSDIR%%/html/nipguidese34.html
-%%DOCSDIR%%/html/nipguidese35.html
+%%DOCSDIR%%/html/nipguidese17.html
+%%DOCSDIR%%/html/nipguidech3.html
%%DOCSDIR%%/html/nipguidese36.html
-%%DOCSDIR%%/html/nipguidese4.html
-%%DOCSDIR%%/html/nipguidese5.html
-%%DOCSDIR%%/html/nipguidese6.html
+%%DOCSDIR%%/html/nipguideli3.html
%%DOCSDIR%%/html/nipguidese7.html
-%%DOCSDIR%%/html/nipguidese8.html
-%%DOCSDIR%%/html/nipguidese9.html
+%%DOCSDIR%%/html/nipguidese19.html
+%%DOCSDIR%%/html/nipguidech4.html
+%%DOCSDIR%%/html/nipguidese32.html
+%%DOCSDIR%%/html/nipguidese13.html
+%%DOCSDIR%%/html/nipguidech2.html
+%%DOCSDIR%%/html/nipguidese10.html
+%%DOCSDIR%%/html/nipguidese14.html
+%%DOCSDIR%%/html/nipguidese35.html
%%PORTDOCS%%%%DOCSDIR%%/pdf/nipguide.pdf
%%PORTDOCS%%@dirrm %%DOCSDIR%%/pdf
@dirrm %%DOCSDIR%%/html/figs
diff --git a/graphics/vips/Makefile b/graphics/vips/Makefile
index 96da514e09a4..b261b6aaf8a0 100644
--- a/graphics/vips/Makefile
+++ b/graphics/vips/Makefile
@@ -2,30 +2,29 @@
# $FreeBSD$
PORTNAME= vips
-PORTVERSION= 7.26.3
-PORTREVISION= 10
+PORTVERSION= 7.40.2
CATEGORIES= graphics
MASTER_SITES= http://www.vips.ecs.soton.ac.uk/supported/${PORTVERSION:R}/
MAINTAINER= mi@aldan.algebra.com
COMMENT= Free image processing system
-OPTIONS_DEFINE= LIBOIL PYTHON DOCS
-OPTIONS_DEFAULT= LIBOIL
-LIBOIL_DESC= Use liboil for CPU-optimized primitives
+OPTIONS_DEFINE= PYTHON DOCS
+OPTIONS_DEFAULT=
PYTHON_DESC= Create Python bindings
BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
LIB_DEPENDS= libfftw3.so:${PORTSDIR}/math/fftw3 \
libjpeg.so:${PORTSDIR}/graphics/jpeg \
libexif.so:${PORTSDIR}/graphics/libexif \
+ liblcms2.so:${PORTSDIR}/graphics/lcms2 \
libtiff.so:${PORTSDIR}/graphics/tiff \
libGraphicsMagick.so:${PORTSDIR}/graphics/GraphicsMagick \
libIlmImf.so:${PORTSDIR}/graphics/OpenEXR \
- liborc-0.4.so:${PORTSDIR}/devel/orc \
+ liborc-0.4.so:${PORTSDIR}/devel/orc \
+ libcfitsio.so:${PORTSDIR}/astro/cfitsio \
libpng15.so:${PORTSDIR}/graphics/png \
- libmatio.so:${PORTSDIR}/math/matio \
- liblcms.so:${PORTSDIR}/graphics/lcms
+ libmatio.so:${PORTSDIR}/math/matio
PYPRESENT!= which python > /dev/null && echo on || echo off
.if ${PYPRESENT} == on
@@ -34,7 +33,7 @@ OPTIONS_DEFAULT+= PYTHON
USES= gettext gmake libtool pathfix perl5 pkgconfig shebangfix
USE_PERL5= build
SHEBANG_FILES= tools/vips-${PORTVERSION:R}
-USE_GNOME= glib20 pango libxml2
+USE_GNOME= glib20 pango libxml2 libgsf
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
@@ -44,16 +43,17 @@ post-configure:
${WRKSRC}/po/Makefile
.include <bsd.port.options.mk>
-# Don't extract doc/ subdirectory - the simplest way:
+
.if ! ${PORT_OPTIONS:MDOCS}
-EXTRACT_AFTER_ARGS= --exclude doc
-EXTRA_PATCHES= ${FILESDIR}/nodoc-patch
+CONFIGURE_ARGS+=--disable-docs
+EXTRACT_AFTER_ARGS+= --exclude doc
+EXTRA_PATCHES+= ${FILESDIR}/nodoc-patch
.endif
+
PLIST_SUB+= VERSION=${PORTVERSION:R}
CONFIGURE_ENV+= MAGICK_CFLAGS="-I${LOCALBASE}/include/GraphicsMagick"
CONFIGURE_ARGS+=--without-x --mandir=${STAGEDIR}${PREFIX}/man --with-magickpackage=GraphicsMagick
-CONFIGURE_ARGS+=--without-v4l
.for p in tiff jpeg zip png
CONFIGURE_ARGS+=--with-$p-includes=${LOCALBASE}/include
CONFIGURE_ARGS+=--with-$p-libraries=${LOCALBASE}/lib
@@ -62,25 +62,14 @@ CONFIGURE_ARGS+=--with-$p-libraries=${LOCALBASE}/lib
.if ${PORT_OPTIONS:MPYTHON}
USE_PYTHON= yes
PLIST_SUB+= PY=""
-.else
-CONFIGURE_ARGS= --without-python
-PLIST_SUB+= PY="@comment "
-.endif
-.include <bsd.port.pre.mk>
+post-patch::
+ ${REINPLACE_CMD} -e 's|/usr/bin/python|${PYTHON_CMD}|' \
+ ${WRKSRC}/tools/vipsprofile
-.if ${ARCH} == "sparc64" && ${OSVERSION} > 900000
-BROKEN= Does not compile on sparc64-9
-.endif
-
-.if ${PORT_OPTIONS:MLIBOIL}
-LIB_DEPENDS+= liboil-0.3.so:${PORTSDIR}/devel/liboil
.else
-CONFIGURE_ARGS+= --without-liboil
+CONFIGURE_ARGS= --without-python
+PLIST_SUB+= PY="@comment "
.endif
-post-patch:
- @${REINPLACE_CMD} -e '/VIPS_CXX_LIBS="-lstdc++"/ d' \
- ${WRKSRC}/configure.in ${WRKSRC}/configure
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/vips/distinfo b/graphics/vips/distinfo
index 13de38bc7585..c6b76821afc3 100644
--- a/graphics/vips/distinfo
+++ b/graphics/vips/distinfo
@@ -1,2 +1,2 @@
-SHA256 (vips-7.26.3.tar.gz) = 9acbe13f391bde2e1748e62a3f2e07a4319ad07c2502cc1ee4422f0a6cbd12a0
-SIZE (vips-7.26.3.tar.gz) = 3163591
+SHA256 (vips-7.40.2.tar.gz) = fd90faa0ccdf5397ca9c2c4944fcfefdfab23b292a74d23443a25d7752d30604
+SIZE (vips-7.40.2.tar.gz) = 3484259
diff --git a/graphics/vips/files/nodoc-patch b/graphics/vips/files/nodoc-patch
index 8467265d5b07..26c33afd44f9 100644
--- a/graphics/vips/files/nodoc-patch
+++ b/graphics/vips/files/nodoc-patch
@@ -1,13 +1,13 @@
-Remove Makefiles under the doc/ subdirectory, which we choose to not even extract,
-much less install, from the list...
+Remove Makefiles under the doc/ subdirectory, which we choose to
+not even extract, much less install, from the list...
---- configure 2011-08-19 11:59:12.000000000 -0400
-+++ configure 2011-09-23 17:34:13.000000000 -0400
-@@ -22859,5 +22859,5 @@
- # vips-$VIPS_MAJOR_VERSION.$VIPS_MINOR_VERSION.pc
- # in AC_OUTPUT, but that seems to break for some combinations of sh/m4
--ac_config_files="$ac_config_files vips-7.26.pc vipsCC-7.26.pc Makefile libvips/include/vips/version.h libvips/include/Makefile libvips/include/vips/Makefile libvips/Makefile libvips/arithmetic/Makefile libvips/boolean/Makefile libvips/cimg/Makefile libvips/colour/Makefile libvips/conversion/Makefile libvips/convolution/Makefile libvips/deprecated/Makefile libvips/format/Makefile libvips/freq_filt/Makefile libvips/histograms_lut/Makefile libvips/inplace/Makefile libvips/iofuncs/Makefile libvips/mask/Makefile libvips/morphology/Makefile libvips/mosaicing/Makefile libvips/other/Makefile libvips/relational/Makefile libvips/resample/Makefile libvips/video/Makefile libvipsCC/include/Makefile libvipsCC/include/vips/Makefile libvipsCC/Makefile tools/Makefile tools/batch_crop tools/batch_image_convert tools/batch_rubber_sheet tools/light_correct tools/shrink_width swig/Makefile swig/vipsCC/Makefile swig/python/setup.py man/Makefile doc/Makefile doc/reference/Makefile doc/reference/libvips-docs.sgml po/Makefile.in"
-+ac_config_files="$ac_config_files vips-7.26.pc vipsCC-7.26.pc Makefile libvips/include/vips/version.h libvips/include/Makefile libvips/include/vips/Makefile libvips/Makefile libvips/arithmetic/Makefile libvips/boolean/Makefile libvips/cimg/Makefile libvips/colour/Makefile libvips/conversion/Makefile libvips/convolution/Makefile libvips/deprecated/Makefile libvips/format/Makefile libvips/freq_filt/Makefile libvips/histograms_lut/Makefile libvips/inplace/Makefile libvips/iofuncs/Makefile libvips/mask/Makefile libvips/morphology/Makefile libvips/mosaicing/Makefile libvips/other/Makefile libvips/relational/Makefile libvips/resample/Makefile libvips/video/Makefile libvipsCC/include/Makefile libvipsCC/include/vips/Makefile libvipsCC/Makefile tools/Makefile tools/batch_crop tools/batch_image_convert tools/batch_rubber_sheet tools/light_correct tools/shrink_width swig/Makefile swig/vipsCC/Makefile swig/python/setup.py man/Makefile po/Makefile.in"
+--- configure 2014-06-23 16:48:44.000000000 -0400
++++ configure 2014-06-24 11:02:30.000000000 -0400
+@@ -25207,5 +25207,5 @@
+
+
+-ac_config_files="$ac_config_files vips.pc vipsCC.pc Makefile libvips/include/vips/version.h libvips/include/Makefile libvips/include/vips/Makefile libvips/Makefile libvips/arithmetic/Makefile libvips/cimg/Makefile libvips/colour/Makefile libvips/conversion/Makefile libvips/convolution/Makefile libvips/deprecated/Makefile libvips/foreign/Makefile libvips/freqfilt/Makefile libvips/histogram/Makefile libvips/draw/Makefile libvips/iofuncs/Makefile libvips/morphology/Makefile libvips/mosaicing/Makefile libvips/create/Makefile libvips/resample/Makefile libvips/video/Makefile libvipsCC/include/Makefile libvipsCC/include/vips/Makefile libvipsCC/Makefile tools/Makefile tools/batch_crop tools/batch_image_convert tools/batch_rubber_sheet tools/light_correct tools/shrink_width swig/Makefile swig/vipsCC/Makefile swig/python/setup.py man/Makefile doc/Makefile doc/reference/Makefile doc/reference/libvips-docs.sgml po/Makefile.in"
++ac_config_files="$ac_config_files vips.pc vipsCC.pc Makefile libvips/include/vips/version.h libvips/include/Makefile libvips/include/vips/Makefile libvips/Makefile libvips/arithmetic/Makefile libvips/cimg/Makefile libvips/colour/Makefile libvips/conversion/Makefile libvips/convolution/Makefile libvips/deprecated/Makefile libvips/foreign/Makefile libvips/freqfilt/Makefile libvips/histogram/Makefile libvips/draw/Makefile libvips/iofuncs/Makefile libvips/morphology/Makefile libvips/mosaicing/Makefile libvips/create/Makefile libvips/resample/Makefile libvips/video/Makefile libvipsCC/include/Makefile libvipsCC/include/vips/Makefile libvipsCC/Makefile tools/Makefile tools/batch_crop tools/batch_image_convert tools/batch_rubber_sheet tools/light_correct tools/shrink_width swig/Makefile swig/vipsCC/Makefile swig/python/setup.py man/Makefile po/Makefile.in"
cat >confcache <<\_ACEOF
--- Makefile.in 2011-08-19 11:59:16.000000000 -0400
@@ -25,11 +25,3 @@ much less install, from the list...
- doc \
$(C_COMPILE_DIR) \
$(P_COMPILE_DIR)
-@@ -907,7 +906,4 @@
-
- install-exec-hook:
-- -rm -rf ${DESTDIR}$(datadir)/doc/vips
-- $(mkinstalldirs) ${DESTDIR}$(datadir)/doc/vips
-- -cp -r ${top_srcdir}/doc/html ${top_srcdir}/doc/pdf ${DESTDIR}$(datadir)/doc/vips
-
- dist-hook:
diff --git a/graphics/vips/files/patch-libsrc-conversion-im_tiff2vips.c b/graphics/vips/files/patch-libsrc-conversion-im_tiff2vips.c
deleted file mode 100644
index 3ba015175492..000000000000
--- a/graphics/vips/files/patch-libsrc-conversion-im_tiff2vips.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- libvips/format/im_tiff2vips.c Wed Aug 17 06:34:12 2005
-+++ libvips/format/im_tiff2vips.c
-@@ -157,6 +157,12 @@
- #include <vips/vips.h>
- #include <vips/thread.h>
-
-+#undef D50_X0
-+#undef D50_Y0
-+#undef D50_Z0
-+#undef D65_X0
-+#undef D65_Y0
-+#undef D65_Z0
- #include <tiffio.h>
-
- #ifdef WITH_DMALLOC
diff --git a/graphics/vips/files/patch-libsrc-conversion-im_vips2tiff.c b/graphics/vips/files/patch-libsrc-conversion-im_vips2tiff.c
deleted file mode 100644
index 7ba268f72d44..000000000000
--- a/graphics/vips/files/patch-libsrc-conversion-im_vips2tiff.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- libvips/format/im_vips2tiff.c Fri Mar 3 03:06:32 2006
-+++ libvips/format/im_vips2tiff.c
-@@ -145,6 +145,12 @@
-
- #include <vips/vips.h>
-
-+#undef D50_X0
-+#undef D50_Y0
-+#undef D50_Z0
-+#undef D65_X0
-+#undef D65_Y0
-+#undef D65_Z0
- #include <tiffio.h>
-
- #ifdef WITH_DMALLOC
diff --git a/graphics/vips/files/patch-v4l b/graphics/vips/files/patch-v4l
deleted file mode 100644
index 9a4b9419b184..000000000000
--- a/graphics/vips/files/patch-v4l
+++ /dev/null
@@ -1,8 +0,0 @@
---- libvips/video/im_video_v4l1.c 2011-07-27 09:30:13.000000000 -0400
-+++ libvips/video/im_video_v4l1.c 2011-09-20 17:52:50.000000000 -0400
-@@ -54,5 +54,4 @@
-
- #include <fcntl.h>
--#include <linux/types.h>
- #include <linux/videodev.h>
-
diff --git a/graphics/vips/pkg-plist b/graphics/vips/pkg-plist
index 23cba497a349..499c4e105403 100644
--- a/graphics/vips/pkg-plist
+++ b/graphics/vips/pkg-plist
@@ -1,44 +1,44 @@
-bin/mergeup
-bin/find_mosaic
bin/vips
-bin/edvips
+bin/vipsedit
bin/vipsthumbnail
-bin/header
+bin/vipsheader
bin/light_correct
bin/shrink_width
bin/batch_image_convert
bin/batch_rubber_sheet
bin/batch_crop
+bin/vipsprofile
bin/vips-%%VERSION%%
+include/vips/basic.h
+include/vips/type.h
+include/vips/gate.h
include/vips/almostdeprecated.h
include/vips/deprecated.h
include/vips/arithmetic.h
-include/vips/boolean.h
include/vips/buf.h
include/vips/colour.h
include/vips/conversion.h
include/vips/convolution.h
include/vips/debug.h
include/vips/dispatch.h
-include/vips/disp.h
include/vips/enumtypes.h
include/vips/error.h
include/vips/operation.h
include/vips/format.h
-include/vips/inplace.h
+include/vips/foreign.h
+include/vips/draw.h
include/vips/generate.h
include/vips/header.h
-include/vips/histograms_lut.h
-include/vips/freq_filt.h
+include/vips/histogram.h
+include/vips/freqfilt.h
include/vips/image.h
include/vips/interpolate.h
include/vips/intl.h
include/vips/mask.h
-include/vips/pool.h
include/vips/memory.h
include/vips/morphology.h
include/vips/mosaicing.h
-include/vips/other.h
+include/vips/create.h
include/vips/video.h
include/vips/cimg_funcs.h
include/vips/object.h
@@ -58,32 +58,33 @@ include/vips/vips7compat.h
include/vips/vips.h
include/vips/VDisplay.h
include/vips/VError.h
-include/vips/VImage.h
include/vips/VMask.h
+include/vips/VImage.h
include/vips/vipscpp.h
include/vips/vips
include/vips/vipsc++.h
@dirrm include/vips
lib/libvips.a
-lib/libvips.so.15
-lib/libvips.so.15.15.2
+lib/libvips.so.38
+lib/libvips.so.38.0.0
lib/libvips.so
lib/libvipsCC.a
lib/libvipsCC.so
-lib/libvipsCC.so.15
-lib/libvipsCC.so.15.15.2
-libdata/pkgconfig/vips-%%VERSION%%.pc
-libdata/pkgconfig/vipsCC-%%VERSION%%.pc
+lib/libvipsCC.so.38
+lib/libvipsCC.so.38.0.0
+libdata/pkgconfig/vips.pc
+libdata/pkgconfig/vipsCC.pc
man/man1/batch_crop.1.gz
man/man1/batch_image_convert.1.gz
man/man1/batch_rubber_sheet.1.gz
-man/man1/edvips.1.gz
-man/man1/header.1.gz
man/man1/light_correct.1.gz
man/man1/vips.1.gz
+man/man1/vipsedit.1.gz
+man/man1/vipsheader.1.gz
+man/man1/vipsprofile.1.gz
man/man1/vipsthumbnail.1.gz
-share/locale/de/LC_MESSAGES/vips7.mo
-share/locale/en_GB/LC_MESSAGES/vips7.mo
+share/locale/de/LC_MESSAGES/vips%%VERSION%%.mo
+share/locale/en_GB/LC_MESSAGES/vips%%VERSION%%.mo
%%PORTDOCS%%share/doc/vips/pdf/vipsmanual.pdf
%%PORTDOCS%%@dirrm share/doc/vips/pdf
%%PORTDOCS%%share/doc/vips/html/figs/arch.png
@@ -170,13 +171,9 @@ share/locale/en_GB/LC_MESSAGES/vips7.mo
%%PORTDOCS%%@dirrmtry share/gtk-doc/html
%%PORTDOCS%%@dirrmtry share/gtk-doc
%%PY%%%%PYTHON_SITELIBDIR%%/vipsCC/vimagemodule.so
-%%PY%%%%PYTHON_SITELIBDIR%%/vipsCC/vimagemodule.la
%%PY%%%%PYTHON_SITELIBDIR%%/vipsCC/vdisplaymodule.so
-%%PY%%%%PYTHON_SITELIBDIR%%/vipsCC/vdisplaymodule.la
%%PY%%%%PYTHON_SITELIBDIR%%/vipsCC/verrormodule.so
-%%PY%%%%PYTHON_SITELIBDIR%%/vipsCC/verrormodule.la
%%PY%%%%PYTHON_SITELIBDIR%%/vipsCC/vmaskmodule.so
-%%PY%%%%PYTHON_SITELIBDIR%%/vipsCC/vmaskmodule.la
%%PY%%%%PYTHON_SITELIBDIR%%/vipsCC/vimagemodule.a
%%PY%%%%PYTHON_SITELIBDIR%%/vipsCC/vdisplaymodule.a
%%PY%%%%PYTHON_SITELIBDIR%%/vipsCC/verrormodule.a