aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/Makefile1
-rw-r--r--audio/azrael/Makefile27
-rw-r--r--audio/azrael/distinfo3
-rw-r--r--audio/azrael/pkg-descr6
4 files changed, 37 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 65f901c89ac9..a0f738bff177 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -43,6 +43,7 @@
SUBDIR += autools
SUBDIR += autozen
SUBDIR += aylet
+ SUBDIR += azrael
SUBDIR += baudline
SUBDIR += beast
SUBDIR += bebocd
diff --git a/audio/azrael/Makefile b/audio/azrael/Makefile
new file mode 100644
index 000000000000..f867da720c7d
--- /dev/null
+++ b/audio/azrael/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: azrael
+# Date created: 25 Aug 2006
+# Whom: Alexander Botero-Lowry <alex@foxybanana.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= azrael
+PORTVERSION= 0.3.5
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= azrael
+
+MAINTAINER= alex@foxybanana.com
+COMMENT= A GTK2 based XMMS2 client, offering a media library interface
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libxmmsclient.so:${PORTSDIR}/audio/xmms2
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= gtk20
+
+PLIST_FILES=bin/azrael
+
+.include <bsd.port.mk>
diff --git a/audio/azrael/distinfo b/audio/azrael/distinfo
new file mode 100644
index 000000000000..43577ebd7a11
--- /dev/null
+++ b/audio/azrael/distinfo
@@ -0,0 +1,3 @@
+MD5 (azrael-0.3.5.tar.bz2) = 7e20d0f54a44a4c139c53f8e4db17640
+SHA256 (azrael-0.3.5.tar.bz2) = d24ed7c6c12b7afb649885ab0626b741b5cedb528d64acf4abf86e9d59a2227f
+SIZE (azrael-0.3.5.tar.bz2) = 19532
diff --git a/audio/azrael/pkg-descr b/audio/azrael/pkg-descr
new file mode 100644
index 000000000000..2ad820352bfd
--- /dev/null
+++ b/audio/azrael/pkg-descr
@@ -0,0 +1,6 @@
+Azrael is a client for XMMS2. It is written in C and uses GTK.
+
+Features include:
+ * LCD for elapsed time,
+ * Nice display of song information
+ * Interfaces to the playlist and media library