aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--astro/ksetiwatch/Makefile7
-rw-r--r--deskutils/kluje/Makefile7
-rw-r--r--deskutils/knowit/Makefile9
-rw-r--r--games/easysok/Makefile9
-rw-r--r--games/easysok/files/patch-src_Makefile.in11
-rw-r--r--games/kslide/Makefile9
-rw-r--r--games/taxipilot/Makefile15
-rw-r--r--graphics/kbarcode/Makefile9
-rw-r--r--graphics/kbarcode/files/patch-kbarcode_Makefile.in11
-rw-r--r--sysutils/pwg/Makefile9
-rw-r--r--x11-themes/qnxstyle/Makefile9
-rw-r--r--x11-themes/qnxstyle/files/patch-src_Makefile.in11
-rw-r--r--x11-wm/qnxstyle/Makefile9
-rw-r--r--x11-wm/qnxstyle/files/patch-src_Makefile.in11
14 files changed, 97 insertions, 39 deletions
diff --git a/astro/ksetiwatch/Makefile b/astro/ksetiwatch/Makefile
index 2fdc724f77b2..2e2372a6562d 100644
--- a/astro/ksetiwatch/Makefile
+++ b/astro/ksetiwatch/Makefile
@@ -20,8 +20,7 @@ GNU_CONFIGURE= yes
USE_REINPLACE= yes
post-patch:
- @${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e 's|-O2||g' -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/deskutils/kluje/Makefile b/deskutils/kluje/Makefile
index a645a986ca93..9b8b80052f1b 100644
--- a/deskutils/kluje/Makefile
+++ b/deskutils/kluje/Makefile
@@ -21,8 +21,7 @@ GNU_CONFIGURE= yes
USE_REINPLACE= yes
post-patch:
- @${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e 's|-O2||g' -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/deskutils/knowit/Makefile b/deskutils/knowit/Makefile
index de2b6a4b14d2..e502c5597235 100644
--- a/deskutils/knowit/Makefile
+++ b/deskutils/knowit/Makefile
@@ -20,7 +20,10 @@ USE_BZIP2= yes
USE_KDELIBS_VER= 3
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||g' -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>
diff --git a/games/easysok/Makefile b/games/easysok/Makefile
index 2f46d7e8c829..53a140cbd0d2 100644
--- a/games/easysok/Makefile
+++ b/games/easysok/Makefile
@@ -17,7 +17,10 @@ COMMENT= A sokoban game for KDE3
USE_KDELIBS_VER= 3
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||g' -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>
diff --git a/games/easysok/files/patch-src_Makefile.in b/games/easysok/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..9d358467dec9
--- /dev/null
+++ b/games/easysok/files/patch-src_Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Fri May 21 22:37:02 2004
++++ src/Makefile.in Fri May 21 22:37:18 2004
+@@ -248,7 +248,7 @@
+
+ easysok_SOURCES = dummy.cpp
+ easysok_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+-easysok_LDADD = easysok.la $(LIB_KDEUI) $(LIB_KFILE) $(LIB_KIO) $(LIB_MNG) -lkdeprint
++easysok_LDADD = easysok.la $(LIB_KDEUI) $(LIB_KFILE) $(LIB_KIO) $(LIB_MNG) -lkdeprint $(LIBPTHREAD)
+
+ easysok_la_SOURCES = atomic_move.cpp move.cpp movements.cpp hash.cpp map.cpp \
+ compressed_map.cpp level.cpp collection.cpp collection_holder.cpp \
diff --git a/games/kslide/Makefile b/games/kslide/Makefile
index 11fb8f08ed60..7f34f1a6a83a 100644
--- a/games/kslide/Makefile
+++ b/games/kslide/Makefile
@@ -18,7 +18,10 @@ COMMENT= KDE puzzle game
USE_BZIP2= yes
USE_KDELIBS_VER= 3
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||g' -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>
diff --git a/games/taxipilot/Makefile b/games/taxipilot/Makefile
index 40427838a044..67ef0236c831 100644
--- a/games/taxipilot/Makefile
+++ b/games/taxipilot/Makefile
@@ -19,16 +19,11 @@ LIB_DEPENDS= artsmodules.0:${PORTSDIR}/multimedia/kdemultimedia3
USE_KDELIBS_VER= 3
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_AUTOCONF_VER= 253
-USE_AUTOHEADER= yes
-MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
- AUTOHEADER="${TRUE}"
-
-.include <bsd.port.pre.mk>
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
post-patch:
- @${REINPLACE_CMD} -e 's| -pedantic||g ; \
- s|-pthread|${PTHREAD_LIBS}|g' ${WRKSRC}/aclocal.m4
+ @${REINPLACE_CMD} -e 's|-O2||g' -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/kbarcode/Makefile b/graphics/kbarcode/Makefile
index 0bd4bae10b82..98cb258316b2 100644
--- a/graphics/kbarcode/Makefile
+++ b/graphics/kbarcode/Makefile
@@ -20,7 +20,10 @@ RUN_DEPENDS= barcode:${PORTSDIR}/graphics/barcode
USE_KDELIBS_VER= 3
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||g' -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>
diff --git a/graphics/kbarcode/files/patch-kbarcode_Makefile.in b/graphics/kbarcode/files/patch-kbarcode_Makefile.in
new file mode 100644
index 000000000000..3c25aa57f269
--- /dev/null
+++ b/graphics/kbarcode/files/patch-kbarcode_Makefile.in
@@ -0,0 +1,11 @@
+--- kbarcode/Makefile.in.orig Fri May 21 23:23:23 2004
++++ kbarcode/Makefile.in Fri May 21 23:24:01 2004
+@@ -259,7 +259,7 @@
+
+ # the application source, library search path, and link libraries
+ kbarcode_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+-kbarcode_LDADD = $(LIB_KABC) $(LIB_KSPELL) $(LIB_KDEPRINT) $(LIB_KDEUI)
++kbarcode_LDADD = $(LIB_KABC) $(LIB_KSPELL) $(LIB_KDEPRINT) $(LIB_KDEUI) $(LIBPTHREAD)
+ noinst_HEADERS = barcodecache.h barcodecombo.h barcodedialog.h barcodedialogs.h commands.h configdialog.h confwizard.h csvimportdlg.h databasebrowser.h definition.h definitiondialog.h dsmainwindow.h dsrichtext.h kbarcode.h label.h labeleditor.h labelprinter.h labelutils.h mimesources.h multilineeditdlg.h mybarcode.h mycanvasitem.h mycanvasview.h mydatatable.h newlabel.h previewdialog.h printersettings.h printlabeldlg.h rectsettingsdlg.h smalldialogs.h sqltables.h tokenprovider.h xmlutils.h zplutils.h
+ kbarcode_SOURCES = barcodecombo.cpp barcodecache.cpp barcodedialog.cpp barcodedialogs.cpp commands.cpp configdialog.cpp confwizard.cpp csvimportdlg.cpp databasebrowser.cpp definition.cpp definitiondialog.cpp dsmainwindow.cpp dsrichtext.cpp kbarcode.cpp label.cpp labeleditor.cpp labelprinter.cpp labelutils.cpp main.cpp mimesources.cpp multilineeditdlg.cpp mybarcode.cpp mycanvasitem.cpp mycanvasview.cpp mydatatable.cpp newlabel.cpp previewdialog.cpp printersettings.cpp printlabeldlg.cpp rectsettingsdlg.cpp smalldialogs.cpp sqltables.cpp tokenprovider.cpp xmlutils.cpp zplutils.cpp
+
diff --git a/sysutils/pwg/Makefile b/sysutils/pwg/Makefile
index a0d3d3f29884..5c0b9ba6f1d4 100644
--- a/sysutils/pwg/Makefile
+++ b/sysutils/pwg/Makefile
@@ -19,7 +19,10 @@ USE_BZIP2= yes
USE_KDELIBS_VER= 3
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||g' -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>
diff --git a/x11-themes/qnxstyle/Makefile b/x11-themes/qnxstyle/Makefile
index ab0f1e58e7dc..4511f2062ab2 100644
--- a/x11-themes/qnxstyle/Makefile
+++ b/x11-themes/qnxstyle/Makefile
@@ -22,11 +22,14 @@ USE_KDELIBS_VER= 3
USE_GMAKE= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
PLIST_FILES= lib/kde3/plugins/styles/qnx.so \
lib/kde3/plugins/styles/qnx.la \
share/apps/kstyle/themes/qnx.themerc
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||g' -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>
diff --git a/x11-themes/qnxstyle/files/patch-src_Makefile.in b/x11-themes/qnxstyle/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..e4e6bc88a88b
--- /dev/null
+++ b/x11-themes/qnxstyle/files/patch-src_Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Sat May 22 00:01:43 2004
++++ src/Makefile.in Sat May 22 00:02:13 2004
+@@ -228,7 +228,7 @@
+ noinst_HEADERS = qnx.h
+ kde_style_LTLIBRARIES = qnx.la
+ qnx_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -lkdefx -module
+-qnx_la_LIBADD =
++qnx_la_LIBADD = $(LIBPTHREAD)
+ qnx_la_SOURCES = qnx.cpp
+ #>- qnx_la_METASOURCES = AUTO
+
diff --git a/x11-wm/qnxstyle/Makefile b/x11-wm/qnxstyle/Makefile
index ab0f1e58e7dc..4511f2062ab2 100644
--- a/x11-wm/qnxstyle/Makefile
+++ b/x11-wm/qnxstyle/Makefile
@@ -22,11 +22,14 @@ USE_KDELIBS_VER= 3
USE_GMAKE= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
PLIST_FILES= lib/kde3/plugins/styles/qnx.so \
lib/kde3/plugins/styles/qnx.la \
share/apps/kstyle/themes/qnx.themerc
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||g' -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>
diff --git a/x11-wm/qnxstyle/files/patch-src_Makefile.in b/x11-wm/qnxstyle/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..e4e6bc88a88b
--- /dev/null
+++ b/x11-wm/qnxstyle/files/patch-src_Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Sat May 22 00:01:43 2004
++++ src/Makefile.in Sat May 22 00:02:13 2004
+@@ -228,7 +228,7 @@
+ noinst_HEADERS = qnx.h
+ kde_style_LTLIBRARIES = qnx.la
+ qnx_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -lkdefx -module
+-qnx_la_LIBADD =
++qnx_la_LIBADD = $(LIBPTHREAD)
+ qnx_la_SOURCES = qnx.cpp
+ #>- qnx_la_METASOURCES = AUTO
+