aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/cxxtools/Makefile4
-rw-r--r--devel/giggle/Makefile8
-rw-r--r--devel/ice/Makefile4
-rw-r--r--devel/ioncube/Makefile3
-rw-r--r--devel/lasi/Makefile8
-rw-r--r--devel/libbobcat/Makefile8
-rw-r--r--devel/libdsp/Makefile4
-rw-r--r--devel/libdwarf/Makefile8
-rw-r--r--devel/libgsf/Makefile10
-rw-r--r--devel/libiqxmlrpc/Makefile8
-rw-r--r--devel/libopkele/Makefile3
-rw-r--r--devel/libpthread-stubs/Makefile8
-rw-r--r--devel/linux-js/Makefile2
-rw-r--r--devel/linux-kmod-compat/Makefile8
-rw-r--r--devel/llvm-etoile/Makefile4
-rw-r--r--devel/pecl-gearman/Makefile8
-rw-r--r--devel/py-freebsd/Makefile3
-rw-r--r--devel/py-freebsd/files/freebsd7_patch-src-netstat.c10
-rw-r--r--devel/py-ncurses/Makefile2
-rw-r--r--devel/rsvndump/Makefile4
-rw-r--r--devel/subcommander2/Makefile8
-rw-r--r--devel/uppaal/Makefile4
-rw-r--r--devel/ustl/Makefile3
-rw-r--r--dns/ldns/Makefile9
-rw-r--r--dns/unbound/Makefile13
-rw-r--r--editors/nano-devel/Makefile2
-rw-r--r--editors/nano/Makefile2
-rw-r--r--emulators/dynamips-devel/Makefile2
-rw-r--r--emulators/dynamips/Makefile2
-rw-r--r--emulators/open-vm-tools/Makefile4
-rw-r--r--emulators/parallels-tools/Makefile8
-rw-r--r--french/aster/Makefile4
-rw-r--r--games/d2x-xl/Makefile4
-rw-r--r--games/euchre/Makefile8
-rw-r--r--games/naev/Makefile8
-rw-r--r--games/pokerth/Makefile8
-rw-r--r--games/spring/Makefile4
-rw-r--r--games/warzone2100/Makefile8
-rw-r--r--games/wesnoth/Makefile4
39 files changed, 25 insertions, 197 deletions
diff --git a/devel/cxxtools/Makefile b/devel/cxxtools/Makefile
index 08660fec2851..c7067e0b19ec 100644
--- a/devel/cxxtools/Makefile
+++ b/devel/cxxtools/Makefile
@@ -24,10 +24,6 @@ MAKE_JOBS_SAFE= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 700042
-LIB_DEPENDS+= boost_thread:${PORTSDIR}/devel/boost-libs
-.endif
-
.if ${ARCH} == "sparc64"
BROKEN= Does not configure on sparc64
.endif
diff --git a/devel/giggle/Makefile b/devel/giggle/Makefile
index bdc7531056ac..573fb6590da8 100644
--- a/devel/giggle/Makefile
+++ b/devel/giggle/Makefile
@@ -47,13 +47,7 @@ CONFIGURE_ARGS+= --disable-terminal
PLIST_SUB+= VTE="@comment "
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700000
-BROKEN= does not build
-.endif
-
post-install:
@-update-desktop-database
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/ice/Makefile b/devel/ice/Makefile
index 6f2ccf345b8c..d6616f9e0ec0 100644
--- a/devel/ice/Makefile
+++ b/devel/ice/Makefile
@@ -68,9 +68,5 @@ post-patch:
${WRKSRC}/cpp/src/ca/Makefile
${REINPLACE_CMD} '/LICENSE/s/prefix/install_slicedir/' \
${WRKSRC}/config/Make.common.rules
-.if ${OSVERSION} < 700000
- ${REINPLACE_CMD} 's|__APPLE__|__FreeBSD__|' \
- ${WRKSRC}/cpp/src/IceUtil/Cond.cpp
-.endif
.include <bsd.port.post.mk>
diff --git a/devel/ioncube/Makefile b/devel/ioncube/Makefile
index 3a925df373ea..ed9eb33a4b1f 100644
--- a/devel/ioncube/Makefile
+++ b/devel/ioncube/Makefile
@@ -28,8 +28,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
# Detect OS Version
.if ${OSVERSION} >= 800000
VER= 8
-.endif
-.if (${OSVERSION} >= 700000 && ${OSVERSION} < 800000)
+.else
VER= 7
.endif
diff --git a/devel/lasi/Makefile b/devel/lasi/Makefile
index a481e50a454c..fa613065769d 100644
--- a/devel/lasi/Makefile
+++ b/devel/lasi/Makefile
@@ -33,12 +33,6 @@ BUILD_DEPENDS+= ${LOCALBASE}/bin/doxygen:${PORTSDIR}/devel/doxygen
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-cmake+modules+lasi.cmake
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700000
-BROKEN= does not compile on 6.X
-.endif
-
pre-install:
.if defined(NOPORTEXAMPLES)
@${REINPLACE_CMD} 's/^\(add_subdirectory(examples)\)/#\1/' ${WRKSRC}/CMakeLists.txt
@@ -61,4 +55,4 @@ post-install:
.endif
@${TEST} -d ${DATADIR} && ${RMDIR} ${DATADIR} || ${TRUE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/libbobcat/Makefile b/devel/libbobcat/Makefile
index 9173df5ca384..09025e02e1bb 100644
--- a/devel/libbobcat/Makefile
+++ b/devel/libbobcat/Makefile
@@ -60,12 +60,6 @@ PLIST_SUB+= PORTVERSION="${PORTVERSION}"
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/bobcat-${PORTVERSION}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700000
-BUILD_DEPENDS+= openssl>=0.9.8:${PORTSDIR}/security/openssl
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|"/usr"|"${PREFIX}"| ; \
s|"/share/doc/libbobcat2"|"/share/doc/${PORTNAME}-${PORTVERSION}"| ; \
@@ -96,4 +90,4 @@ do-build:
do-install:
@cd ${WRKSRC} && ./build install
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/libdsp/Makefile b/devel/libdsp/Makefile
index 7c327bd34884..e0f43d37313e 100644
--- a/devel/libdsp/Makefile
+++ b/devel/libdsp/Makefile
@@ -35,8 +35,4 @@ do-configure:
CFLAGS+= -DDSP_X86
.endif
-.if ${OSVERSION} < 700000
-BROKEN= Unable to build
-.endif
-
.include <bsd.port.post.mk>
diff --git a/devel/libdwarf/Makefile b/devel/libdwarf/Makefile
index b426d20c9d89..50860201c43d 100644
--- a/devel/libdwarf/Makefile
+++ b/devel/libdwarf/Makefile
@@ -16,12 +16,6 @@ COMMENT= A library to analyze DWARF debugging information in ELF files
INSTALL_CONFLICT= bsdlibdwarf*
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700000
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libelf.so.0:${PORTSDIR}/devel/libelf
-.endif
-
WRKSRC= ${WRKDIR}/dwarf-${PORTVERSION}/libdwarf
GNU_CONFIGURE= yes
@@ -41,4 +35,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/$$f ${PREFIX}/share/doc/libdwarf ; \
done
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/libgsf/Makefile b/devel/libgsf/Makefile
index 9bef7963aa5a..51a54afb68ad 100644
--- a/devel/libgsf/Makefile
+++ b/devel/libgsf/Makefile
@@ -45,12 +45,4 @@ GCONF_SCHEMAS= gsf-office-thumbnailer.schemas
PLIST_SUB+= THUMB="@comment "
.endif
-.include <bsd.port.pre.mk>
-
-.if defined(GSF_SLAVE)
-.if ${OSVERSION} < 700000
-BROKEN= does not configure on 6.X
-.endif
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/libiqxmlrpc/Makefile b/devel/libiqxmlrpc/Makefile
index f6c7e9e90b69..3d6506a92cd6 100644
--- a/devel/libiqxmlrpc/Makefile
+++ b/devel/libiqxmlrpc/Makefile
@@ -20,14 +20,8 @@ LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs\
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700000
-CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}"
-.endif
-
post-patch:
@${REINPLACE_CMD} 's,libxml++-1.0,libxml++-2.6,g' ${WRKSRC}/configure
@${REINPLACE_CMD} 's,{libdir}/pkgconfig,{prefix}/libdata/pkgconfig,' ${WRKSRC}/Makefile.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/libopkele/Makefile b/devel/libopkele/Makefile
index e4d7ea0037b9..515ed128da80 100644
--- a/devel/libopkele/Makefile
+++ b/devel/libopkele/Makefile
@@ -35,9 +35,6 @@ LDFLAGS+= -L${LOCALBASE}/lib
# This port needs OpenSSL 0.9.8b which is present in 7.0 and up
USE_OPENSSL= yes
-.if ${OSVERSION} < 700000
-WITH_OPENSSL_PORT= yes
-.endif
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
# If we use the base OpenSSL either by default or
diff --git a/devel/libpthread-stubs/Makefile b/devel/libpthread-stubs/Makefile
index 6b5ed8d8a756..aa4eac192a08 100644
--- a/devel/libpthread-stubs/Makefile
+++ b/devel/libpthread-stubs/Makefile
@@ -22,10 +22,4 @@ WITH_FBSD10_FIX= yes
GNU_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700000
-LDFLAGS+= -lpthread
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/linux-js/Makefile b/devel/linux-js/Makefile
index 6ef0646113cb..9850c63c45b8 100644
--- a/devel/linux-js/Makefile
+++ b/devel/linux-js/Makefile
@@ -51,10 +51,8 @@ MAKE_ENV+= WITHOUT_UHID=yes
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|' ${WRKSRC}/linux_js.4
-.if ${OSVERSION} >= 700000
@${REINPLACE_CMD} -e 's|FILEDESC_UNLOCK|FILEDESC_SUNLOCK|' ${WRKSRC}/linux_js.c
@${REINPLACE_CMD} -e 's|FILEDESC_LOCK|FILEDESC_SLOCK|' ${WRKSRC}/linux_js.c
-.endif
post-install:
${MKDIR} ${PREFIX}/include/linux
diff --git a/devel/linux-kmod-compat/Makefile b/devel/linux-kmod-compat/Makefile
index c413f9bf2ed3..b12d7f35d4ca 100644
--- a/devel/linux-kmod-compat/Makefile
+++ b/devel/linux-kmod-compat/Makefile
@@ -16,12 +16,6 @@ COMMENT= Adaptation layer to build linux drivers on FreeBSD
WRKSRC= ${WRKDIR}/linux_compat
NO_BUILD= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 602100
-IGNORE= requires a recent USB stack, not present in ${OSVERSION}
-.endif
-
# Here is where install most things except the .mk file
MY_DST= ${DATADIR}/linux_compat
MY_MK= bsd.linux_kmod.mk
@@ -53,4 +47,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/llvm-etoile/Makefile b/devel/llvm-etoile/Makefile
index cb01d00c18df..a55fcac42fcb 100644
--- a/devel/llvm-etoile/Makefile
+++ b/devel/llvm-etoile/Makefile
@@ -52,9 +52,7 @@ SVN_REV!= svn info http://llvm.org/svn/llvm-project/ | ${GREP} Revision | cut -d
.include "Makefile.svn_rev"
.endif
-.if ${OSVERSION} < 700000 && ${ARCH} == "amd64"
-BROKEN= does not compile
-.elif ${ARCH} == "sparc64"
+.if ${ARCH} == "sparc64"
BROKEN= Does not compile on sparc64
.endif
diff --git a/devel/pecl-gearman/Makefile b/devel/pecl-gearman/Makefile
index 131d07fbddc3..ae5f0d310dc7 100644
--- a/devel/pecl-gearman/Makefile
+++ b/devel/pecl-gearman/Makefile
@@ -26,10 +26,4 @@ USE_PHP= yes
USE_PHPEXT= yes
IGNORE_WITH_PHP=4
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} <= 700000
-BROKEN= does not compile
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/py-freebsd/Makefile b/devel/py-freebsd/Makefile
index c7c9cc41a37e..86f52f6ebd64 100644
--- a/devel/py-freebsd/Makefile
+++ b/devel/py-freebsd/Makefile
@@ -29,9 +29,6 @@ PLIST_FILES= %%PYTHON_SITELIBDIR%%/freebsd.so \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700000
-EXTRA_PATCHES+= ${FILESDIR}/freebsd7_patch-src-netstat.c
-.endif
# Multi-IPv4/v6/no-IP jails.
.if ${OSVERSION} >= 800056 || \
(${OSVERSION} < 800000 && ${OSVERSION} >= 701103)
diff --git a/devel/py-freebsd/files/freebsd7_patch-src-netstat.c b/devel/py-freebsd/files/freebsd7_patch-src-netstat.c
deleted file mode 100644
index 11ae01cc4d6c..000000000000
--- a/devel/py-freebsd/files/freebsd7_patch-src-netstat.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/netstat.c.orig 2007-08-17 13:07:10.654911645 -0500
-+++ src/netstat.c 2007-08-17 13:07:19.496912514 -0500
-@@ -243,7 +243,6 @@
- Py_DECREF(t);
- p_int(type); p_int(physical);
- p_int(addrlen); p_int(hdrlen);
-- p_int(recvquota); p_int(xmitquota);
- p_long(mtu); p_long(metric);
- p_long(baudrate); p_long(ipackets);
- p_long(ierrors); p_long(opackets);
diff --git a/devel/py-ncurses/Makefile b/devel/py-ncurses/Makefile
index 55189a55f011..853949f2ccb9 100644
--- a/devel/py-ncurses/Makefile
+++ b/devel/py-ncurses/Makefile
@@ -27,7 +27,7 @@ post-patch:
@${REINPLACE_CMD} -e '45s,^.*$$,#include "py_curses.h",' \
${WRKSRC}/ncurses/${f}
.endfor
-.if ${OSVERSION} > 700033 || (${OSVERSION} < 700000)
+.if ${OSVERSION} > 700033
@${REINPLACE_CMD} -e '/^extern int define_key(/d' \
${WRKSRC}/ncurses/_curses_wrap.c
.endif
diff --git a/devel/rsvndump/Makefile b/devel/rsvndump/Makefile
index daf025a41ca4..671edea9e870 100644
--- a/devel/rsvndump/Makefile
+++ b/devel/rsvndump/Makefile
@@ -31,10 +31,6 @@ PLIST_FILES+= bin/rsvndump
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 700041
-LDFLAGS+= ${PTHREAD_LIBS}
-.endif
-
.if !defined(NOPORTDOCS)
BUILD_DEPENDS+= asciidoc:${PORTSDIR}/textproc/asciidoc \
xmlto:${PORTSDIR}/textproc/xmlto
diff --git a/devel/subcommander2/Makefile b/devel/subcommander2/Makefile
index eb68530b3f1f..fd7961cc8ad3 100644
--- a/devel/subcommander2/Makefile
+++ b/devel/subcommander2/Makefile
@@ -44,10 +44,4 @@ LDFLAGS+= -L${LOCALBASE}/lib -L${LOCALBASE}/lib/qt4 ${PTHREAD_LIBS}
post-extract:
@${CHMOD} +x ${WRKSRC}/configure
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700000
-BROKEN= Does not compile on 6.x
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/uppaal/Makefile b/devel/uppaal/Makefile
index 4e3de150a53d..b87a4f0ffac1 100644
--- a/devel/uppaal/Makefile
+++ b/devel/uppaal/Makefile
@@ -35,10 +35,6 @@ RESTRICTED= Downloading requires completion of a license agreement
LINUX_OSRELEASE!= ${ECHO_CMD} `${SYSCTL} -n compat.linux.osrelease 2>/dev/null`
-.if ${LINUX_OSRELEASE} == "2.4.2" || ${OSVERSION} < 700000
-IGNORE=requires compat.linux.osrelease of at least 2.6.16 (needs 7.0 or later)
-.endif
-
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
ECHO_MSG=/usr/bin/printf
IGNORE=Please download ${DISTNAME}${EXTRACT_SUFX} into\
diff --git a/devel/ustl/Makefile b/devel/ustl/Makefile
index 0caf2e7e2b05..a154e132333c 100644
--- a/devel/ustl/Makefile
+++ b/devel/ustl/Makefile
@@ -31,9 +31,8 @@ PLIST_FILES= lib/libustl.so lib/libustl.so.1 lib/libustl.so.1.0.0
.if ${ARCH} != "i386"
BROKEN= Does not compile on !i386
-.elif ${OSVERSION} >= 700000
-MANUAL_PACKAGE_BUILD= yes
.endif
+MANUAL_PACKAGE_BUILD= yes
post-patch:
@${REINPLACE_CMD} -e "s,/bin/bash,/bin/sh," ${WRKSRC}/configure
diff --git a/dns/ldns/Makefile b/dns/ldns/Makefile
index ce30a0fdfd2f..0d0ac151620d 100644
--- a/dns/ldns/Makefile
+++ b/dns/ldns/Makefile
@@ -39,8 +39,6 @@ PLIST_SUB+= PYLDNS=""
PLIST_SUB+= PYLDNS="@comment "
.endif
-.include <bsd.port.pre.mk>
-
ALL_TARGET= all
INSTALL_TARGET= install-lib install-h
@@ -266,15 +264,10 @@ MAN1+= ldns-chaos.1 ldns-compare-zones.1 ldns-dpa.1 \
PLIST_SUB+= EXAMPLES="@comment "
.endif
-.if defined(WITH_ECDSA) && ${OSVERSION} > 700000
+.if defined(WITH_ECDSA)
CONFIGURE_ARGS+=--enable-ecdsa
.endif
-.if ${OSVERSION} < 700000
-NO_SHA2= --disable-sha2
-CONFIGURE_ARGS+=${NO_SHA2}
-.endif
-
post-configure:
.if defined(WITH_EXAMPLES)
@(cd ${WRKSRC}/examples; ./configure --prefix=${PREFIX} \
diff --git a/dns/unbound/Makefile b/dns/unbound/Makefile
index 0b79af48f39b..cbc18332f577 100644
--- a/dns/unbound/Makefile
+++ b/dns/unbound/Makefile
@@ -59,17 +59,6 @@ WITH_OPENSSL_PORT= yes
CONFIGURE_ARGS+= --disable-gost
.endif
-.include <bsd.port.pre.mk>
-
-# OpenSSL on 6.x has no sha256 functions
-.if ${OSVERSION} < 700000
-CONFIGURE_ARGS+= --disable-sha2
-.endif
-
-.if ${ARCH} == "sparc64" && ${OSVERSION} < 700000
-BROKEN= Does not build on sparc64-6
-.endif
-
.if defined(WITH_LIBEVENT)
LIB_DEPENDS+= event-1.4:${PORTSDIR}/devel/libevent
CONFIGURE_ARGS+= --with-libevent=${LOCALBASE}
@@ -94,4 +83,4 @@ post-install:
done
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/editors/nano-devel/Makefile b/editors/nano-devel/Makefile
index fa0e694fe52b..b2a8e4d78e21 100644
--- a/editors/nano-devel/Makefile
+++ b/editors/nano-devel/Makefile
@@ -36,7 +36,7 @@ MAN5= nanorc.5
.include <bsd.port.pre.mk>
# requires wide character curses
-.if (${OSVERSION} >= 700000 && ${OSVERSION} < 700033)
+.if (${OSVERSION} < 700033
CONFIGURE_ARGS+=--disable-utf8
.else
CONFIGURE_ARGS+=--enable-utf8
diff --git a/editors/nano/Makefile b/editors/nano/Makefile
index a1ce02532409..e418a4bef781 100644
--- a/editors/nano/Makefile
+++ b/editors/nano/Makefile
@@ -45,7 +45,7 @@ MAN5= nanorc.5
.include <bsd.port.pre.mk>
# requires wide character curses
-.if (${OSVERSION} < 602107) || (${OSVERSION} >= 700000 && ${OSVERSION} < 700033)
+.if (${OSVERSION} < 700033
CONFIGURE_ARGS+=--disable-utf8
.else
CONFIGURE_ARGS+=--enable-utf8
diff --git a/emulators/dynamips-devel/Makefile b/emulators/dynamips-devel/Makefile
index fa8d8713d02d..d37d0c4e4b1b 100644
--- a/emulators/dynamips-devel/Makefile
+++ b/emulators/dynamips-devel/Makefile
@@ -51,7 +51,7 @@ DYNAMIPS_ARCH= "nojit"
.endif
# It required libpcap version 0.9.4 or is higher.
-.if ${OSVERSION} < 602100 || (${OSVERSION} >= 700000 && ${OSVERSION} < 700021)
+.if ${OSVERSION} < 700021
BUILD_DEPENDS+= ${LOCALBASE}/lib/libpcap.a:${PORTSDIR}/net/libpcap
MAKE_ENV+= PCAP_LIB=${LOCALBASE}/lib/libpcap.a
#.warning Do not overlook, make libpcap with LIBPCAP_OVERWRITE_BASE parameter, for use with shared library.
diff --git a/emulators/dynamips/Makefile b/emulators/dynamips/Makefile
index 518f12cc76a5..2df710e9912f 100644
--- a/emulators/dynamips/Makefile
+++ b/emulators/dynamips/Makefile
@@ -42,7 +42,7 @@ DYNAMIPS_ARCH= "amd64"
DYNAMIPS_ARCH= "nojit"
.endif
-.if ${OSVERSION} < 602100 || ${OSVERSION} < 700021
+.if ${OSVERSION} < 700021
BUILD_DEPENDS+= libpcap>=0.9.4:${PORTSDIR}/net/libpcap
.endif
diff --git a/emulators/open-vm-tools/Makefile b/emulators/open-vm-tools/Makefile
index e4ba096d5108..87e546c88770 100644
--- a/emulators/open-vm-tools/Makefile
+++ b/emulators/open-vm-tools/Makefile
@@ -77,10 +77,6 @@ USE_RC_SUBR= vmware-guestd.sh vmware-kmod.sh
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 700000
-BROKEN= does not compile on 6.X
-.endif
-
.if ${ARCH} == "sparc64"
IGNORE= not yet ported to sparc64
.endif
diff --git a/emulators/parallels-tools/Makefile b/emulators/parallels-tools/Makefile
index 3840ca49da30..034a37f6ce8f 100644
--- a/emulators/parallels-tools/Makefile
+++ b/emulators/parallels-tools/Makefile
@@ -22,10 +22,4 @@ KMODDIR?= /boot/modules
PLIST_SUB+= KMODDIR=${KMODDIR}
MAKE_ENV+= KMODDIR=${KMODDIR}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700000
-IGNORE= is only supported on FreeBSD 7.x or later
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/french/aster/Makefile b/french/aster/Makefile
index 304f040f52b4..8c82382dab8b 100644
--- a/french/aster/Makefile
+++ b/french/aster/Makefile
@@ -83,10 +83,6 @@ PYTHON_VERSION= 2.6
# Avoid renaming .f into .F
#F90FLAGS= -x f77-cpp-input ${FFLAGS}
-.if ${OSVERSION} < 700000
-BROKEN= does not install
-.endif
-
.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
WITH_ATLAS= yes
.endif
diff --git a/games/d2x-xl/Makefile b/games/d2x-xl/Makefile
index a0fd75902cdb..eaef15768e9e 100644
--- a/games/d2x-xl/Makefile
+++ b/games/d2x-xl/Makefile
@@ -46,10 +46,6 @@ OPTIONS= OPENGL "Use OpenGL for 3D graphics" on
BROKEN= Does not compile on sparc64
.endif
-.if ${OSVERSION} <= 700000
-BROKEN= does not compile
-.endif
-
.if !defined(WITHOUT_OPENGL)
USE_GL= gl glu
CONFIGURE_ARGS+=--with-opengl
diff --git a/games/euchre/Makefile b/games/euchre/Makefile
index d5ef23e5ce0f..b0d1b484f890 100644
--- a/games/euchre/Makefile
+++ b/games/euchre/Makefile
@@ -20,15 +20,9 @@ USE_GNOME= gtk12
CFLAGS+= -include "${FILESDIR}/std-namespace.h" -Werror
MAKE_JOBS_SAFE= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700000 && ${ARCH} == "amd64"
-BROKEN= does not compile
-.endif
-
post-patch:
${REINPLACE_CMD} 's,char,const char,' \
${WRKSRC}/src/pixmaps/*.xpm \
${WRKSRC}/src/pixmaps/pixmaps.?pp
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/naev/Makefile b/games/naev/Makefile
index 441c6873fa9d..1f3b0e838cea 100644
--- a/games/naev/Makefile
+++ b/games/naev/Makefile
@@ -38,12 +38,6 @@ SUB_FILES= pkg-message
OPTIONS= OPENAL "Use the OpenAL sound backend" on \
SDL_MIXER "Use the SDL_mixer sound backend" on
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700000
-BROKEN= does not configure on 6.X
-.endif
-
.if defined(WITH_OPENAL)
USE_OPENAL= yes
CONFIGURE_ARGS+= --with-openal=yes
@@ -65,4 +59,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/pokerth/Makefile b/games/pokerth/Makefile
index f9db99609de2..751df6f4ae9c 100644
--- a/games/pokerth/Makefile
+++ b/games/pokerth/Makefile
@@ -38,12 +38,6 @@ QMAKE_ARGS+= -unix PREFIX=${PREFIX}
PORTDOCS= server_setup_howto.txt
MAN1= pokerth.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700000
-BROKEN= does not compile on 6.x
-.endif
-
post-patch:
@${REINPLACE_CMD} -E \
-e 's|/usr([a-z|/]*)|${LOCALBASE}/\1|g' \
@@ -65,4 +59,4 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/docs/server_setup_howto.txt ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/spring/Makefile b/games/spring/Makefile
index 670aad81841c..eee88d5b5e98 100644
--- a/games/spring/Makefile
+++ b/games/spring/Makefile
@@ -51,10 +51,6 @@ CXXFLAGS= # empty
CMAKE_ARGS+= -DCMAKE_BUILD_TYPE=DEBUG2 -DTRACE_SYNC=true -DSYNCDEBUG=true
.endif
-.if ${OSVERSION} < 700042
-BROKEN= does not build in 6.x
-.endif
-
post-patch:
@${REINPLACE_CMD} -E -e '/FIND_PACKAGE.*(Python|JNI)/ d' \
${WRKSRC}/tools/unitsync/CMakeLists.txt
diff --git a/games/warzone2100/Makefile b/games/warzone2100/Makefile
index 21003481f303..832a75f65a9e 100644
--- a/games/warzone2100/Makefile
+++ b/games/warzone2100/Makefile
@@ -50,12 +50,6 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700004
-BROKEN= Does not build
-.endif
-
post-patch:
@${REINPLACE_CMD} -e '/_XOPEN_SOURCE/ d' ${WRKSRC}/config.h.in
@${REINPLACE_CMD} -e 's|NSIG|32|g; s|SIGPOLL|SIGIO|g' \
@@ -83,4 +77,4 @@ post-patch:
.else
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/wesnoth/Makefile b/games/wesnoth/Makefile
index 71440f2c11be..d00cd3977edc 100644
--- a/games/wesnoth/Makefile
+++ b/games/wesnoth/Makefile
@@ -64,10 +64,6 @@ OPTIONS= BWMON "Enable bandwidth monitoring for server" Off \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 700000
-BROKEN= does not compile
-.endif
-
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug
.endif