aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/p5-Tk-JPEG-Lite/Makefile32
-rw-r--r--graphics/p5-Tk-JPEG-Lite/distinfo2
-rw-r--r--graphics/p5-Tk-JPEG-Lite/pkg-descr3
-rw-r--r--graphics/p5-Tk-JPEG-Lite/pkg-plist8
5 files changed, 46 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 46e74e9b3da5..40f40b4fd4a2 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -311,6 +311,7 @@
SUBDIR += p5-OpenGL
SUBDIR += p5-SWF-Builder
SUBDIR += p5-SWF-File
+ SUBDIR += p5-Tk-JPEG-Lite
SUBDIR += p5-VCG
SUBDIR += p5-chart
SUBDIR += p5-ming
diff --git a/graphics/p5-Tk-JPEG-Lite/Makefile b/graphics/p5-Tk-JPEG-Lite/Makefile
new file mode 100644
index 000000000000..ab5bc090675b
--- /dev/null
+++ b/graphics/p5-Tk-JPEG-Lite/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Tk-JPEG-Lite
+# Date created: 2004-07-23
+# Whom: Michael Johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Tk-JPEG-Lite
+PORTVERSION= 2.01403
+CATEGORIES= graphics perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Tk
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Very simplistic image viewer that loads JPEG images
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Tk.pm:${PORTSDIR}/x11-toolkits/p5-Tk
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+USE_REINPLACE= yes
+
+MAN1= tkjpeg.1
+MAN3= Tk::JPEG::Lite.3
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
+ ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/graphics/p5-Tk-JPEG-Lite/distinfo b/graphics/p5-Tk-JPEG-Lite/distinfo
new file mode 100644
index 000000000000..c06a61e66fae
--- /dev/null
+++ b/graphics/p5-Tk-JPEG-Lite/distinfo
@@ -0,0 +1,2 @@
+MD5 (Tk-JPEG-Lite-2.01403.tar.gz) = 5d930c96e03869c49ad58dd56974a683
+SIZE (Tk-JPEG-Lite-2.01403.tar.gz) = 19328
diff --git a/graphics/p5-Tk-JPEG-Lite/pkg-descr b/graphics/p5-Tk-JPEG-Lite/pkg-descr
new file mode 100644
index 000000000000..0d773798a69c
--- /dev/null
+++ b/graphics/p5-Tk-JPEG-Lite/pkg-descr
@@ -0,0 +1,3 @@
+Very simplistic image viewer that loads JPEG images
+
+WWW: http://search.cpan.org/~srezic/Tk-JPEG-Lite/
diff --git a/graphics/p5-Tk-JPEG-Lite/pkg-plist b/graphics/p5-Tk-JPEG-Lite/pkg-plist
new file mode 100644
index 000000000000..e13ba46c7d0a
--- /dev/null
+++ b/graphics/p5-Tk-JPEG-Lite/pkg-plist
@@ -0,0 +1,8 @@
+bin/tkjpeg
+%%SITE_PERL%%/%%PERL_ARCH%%/Tk/JPEG/Lite.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Tk/JPEG/Lite/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Tk/JPEG/Lite/Lite.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Tk/JPEG/Lite/Lite.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Tk/JPEG/Lite
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Tk/JPEG 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Tk/JPEG 2>/dev/null || true