aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--print/Makefile1
-rw-r--r--print/dviselect/Makefile24
-rw-r--r--print/dviselect/distinfo2
-rw-r--r--print/dviselect/files/patch-dviselect.c44
-rw-r--r--print/dviselect/files/patch-lib_Makefile14
-rw-r--r--print/dviselect/files/patch-lib_error.c53
-rw-r--r--print/dviselect/files/patch-lib_font.c12
-rw-r--r--print/dviselect/files/patch-lib_pkfont.c22
-rw-r--r--print/dviselect/files/patch-lib_pxlfont.c28
-rw-r--r--print/dviselect/files/patch-lib_rotate.c10
-rw-r--r--print/dviselect/files/patch-lib_search.c11
-rw-r--r--print/dviselect/files/patch-lib_seek.c10
-rw-r--r--print/dviselect/files/patch-lib_tfm.c23
-rw-r--r--print/dviselect/files/patch-lib_tfmfont.c20
-rw-r--r--print/dviselect/pkg-descr3
-rw-r--r--print/dviselect/scripts/configure13
17 files changed, 1 insertions, 290 deletions
diff --git a/MOVED b/MOVED
index 86ae576cee9a..ba93bc875261 100644
--- a/MOVED
+++ b/MOVED
@@ -6496,3 +6496,4 @@ misc/rubygem-mime-types117|misc/rubygem-mime-types1|2014-08-26|Renamed to proper
devel/rubygem-json146|devel/rubygem-json|2014-08-28|Has expired: Old version no longer required by dependencies
archivers/rubygem-bzip2|archivers/rubygem-bzip2-ruby|2014-08-29|Rename to match our rubygems naming
ports-mgmt/pkg_add_it||2014-08-30|Has expired: Does not support pkgng
+print/dviselect|print/texlive-base|2014-08-30|Use print/texlive-base instead
diff --git a/print/Makefile b/print/Makefile
index 76b699170e51..869e195a9712 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -45,7 +45,6 @@
SUBDIR += dot2tex
SUBDIR += dvi2tty
SUBDIR += dvips2ascii
- SUBDIR += dviselect
SUBDIR += dvisvg
SUBDIR += easylatex
SUBDIR += enscript-a4
diff --git a/print/dviselect/Makefile b/print/dviselect/Makefile
deleted file mode 100644
index 6081db44d003..000000000000
--- a/print/dviselect/Makefile
+++ /dev/null
@@ -1,24 +0,0 @@
-# Created by: jmz
-# $FreeBSD$
-
-PORTNAME= dviselect
-PORTVERSION= 1.3
-PORTREVISION= 2
-CATEGORIES= print
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= jmz
-
-DISTNAME= ${PORTNAME}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Extract pages from DVI files
-
-SCRIPTS_ENV= CFLAGS="${CFLAGS}"
-
-PLIST_FILES= bin/dviselect man/man1/dviselect.1.gz
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/dviselect ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/dviselect.1 ${STAGEDIR}${MANPREFIX}/man/man1
-
-.include <bsd.port.mk>
diff --git a/print/dviselect/distinfo b/print/dviselect/distinfo
deleted file mode 100644
index ea47787d8632..000000000000
--- a/print/dviselect/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (dviselect.tar.gz) = 81b2c9e37900af7451903955430b7fe188741eeeeafee44fa0ed0ff8be05776b
-SIZE (dviselect.tar.gz) = 56299
diff --git a/print/dviselect/files/patch-dviselect.c b/print/dviselect/files/patch-dviselect.c
deleted file mode 100644
index 819b8a1ca201..000000000000
--- a/print/dviselect/files/patch-dviselect.c
+++ /dev/null
@@ -1,44 +0,0 @@
---- dviselect.c.orig 1989-11-15 13:19:15.000000000 +0100
-+++ dviselect.c 2012-11-30 14:56:42.000000000 +0100
-@@ -122,7 +122,6 @@
- /* save some string space: we use this a lot */
- char writeerr[] = "error writing DVI file";
-
--char *malloc(), *realloc(), *sprintf();
-
- /*
- * lint gets rather confused with the current definitions of getc and putc,
-@@ -136,6 +135,9 @@
- #define getc(f) (*(f)->_ptr++)
- #endif
-
-+void HandleDVIFile (void);
-+void EndPage (void);
-+
- /*
- * Return true iff the 10 \counts are one of the desired output pages.
- */
-@@ -190,6 +192,7 @@
- /*
- * Start a page (process a DVI_BOP).
- */
-+void
- BeginPage()
- {
- register i32 *i;
-@@ -243,6 +246,7 @@
- /*
- * End a page (process a DVI_EOP).
- */
-+void
- EndPage()
- {
- if (!ExpectEOP)
-@@ -815,6 +819,7 @@
- * output DVI file. We also keep track of font changes, handle font
- * definitions, and perform some other housekeeping.
- */
-+void
- HandleDVIFile()
- {
- register int c, l;
diff --git a/print/dviselect/files/patch-lib_Makefile b/print/dviselect/files/patch-lib_Makefile
deleted file mode 100644
index b07c457b6d7d..000000000000
--- a/print/dviselect/files/patch-lib_Makefile
+++ /dev/null
@@ -1,14 +0,0 @@
---- lib/Makefile.orig Wed Nov 15 13:19:54 1989
-+++ lib/Makefile Wed Dec 13 23:00:00 2006
-@@ -10,9 +10,8 @@
- DESTDIR=
- # Alas, -R makes ALL initialised variables read-only, and we cannot
- # use it on font files; hence, FCFLAGS.
--CC=cc
--CFLAGS= -O -I../h
--FCFLAGS=-O -I../h
-+CFLAGS+= -I../h
-+FCFLAGS+= -I../h
-
- # 4.1BSD Vax:
- #ASSRC= bcopy.s bzero.s
diff --git a/print/dviselect/files/patch-lib_error.c b/print/dviselect/files/patch-lib_error.c
deleted file mode 100644
index 6e9fb918a4c3..000000000000
--- a/print/dviselect/files/patch-lib_error.c
+++ /dev/null
@@ -1,53 +0,0 @@
---- lib/error.c.orig Wed Nov 15 04:19:40 1989
-+++ lib/error.c Wed Oct 15 06:38:57 2003
-@@ -18,7 +18,8 @@
- */
-
- #include <stdio.h>
--#include <varargs.h>
-+#include <stdarg.h>
-+#include <errno.h>
-
- #ifdef lint
-
-@@ -31,20 +32,15 @@
- #else lint
-
- extern char *ProgName;
--extern int errno;
--extern char *sys_errlist[];
--extern int sys_nerr;
-
--error(va_alist)
-- va_dcl
-+error(char *fmt,...)
- {
- va_list l;
- int quit, e;
-- char *fmt;
-
- (void) fflush(stdout); /* sync error messages */
- (void) fprintf(stderr, "%s: ", ProgName);
-- va_start(l);
-+ va_start(l,fmt);
- /* pick up the constant arguments: quit, errno, printf format */
- quit = va_arg(l, int);
- e = va_arg(l, int);
-@@ -69,15 +65,13 @@
- exit(quit);
- }
-
--panic(va_alist)
-- va_dcl
-+panic(char *fmt,...)
- {
- va_list l;
-- char *fmt;
-
- (void) fflush(stdout);
- (void) fprintf(stderr, "%s: panic: ", ProgName);
-- va_start(l);
-+ va_start(l,fmt);
- /* pick up the constant argument: printf format */
- fmt = va_arg(l, char *);
- #if defined(sys5) || defined(HAVE_VPRINTF)
diff --git a/print/dviselect/files/patch-lib_font.c b/print/dviselect/files/patch-lib_font.c
deleted file mode 100644
index 610e850e63ef..000000000000
--- a/print/dviselect/files/patch-lib_font.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- lib/font.c~ Wed Nov 15 13:19:43 1989
-+++ lib/font.c Mon Jul 3 00:39:32 2000
-@@ -67,9 +67,6 @@
- */
- extern int errno;
- char *getenv(), *malloc(), *strsave();
--#ifndef sys5
--char *sprintf();
--#endif
-
- static readconf();
- static setfont();
diff --git a/print/dviselect/files/patch-lib_pkfont.c b/print/dviselect/files/patch-lib_pkfont.c
deleted file mode 100644
index a3eeab64fca6..000000000000
--- a/print/dviselect/files/patch-lib_pkfont.c
+++ /dev/null
@@ -1,22 +0,0 @@
---- lib/pkfont.c.orig 1989-11-15 13:19:52.000000000 +0100
-+++ lib/pkfont.c 2012-11-30 14:59:23.000000000 +0100
-@@ -183,7 +183,7 @@
- /*
- * Skip over special commands (PK_XXX?, PK_YYY).
- */
--static
-+static void
- skip_specials(f)
- struct font *f;
- {
-@@ -781,8 +781,8 @@
- if (pk != NULL) {
- free(pk->pk_base); pk -> pk_base = 0;
- if (pk->pk_morec != NULL) {
-- free((char *) pk->pk_morec); (char *) pk->pk_morec = 0;
-+ free((char *) pk->pk_morec); pk->pk_morec = 0;
- }
-- free((char *) pk); (char *) pk = 0;
-+ free((char *) pk); pk = 0;
- }
- }
diff --git a/print/dviselect/files/patch-lib_pxlfont.c b/print/dviselect/files/patch-lib_pxlfont.c
deleted file mode 100644
index 2c9148755d63..000000000000
--- a/print/dviselect/files/patch-lib_pxlfont.c
+++ /dev/null
@@ -1,28 +0,0 @@
---- lib/pxlfont.c~ Wed Nov 15 13:19:53 1989
-+++ lib/pxlfont.c Wed Dec 13 23:03:21 2006
-@@ -156,7 +156,7 @@
- if (pd->pd_ras) {
- free(pd->pd_ras); pd->pd_ras = 0;
- }
-- free((char *) pd); (char *) pd = 0;
-+ free((char *) pd); pd = 0;
- }
- if (fp)
- (void) fclose(fp);
-@@ -286,7 +286,7 @@
- pd->pd_nconv += h - l;
- if (pd->pd_nconv == 128) {
- free(pd->pd_ras); pd->pd_ras = 0;
-- free((char *) pd); (char *) pd = 0;
-+ free((char *) pd); pd = 0;
- f->f_details = NULL;
- }
- return (0);
-@@ -305,6 +305,6 @@
- if (pd->pd_ras != NULL) {
- free(pd->pd_ras); pd->pd_ras = 0;
- }
-- free((char *) pd); (char *) pd = 0;
-+ free((char *) pd); pd = 0;
- }
- }
diff --git a/print/dviselect/files/patch-lib_rotate.c b/print/dviselect/files/patch-lib_rotate.c
deleted file mode 100644
index 51af383d9d2e..000000000000
--- a/print/dviselect/files/patch-lib_rotate.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- lib/rotate.c.orig 2012-11-30 14:57:39.000000000 +0100
-+++ lib/rotate.c 2012-11-30 14:58:50.000000000 +0100
-@@ -31,6 +31,7 @@
- /*
- * Set the rotation of glyph g to r.
- */
-+void
- SetRotation(g, r)
- register struct glyph *g;
- int r;
diff --git a/print/dviselect/files/patch-lib_search.c b/print/dviselect/files/patch-lib_search.c
deleted file mode 100644
index 43054c620521..000000000000
--- a/print/dviselect/files/patch-lib_search.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/search.c~ Wed Nov 15 13:19:58 1989
-+++ lib/search.c Wed Dec 13 22:53:51 2006
-@@ -72,7 +72,7 @@
- s->s_space = 10; /* initially, room for 10 objects */
- s->s_n = 0; /* and none in the table */
- if ((s->s_data = malloc(s->s_space * dsize)) == 0) {
-- free((char *) s); (char *) s = 0;
-+ free((char *) s); s = 0;
- return (0);
- }
- return (s);
diff --git a/print/dviselect/files/patch-lib_seek.c b/print/dviselect/files/patch-lib_seek.c
deleted file mode 100644
index 05abce5e78fe..000000000000
--- a/print/dviselect/files/patch-lib_seek.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- lib/seek.c~ Wed Nov 15 13:19:59 1989
-+++ lib/seek.c Tue Aug 19 18:46:13 1997
-@@ -25,7 +25,6 @@
- #include <sys/file.h>
- #include <sys/stat.h>
-
--long lseek();
- char *getenv();
-
- int
diff --git a/print/dviselect/files/patch-lib_tfm.c b/print/dviselect/files/patch-lib_tfm.c
deleted file mode 100644
index 72623335046a..000000000000
--- a/print/dviselect/files/patch-lib_tfm.c
+++ /dev/null
@@ -1,23 +0,0 @@
---- lib/tfm.c~ Wed Nov 15 13:20:02 1989
-+++ lib/tfm.c Wed Dec 13 22:56:44 2006
-@@ -63,16 +63,16 @@
-
- bad:
- if (t->t_ci != NULL) {
-- free((char *) t->t_ci); (char *) t->t_ci = 0;
-+ free((char *) t->t_ci); t->t_ci = 0;
- }
- if (t->t_width != NULL) {
-- free((char *) t->t_width); (char *) t->t_width = 0;
-+ free((char *) t->t_width); t->t_width = 0;
- }
- if (t->t_height != NULL) {
-- free((char *) t->t_height); (char *) t->t_height = 0;
-+ free((char *) t->t_height); t->t_height = 0;
- }
- if (t->t_depth != NULL) {
-- free((char *) t->t_depth); (char *) t->t_depth = 0;
-+ free((char *) t->t_depth); t->t_depth = 0;
- }
- return (-1);
- }
diff --git a/print/dviselect/files/patch-lib_tfmfont.c b/print/dviselect/files/patch-lib_tfmfont.c
deleted file mode 100644
index 9de2cc7bce0f..000000000000
--- a/print/dviselect/files/patch-lib_tfmfont.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- lib/tfmfont.c.orig 1989-11-15 13:20:03.000000000 +0100
-+++ lib/tfmfont.c 2012-11-30 15:00:41.000000000 +0100
-@@ -139,7 +139,7 @@
- fail:
- (void) fclose(fd);
- if (tfm != NULL) {
-- free((char *) tfm); (char *) tfm = 0;
-+ free((char *) tfm); tfm = 0;
- }
- return (-1);
- }
-@@ -199,7 +199,7 @@
- #define EDGE 2
-
- if (tfm->tfm_edge == 0)
-- return;
-+ return (-1);
- if (tfm->tfm_edge != 2) panic("tfm_rasterise");
- for (i = l; i < h; i++) {
- g = f->f_gly[i];
diff --git a/print/dviselect/pkg-descr b/print/dviselect/pkg-descr
deleted file mode 100644
index 672e772df062..000000000000
--- a/print/dviselect/pkg-descr
+++ /dev/null
@@ -1,3 +0,0 @@
-Dviselect selects pages from a DVI file produced by TeX, creating a
-new DVI file usable by any of TeX's conversion program, or even by
-dviselect itself.
diff --git a/print/dviselect/scripts/configure b/print/dviselect/scripts/configure
deleted file mode 100644
index cd9900bcf250..000000000000
--- a/print/dviselect/scripts/configure
+++ /dev/null
@@ -1,13 +0,0 @@
-#!/bin/sh
-
-cd $WRKSRC
-mv Makefile Makefile~
-sed -e /DELETE/q <Makefile~ >Makefile
-
-echo "BINDIR = $PREFIX/bin" >> $WRKSRC/Makefile || exit 1;
-echo "MANDIR = $PREFIX/man" >> $WRKSRC/Makefile || exit 1;
-echo "all: default" >> $WRKSRC/Makefile || exit 1;
-echo "install: inst-dviselect" >> $WRKSRC/Makefile || exit 1;
-echo "CFLAGS= $CFLAGS -I../h -I./h -DHAVE_VPRINTF" >> $WRKSRC/Makefile || exit 1;
-echo "MFLAGS=CFLAGS=\"\${CFLAGS}\"" >> $WRKSRC/Makefile || exit 1;
-exit 0;