aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/p5-Log-Dispatchouli/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/devel/p5-Log-Dispatchouli/Makefile b/devel/p5-Log-Dispatchouli/Makefile
index fb6aaa436d21..6ee071c10d35 100644
--- a/devel/p5-Log-Dispatchouli/Makefile
+++ b/devel/p5-Log-Dispatchouli/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Log-Dispatchouli
PORTVERSION= 2.005
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -21,8 +22,11 @@ RUN_DEPENDS= p5-Log-Dispatch>=0:${PORTSDIR}/devel/p5-Log-Dispatch \
p5-Log-Dispatch-Array>=0:${PORTSDIR}/devel/p5-Log-Dispatch-Array \
p5-Sub-Exporter>=0:${PORTSDIR}/devel/p5-Sub-Exporter \
p5-Sub-Exporter-GlobExporter>=0:${PORTSDIR}/devel/p5-Sub-Exporter-GlobExporter \
- p5-String-Flogger>=0:${PORTSDIR}/textproc/p5-String-Flogger
+ p5-String-Flogger>=0:${PORTSDIR}/textproc/p5-String-Flogger \
+ p5-Try-Tiny>0:${PORTSDIR}/lang/p5-Try-Tiny
BUILD_DEPENDS:= ${RUN_DEPENDS}
+TEST_DEPENDS= p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep \
+ p5-Test-Fatal>=0:${PORTSDIR}/devel/p5-Test-Fatal
PERL_CONFIGURE= yes
@@ -30,4 +34,10 @@ MAN3= Log::Dispatchouli.3 \
Log::Dispatchouli::Global.3 \
Log::Dispatchouli::Proxy.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501400
+TEST_DEPENDS+= p5-Test-Simple>=0.98:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>