aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/Makefile1
-rw-r--r--audio/gmpc-qosd/Makefile26
-rw-r--r--audio/gmpc-qosd/distinfo3
-rw-r--r--audio/gmpc-qosd/pkg-descr3
-rw-r--r--audio/gmpc-qosd/pkg-plist3
5 files changed, 36 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 8a2f90948be7..596dc759d237 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -198,6 +198,7 @@
SUBDIR += gmidimonitor
SUBDIR += gmixer
SUBDIR += gmpc
+ SUBDIR += gmpc-qosd
SUBDIR += gmpc-serverstats
SUBDIR += gmpccaa
SUBDIR += gnapster
diff --git a/audio/gmpc-qosd/Makefile b/audio/gmpc-qosd/Makefile
new file mode 100644
index 000000000000..e6fc26bf99df
--- /dev/null
+++ b/audio/gmpc-qosd/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: gmpc-qosd
+# Date created: September 14 2007
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gmpc-qosd
+PORTVERSION= 0.15.0
+CATEGORIES= audio
+MASTER_SITES= http://download.sarine.nl/gmpc-${PORTVERSION}/plugins/
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= Q on Screen Display plugin for gmpc
+
+LIB_DEPENDS= mpd:${PORTSDIR}/audio/libmpd \
+ curl.4:${PORTSDIR}/ftp/curl
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gmpc.pc:${PORTSDIR}/audio/gmpc \
+ xosd-config:${PORTSDIR}/misc/xosd
+RUN_DEPEND= gmpc:${PORTSDIR}/audio/gmpc
+
+GNU_CONFIGURE= yes
+USE_XLIB= yes
+USE_GNOME= gnomehack
+
+.include <bsd.port.mk>
diff --git a/audio/gmpc-qosd/distinfo b/audio/gmpc-qosd/distinfo
new file mode 100644
index 000000000000..0b68abb5ffc8
--- /dev/null
+++ b/audio/gmpc-qosd/distinfo
@@ -0,0 +1,3 @@
+MD5 (gmpc-qosd-0.15.0.tar.gz) = 40c2e76ca84a15c9199dfdb8e7ec183d
+SHA256 (gmpc-qosd-0.15.0.tar.gz) = 539f37b2879acfb5743e417b60ef9f760264db2b745a3364d36a94292b1c1dec
+SIZE (gmpc-qosd-0.15.0.tar.gz) = 311563
diff --git a/audio/gmpc-qosd/pkg-descr b/audio/gmpc-qosd/pkg-descr
new file mode 100644
index 000000000000..3e717d0244bf
--- /dev/null
+++ b/audio/gmpc-qosd/pkg-descr
@@ -0,0 +1,3 @@
+A on-screen-display written to look nicer then xosd.
+
+WWW: http://sarine.nl/gmpc-plugins
diff --git a/audio/gmpc-qosd/pkg-plist b/audio/gmpc-qosd/pkg-plist
new file mode 100644
index 000000000000..1891dacdd383
--- /dev/null
+++ b/audio/gmpc-qosd/pkg-plist
@@ -0,0 +1,3 @@
+share/gmpc/plugins/qosdplugin.so
+@dirrmtry share/gmpc/plugins
+@dirrmtry share/gmpc