aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/kbarcode/Makefile28
-rw-r--r--graphics/kbarcode/distinfo1
-rw-r--r--graphics/kbarcode/pkg-comment1
-rw-r--r--graphics/kbarcode/pkg-descr22
-rw-r--r--graphics/kbarcode/pkg-plist19
6 files changed, 72 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 6be5e63351c3..5339fac53bc7 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -165,6 +165,7 @@
SUBDIR += jslice
SUBDIR += juno-2
SUBDIR += kallery
+ SUBDIR += kbarcode
SUBDIR += kdc2tiff
SUBDIR += kdegraphics3
SUBDIR += kisomandel
diff --git a/graphics/kbarcode/Makefile b/graphics/kbarcode/Makefile
new file mode 100644
index 000000000000..72f09c0dfbd9
--- /dev/null
+++ b/graphics/kbarcode/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: kbarcode
+# Date created: 05 July 2002
+# Whom: Andy Raffle <andy@digitalspecies.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kbarcode
+PORTVERSION= 0.4.3
+CATEGORIES= graphics kde
+MASTER_SITES= ftp://ftp.kde.com/pub/Office/Organize_Track/KBarcode/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= andy@digitalspecies.com
+
+BUILD_DEPENDS= barcode:${PORTSDIR}/graphics/barcode
+
+USE_KDELIBS_VER=3
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=
+CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL} \
+ --with-extra-includes=${LOCALBASE}/include
+
+post-install:
+ ${STRIP_CMD} ${PREFIX}/bin/kbarcode
+
+.include <bsd.port.mk>
diff --git a/graphics/kbarcode/distinfo b/graphics/kbarcode/distinfo
new file mode 100644
index 000000000000..9df150c61c22
--- /dev/null
+++ b/graphics/kbarcode/distinfo
@@ -0,0 +1 @@
+MD5 (kbarcode-0.4.3.tar.gz) = d34a41875b3ecf66749d6b11a41ce26e
diff --git a/graphics/kbarcode/pkg-comment b/graphics/kbarcode/pkg-comment
new file mode 100644
index 000000000000..7e2c133e6d2f
--- /dev/null
+++ b/graphics/kbarcode/pkg-comment
@@ -0,0 +1 @@
+KBarcode creates, handles, manages and prints barcodes
diff --git a/graphics/kbarcode/pkg-descr b/graphics/kbarcode/pkg-descr
new file mode 100644
index 000000000000..f530bd4cd9d8
--- /dev/null
+++ b/graphics/kbarcode/pkg-descr
@@ -0,0 +1,22 @@
+KBarcode creates, handles, manages and prints barcodes
+
+* a label designer with more than 1,000 predefined labels
+ and support for creating customized labels
+* a barcode generator for creating single barcodes and
+ saving or printing them
+* support for using an SQL database for storing data
+* a configuration wizard for connecting to an SQL database
+ and creating database tables
+* support for different barcode formats (like UPC, EAN, etc.)
+ for each article
+* support for adding customer-related information and print
+ customized barcodes for each article
+* batch control for importing a very large number of barcode
+ descriptions (quantity and number of articles) and printing
+ them using the specified barcode label
+* a friendly GUI.
+
+WWW: http://kbarcode.sourceforge.net/
+Authors: Dominik Seichter <domseichter@web.de>,
+ Stefan "Stonki" Onken <stonki@gmx.de>
+Maintainer: Andy Raffle <andy@digitalspecies.com>
diff --git a/graphics/kbarcode/pkg-plist b/graphics/kbarcode/pkg-plist
new file mode 100644
index 000000000000..a2f5bdb73b64
--- /dev/null
+++ b/graphics/kbarcode/pkg-plist
@@ -0,0 +1,19 @@
+bin/kbarcode
+share/applnk/Applications/kbarcode.desktop
+share/icons/locolor/32x32/apps/kbarcode.png
+share/icons/locolor/16x16/apps/kbarcode.png
+share/apps/kbarcode/labeldefinitions.sql
+share/apps/kbarcode/exampledata.sql
+share/apps/kbarcode/barcodes.html
+share/doc/HTML/en/kbarcode/index.docbook
+share/doc/HTML/en/kbarcode/index.cache.bz2
+share/doc/HTML/en/kbarcode/common
+@dirrm share/doc/HTML/en/kbarcode
+@dirrm share/apps/kbarcode
+@unexec rmdir %D/share/icons/locolor/32x32/apps 2>/dev/null || true
+@unexec rmdir %D/share/icons/locolor/32x32 2>/dev/null || true
+@unexec rmdir %D/share/icons/locolor 2>/dev/null || true
+@unexec rmdir %D/share/icons/locolor/16x16/apps 2>/dev/null || true
+@unexec rmdir %D/share/icons/locolor/16x16 2>/dev/null || true
+@unexec rmdir %D/share/icons/locolor 2>/dev/null || true
+@unexec rmdir %D/share/applnk/Applications 2>/dev/null || true