aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--editors/vim/Makefile1
-rw-r--r--editors/vim6/Makefile1
-rw-r--r--irc/irssi/Makefile1
-rw-r--r--misc/amanda-server/Makefile1
-rw-r--r--misc/amanda25-server/Makefile1
-rw-r--r--misc/amanda26-server/Makefile1
-rw-r--r--misc/amanda32-server/Makefile1
-rw-r--r--net/freeradius/Makefile1
-rw-r--r--net/freeradius2/Makefile1
-rw-r--r--print/hpijs/Makefile1
10 files changed, 10 insertions, 0 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 1d930e99cf99..069c7f18285c 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -67,6 +67,7 @@ MANLANG= "" ru.KOI8-R ru.UTF-8 pl.ISO8859-2 pl.UTF-8 pl fr.ISO8859-1 \
fr.UTF-8 fr it.ISO8859-1 it.UTF-8 it
WANT_GNOME= yes
+WANT_PERL= yes
.if defined(WITH_PYTHON)
USE_PYTHON= yes
diff --git a/editors/vim6/Makefile b/editors/vim6/Makefile
index 4b77e5f57e84..57eb2da08cf2 100644
--- a/editors/vim6/Makefile
+++ b/editors/vim6/Makefile
@@ -54,6 +54,7 @@ MLINKS+= vim.1 gvim.1 vim.1 gview.1 vimdiff.1 gvimdiff.1 \
.endif
WANT_GNOME= yes
+WANT_PERL= yes
.if defined(WITH_PYTHON)
USE_PYTHON= yes
diff --git a/irc/irssi/Makefile b/irc/irssi/Makefile
index 1d81811b9211..34c8721069cc 100644
--- a/irc/irssi/Makefile
+++ b/irc/irssi/Makefile
@@ -20,6 +20,7 @@ USE_BZIP2= yes
USE_GNOME= glib20
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-module
+WANT_PERL= yes
MAN1= irssi.1
diff --git a/misc/amanda-server/Makefile b/misc/amanda-server/Makefile
index 89520ce8f8d8..037b3e3b43e5 100644
--- a/misc/amanda-server/Makefile
+++ b/misc/amanda-server/Makefile
@@ -30,6 +30,7 @@ CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
--disable-libtool --prefix=${PREFIX} \
--with-user=${AMANDA_USER} --with-group=${AMANDA_GROUP}
INSTALLS_SHLIB= yes
+WANT_PERL= yes
OPTIONS= GNUTAR "use GNU tar" on
diff --git a/misc/amanda25-server/Makefile b/misc/amanda25-server/Makefile
index 89520ce8f8d8..037b3e3b43e5 100644
--- a/misc/amanda25-server/Makefile
+++ b/misc/amanda25-server/Makefile
@@ -30,6 +30,7 @@ CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
--disable-libtool --prefix=${PREFIX} \
--with-user=${AMANDA_USER} --with-group=${AMANDA_GROUP}
INSTALLS_SHLIB= yes
+WANT_PERL= yes
OPTIONS= GNUTAR "use GNU tar" on
diff --git a/misc/amanda26-server/Makefile b/misc/amanda26-server/Makefile
index 89520ce8f8d8..037b3e3b43e5 100644
--- a/misc/amanda26-server/Makefile
+++ b/misc/amanda26-server/Makefile
@@ -30,6 +30,7 @@ CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
--disable-libtool --prefix=${PREFIX} \
--with-user=${AMANDA_USER} --with-group=${AMANDA_GROUP}
INSTALLS_SHLIB= yes
+WANT_PERL= yes
OPTIONS= GNUTAR "use GNU tar" on
diff --git a/misc/amanda32-server/Makefile b/misc/amanda32-server/Makefile
index 89520ce8f8d8..037b3e3b43e5 100644
--- a/misc/amanda32-server/Makefile
+++ b/misc/amanda32-server/Makefile
@@ -30,6 +30,7 @@ CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
--disable-libtool --prefix=${PREFIX} \
--with-user=${AMANDA_USER} --with-group=${AMANDA_GROUP}
INSTALLS_SHLIB= yes
+WANT_PERL= yes
OPTIONS= GNUTAR "use GNU tar" on
diff --git a/net/freeradius/Makefile b/net/freeradius/Makefile
index be4f0f91a493..38ec0a6d154f 100644
--- a/net/freeradius/Makefile
+++ b/net/freeradius/Makefile
@@ -20,6 +20,7 @@ MAINTAINER?= david@wood2.org.uk
COMMENT?= A free RADIUS server implementation
USE_BZIP2= yes
+WANT_PERL= yes
LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm
diff --git a/net/freeradius2/Makefile b/net/freeradius2/Makefile
index be4f0f91a493..38ec0a6d154f 100644
--- a/net/freeradius2/Makefile
+++ b/net/freeradius2/Makefile
@@ -20,6 +20,7 @@ MAINTAINER?= david@wood2.org.uk
COMMENT?= A free RADIUS server implementation
USE_BZIP2= yes
+WANT_PERL= yes
LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm
diff --git a/print/hpijs/Makefile b/print/hpijs/Makefile
index b4a81405f5d9..a1c7854a4f10 100644
--- a/print/hpijs/Makefile
+++ b/print/hpijs/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-dependency-tracking
USE_GHOSTSCRIPT_RUN= yes
+WANT_PERL= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"