aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/mixxx/Makefile39
-rw-r--r--audio/mixxx/distinfo4
-rw-r--r--audio/mixxx/files/patch-build__qt4.py2
-rw-r--r--audio/mixxx/files/patch-src__SConscript.env24
-rw-r--r--audio/mixxx/files/patch-src__recording__encodermp3.cpp16
-rw-r--r--audio/mixxx/pkg-plist4
6 files changed, 55 insertions, 34 deletions
diff --git a/audio/mixxx/Makefile b/audio/mixxx/Makefile
index be142a1a87af..c029dfc6c585 100644
--- a/audio/mixxx/Makefile
+++ b/audio/mixxx/Makefile
@@ -1,18 +1,11 @@
-# New ports collection makefile for: Mixxx
-# Date created: 25 Jun 2004
-# Whom: Jean-Yves Lefort <jylefort@brutele.be>
-#
+# Created by: Jean-Yves Lefort <jylefort@brutele.be>
# $FreeBSD$
-#
PORTNAME= mixxx
-PORTVERSION= 1.10.0
-PORTREVISION= 3
+PORTVERSION= 1.10.1
DISTVERSIONSUFFIX= -src
CATEGORIES= audio
-MASTER_SITES= http://mixxx.rasant-records.de/downloads/%SUBDIR%/ \
- http://moo.glines.org/mixxx/%SUBDIR%/ \
- http://web.mit.edu/rryan/www/downloads.mixxx.org/%SUBDIR%/
+MASTER_SITES= http://moo.glines.org/mixxx/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
@@ -20,24 +13,25 @@ COMMENT= A DJ mixing application
LICENSE= GPLv2 # (or later)
-LIB_DEPENDS= FLAC.10:${PORTSDIR}/audio/flac \
- id3tag.0:${PORTSDIR}/audio/libid3tag \
- mad.2:${PORTSDIR}/audio/libmad \
- sndfile.1:${PORTSDIR}/audio/libsndfile \
- vorbis.4:${PORTSDIR}/audio/libvorbis \
- portaudio.2:${PORTSDIR}/audio/portaudio2 \
- tag.1:${PORTSDIR}/audio/taglib
+BUILD_DEPENDS= portaudio>=19:${PORTSDIR}/audio/portaudio2
+LIB_DEPENDS= FLAC:${PORTSDIR}/audio/flac \
+ id3tag:${PORTSDIR}/audio/libid3tag \
+ mad:${PORTSDIR}/audio/libmad \
+ sndfile:${PORTSDIR}/audio/libsndfile \
+ vorbis:${PORTSDIR}/audio/libvorbis \
+ tag:${PORTSDIR}/audio/taglib
+RUN_DEPENDS= portaudio>=19:${PORTSDIR}/audio/portaudio2
-OPTIONS_DEFINE= LAME FAAD WAVPACK SHOUTCAST DOCS
-SHOUTCAST_DESC= Enable Shoutcast Broadcasting
-WAVPACK_DESC= Enable WavPack audio support plugin
+OPTIONS_DEFINE= LAME SHOUTCAST FAAD WAVPACK DOCS
+SHOUTCAST_DESC= Shoutcast Broadcasting
+WAVPACK_DESC= WavPack audio support plugin
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USE_GL= glu
USE_QT4= corelib gui network opengl script sql svg webkit xml \
xmlpatterns linguist_build moc_build qmake_build rcc_build \
uic_build
+USE_GL= glu
USE_SCONS= yes
SCONS_BUILDENV= ${SCONS_ENV}
SCONS_ARGS= qtdir="${QT_PREFIX}" optimize=0
@@ -82,7 +76,8 @@ post-patch:
s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/${FILE}
.endfor
@${REINPLACE_CMD} -e \
- "/('install', docs)/d" ${WRKSRC}/src/SConscript
+ "/_get_bzr_/s|^|#| ; \
+ /('install', docs)/d" ${WRKSRC}/src/SConscript
@${REINPLACE_CMD} -e \
"s|^Exec=.*|Exec=mixxx|" ${WRKSRC}/src/mixxx.desktop
diff --git a/audio/mixxx/distinfo b/audio/mixxx/distinfo
index 362edbff48a9..8b5b6fc1061d 100644
--- a/audio/mixxx/distinfo
+++ b/audio/mixxx/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mixxx-1.10.0-src.tar.gz) = 9135f814262bf42eb05bf5d56c760ab462329c06785271d570be6a9d14ab1e97
-SIZE (mixxx-1.10.0-src.tar.gz) = 15852338
+SHA256 (mixxx-1.10.1-src.tar.gz) = eab49a95336dacee9a9e4c2ad22a0436e9c0b341930e9a03e3b46619d7a9f365
+SIZE (mixxx-1.10.1-src.tar.gz) = 15948956
diff --git a/audio/mixxx/files/patch-build__qt4.py b/audio/mixxx/files/patch-build__qt4.py
index 1cda90dd3de0..e19f9b9b3630 100644
--- a/audio/mixxx/files/patch-build__qt4.py
+++ b/audio/mixxx/files/patch-build__qt4.py
@@ -6,7 +6,7 @@
QT4_BINPATH = os.path.join('$QTDIR', 'bin'),
- QT4_CPPPATH = os.path.join('$QTDIR', 'include'),
- QT4_LIBPATH = os.path.join('$QTDIR', 'lib'),
-+ QT4_CPPPATH = os.path.join('$QTDIR', 'include', 'qt4'),
++ QT4_CPPPATH = os.path.join('$QTDIR', 'include', 'qt4', 'Qt'),
+ QT4_LIBPATH = os.path.join('$QTDIR', 'lib', 'qt4'),
# TODO: This is not reliable to QTDIR value changes but needed in order to support '-qt4' variants
QT4_MOC = locateQt4Command(env,'moc', env['QTDIR']),
diff --git a/audio/mixxx/files/patch-src__SConscript.env b/audio/mixxx/files/patch-src__SConscript.env
new file mode 100644
index 000000000000..d9fb4cffeb32
--- /dev/null
+++ b/audio/mixxx/files/patch-src__SConscript.env
@@ -0,0 +1,24 @@
+--- src/SConscript.env.orig 2012-06-26 05:23:40.000000000 +0900
++++ src/SConscript.env 2012-08-09 09:03:53.000000000 +0900
+@@ -19,21 +19,6 @@
+ print "Deleting deprecated build file: %s" % defs
+ os.remove(defs)
+
+-#env.Append(CPPDEFINES=[('BUILD_REV', '"%s"' % getBZRRevision())]) #doing this forces a rebuild of everything whenever a commit happens -- not much fun
+-## instead, embed BZR version into build
+-## Put version info into a file, so it doesn't force a rebuild of everything :)
+-f = open("build.h","w")
+-try:
+- branch_name = util.get_bzr_branch_name()
+- modified = util.get_bzr_modified() > 0
+- # Do not emit BUILD_BRANCH on release branches.
+- if not branch_name.startswith('release'):
+- f.write('#define BUILD_BRANCH "%s"\n' % branch_name)
+- f.write('#define BUILD_REV "%s%s"\n' % (util.get_bzr_revision(),
+- '+' if modified else ''))
+-finally:
+- f.close()
+-
+ #Check for dependencies if we're not doing a clean...
+ #if not env.GetOption('clean') and not SCons.Util.containsAny(os.sys.argv, ['-h', '--help']):
+ conf = Configure(env, custom_tests = { 'CheckForPKGConfig' : util.CheckForPKGConfig,
diff --git a/audio/mixxx/files/patch-src__recording__encodermp3.cpp b/audio/mixxx/files/patch-src__recording__encodermp3.cpp
index dddb365a8928..8ce01c4d4ca7 100644
--- a/audio/mixxx/files/patch-src__recording__encodermp3.cpp
+++ b/audio/mixxx/files/patch-src__recording__encodermp3.cpp
@@ -1,17 +1,15 @@
---- src/recording/encodermp3.cpp.orig 2011-12-24 11:53:18.000000000 +0900
-+++ src/recording/encodermp3.cpp 2012-01-16 06:10:09.000000000 +0900
-@@ -85,7 +85,9 @@
+--- src/recording/encodermp3.cpp.orig 2012-06-26 05:23:37.000000000 +0900
++++ src/recording/encodermp3.cpp 2012-08-09 09:06:21.000000000 +0900
+@@ -85,7 +85,7 @@
*/
QStringList libnames;
QString libname = "";
-#ifdef __LINUX__
-+#ifdef __BSD__
-+ libnames << "%%LOCALBASE%%/lib/libmp3lame.so";
-+#elif __LINUX__
- libnames << "/usr/lib/libmp3lame.so.0";
- libnames << "/usr/lib/libmp3lame.so";
++#if defined(__BSD__) || defined(__LINUX__)
+ libnames << "mp3lame";
#elif __WINDOWS__
-@@ -109,7 +111,7 @@
+ libnames << "lame_enc.dll";
+@@ -108,7 +108,7 @@
props->setType(DLG_WARNING);
props->setTitle(tr("Encoder"));
QString key = "";
diff --git a/audio/mixxx/pkg-plist b/audio/mixxx/pkg-plist
index 35d3cb6ce826..ac6a4fc7d8b6 100644
--- a/audio/mixxx/pkg-plist
+++ b/audio/mixxx/pkg-plist
@@ -19,6 +19,8 @@ share/applications/mixxx.desktop
%%DATADIR%%/midi/DJ-Tech-i-Mix-Reload-scripts.js
%%DATADIR%%/midi/DJTechTools MIDI Fighter.midi.xml
%%DATADIR%%/midi/DJTechTools-MIDIFighter-scripts.js
+%%DATADIR%%/midi/Denon MC3000.midi.xml
+%%DATADIR%%/midi/Denon-MC3000-scripts.js
%%DATADIR%%/midi/Evolution_Xsession.midi.xml
%%DATADIR%%/midi/FaderFoxDJ2.midi.xml
%%DATADIR%%/midi/Hercules DJ Console Mac Edition.midi.xml
@@ -75,9 +77,11 @@ share/applications/mixxx.desktop
%%DATADIR%%/midi/Vestax Spin.midi.xml
%%DATADIR%%/midi/Vestax Typhoon.midi.xml
%%DATADIR%%/midi/Vestax VCI-100.midi.xml
+%%DATADIR%%/midi/Vestax VCI-400.midi.xml
%%DATADIR%%/midi/Vestax-Spin-scripts.js
%%DATADIR%%/midi/Vestax-Typhoon-scripts.js
%%DATADIR%%/midi/Vestax-VCI-100-scripts.js
+%%DATADIR%%/midi/Vestax-VCI-400-scripts.js
%%DATADIR%%/midi/Wireless DJ App.midi.xml
%%DATADIR%%/midi/Wireless-DJ-scripts.js
%%DATADIR%%/midi/convertToXMLSchemaV1.php