aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--japanese/uim-anthy/Makefile20
-rw-r--r--japanese/uim-anthy/pkg-plist2
-rw-r--r--japanese/uim-canna/Makefile10
-rw-r--r--japanese/uim-prime/Makefile10
-rw-r--r--textproc/uim-gnome/Makefile4
-rw-r--r--textproc/uim-gtk/Makefile4
-rw-r--r--textproc/uim-m17nlib/Makefile10
-rw-r--r--textproc/uim-qt/Makefile4
-rw-r--r--textproc/uim/Makefile29
-rw-r--r--textproc/uim/pkg-plist4
10 files changed, 84 insertions, 13 deletions
diff --git a/japanese/uim-anthy/Makefile b/japanese/uim-anthy/Makefile
index 051f4c12f299..1fac63003bac 100644
--- a/japanese/uim-anthy/Makefile
+++ b/japanese/uim-anthy/Makefile
@@ -6,18 +6,28 @@
#
CATEGORIES= japanese
+.if defined(WITHOUT_X11)
+PKGNAMESUFFIX= -anthy-nox11
+.else
PKGNAMESUFFIX= -anthy
+.endif
COMMENT= Uim plugin using Anthy input method
+.if !defined(WITHOUT_X11)
USE_GNOME= gtk20
+.endif
LIB_DEPENDS= anthy.1:${PORTSDIR}/japanese/anthy \
uim.2:${PORTSDIR}/textproc/uim
MASTERDIR= ${.CURDIR}/../../textproc/uim
PKGDIR= ${.CURDIR}
-CONFIGURE_ARGS= --with-anthy --with-gtk2 --enable-dict
+CONFIGURE_ARGS= --with-anthy
+
+.if !defined(WITHOUT_X11)
+CONFIGURE_ARGS+= --with-gtk2 -enable-dict
+.endif
UIM_SLAVE= yes
@@ -26,14 +36,22 @@ EXTRA_PATCHES= ${PATCHDIR}/extra-patch-uim_Makefile.in \
do-build:
(cd ${WRKSRC}/uim && ${GMAKE} libuim-anthy.la)
+.if !defined(WITHOUT_X11)
(cd ${WRKSRC}/helper && ${GMAKE} LIBS="-luim" uim-dict-gtk)
+.endif
do-install:
(cd ${WRKSRC}/uim && \
${GMAKE} uim_plugin_LTLIBRARIES=libuim-anthy.la install-uim_pluginLTLIBRARIES)
+.if !defined(WITHOUT_X11)
(cd ${WRKSRC}/helper && ${GMAKE} bin_PROGRAMS=uim-dict-gtk install-binPROGRAMS)
+.endif
post-install:
+.if defined(WITHOUT_X11)
+ ${LOCALBASE}/bin/uim-module-manager --register anthy
+.else
${X11BASE}/bin/uim-module-manager --register anthy
+.endif
.include "${MASTERDIR}/Makefile"
diff --git a/japanese/uim-anthy/pkg-plist b/japanese/uim-anthy/pkg-plist
index c84f90800556..1cd2cccad83a 100644
--- a/japanese/uim-anthy/pkg-plist
+++ b/japanese/uim-anthy/pkg-plist
@@ -1,4 +1,4 @@
-bin/uim-dict-gtk
+%%X11%%bin/uim-dict-gtk
lib/uim/plugin/libuim-anthy.a
lib/uim/plugin/libuim-anthy.la
lib/uim/plugin/libuim-anthy.so
diff --git a/japanese/uim-canna/Makefile b/japanese/uim-canna/Makefile
index 1b5ea55a452c..c7ef0158f2cd 100644
--- a/japanese/uim-canna/Makefile
+++ b/japanese/uim-canna/Makefile
@@ -6,7 +6,11 @@
#
CATEGORIES= japanese
+.if defined(WITHOUT_X11)
+PKGNAMESUFFIX= -canna-nox11
+.else
PKGNAMESUFFIX= -canna
+.endif
COMMENT= Uim plugin using Canna input method
@@ -29,6 +33,10 @@ do-install:
${GMAKE} uim_plugin_LTLIBRARIES=libuim-canna.la install-uim_pluginLTLIBRARIES)
post-install:
- ${X11BASE}/bin/uim-module-manager --register canna
+.if defined(WITHOUT_X11)
+ ${LOCALBASE}/bin/uim-module-manager --register anthy
+.else
+ ${X11BASE}/bin/uim-module-manager --register anthy
+.endif
.include "${MASTERDIR}/Makefile"
diff --git a/japanese/uim-prime/Makefile b/japanese/uim-prime/Makefile
index 21a1f0c5cf09..62df9409e63d 100644
--- a/japanese/uim-prime/Makefile
+++ b/japanese/uim-prime/Makefile
@@ -6,7 +6,11 @@
#
CATEGORIES= japanese
+.if defined(WITHOUT_X11)
+PKGNAMESUFFIX= -prime-nox11
+.else
PKGNAMESUFFIX= -prime
+.endif
COMMENT= Uim plugin using PRIME input method
@@ -30,6 +34,10 @@ do-install:
${GMAKE} uim_plugin_LTLIBRARIES=libuim-prime.la install-uim_pluginLTLIBRARIES)
post-install:
- ${X11BASE}/bin/uim-module-manager --register prime
+.if defined(WITHOUT_X11)
+ ${LOCALBASE}/bin/uim-module-manager --register anthy
+.else
+ ${X11BASE}/bin/uim-module-manager --register anthy
+.endif
.include "${MASTERDIR}/Makefile"
diff --git a/textproc/uim-gnome/Makefile b/textproc/uim-gnome/Makefile
index 5f936e2693dc..f7e268412d00 100644
--- a/textproc/uim-gnome/Makefile
+++ b/textproc/uim-gnome/Makefile
@@ -20,6 +20,10 @@ UIM_SLAVE= yes
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-helper_Makefile.in
+.if defined(WITHOUT_X11)
+IGNORE= requires X11
+.endif
+
do-build:
(cd ${WRKSRC}/helper && ${GMAKE} LIBS="-luim -luim-custom")
diff --git a/textproc/uim-gtk/Makefile b/textproc/uim-gtk/Makefile
index 98aec34e26cd..6f3d8268f7f9 100644
--- a/textproc/uim-gtk/Makefile
+++ b/textproc/uim-gtk/Makefile
@@ -21,6 +21,10 @@ UIM_SLAVE= yes
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-gtk_Makefile.in \
${PATCHDIR}/extra-patch-helper_Makefile.in
+.if defined(WITHOUT_X11)
+IGNORE= requires X11
+.endif
+
do-build:
(cd ${WRKSRC}/gtk && ${GMAKE} LIBS="-luim")
(cd ${WRKSRC}/helper && ${GMAKE} LIBS="-luim -luim-custom")
diff --git a/textproc/uim-m17nlib/Makefile b/textproc/uim-m17nlib/Makefile
index dbe18c204187..a7345bb7fc60 100644
--- a/textproc/uim-m17nlib/Makefile
+++ b/textproc/uim-m17nlib/Makefile
@@ -5,7 +5,11 @@
# $FreeBSD$
#
+.if defined(WITHOUT_X11)
+PKGNAMESUFFIX= -m17nlib-nox11
+.else
PKGNAMESUFFIX= -m17nlib
+.endif
COMMENT= Uim plugin using m17n library input method
@@ -28,6 +32,10 @@ do-install:
${GMAKE} uim_plugin_LTLIBRARIES=libuim-m17nlib.la install-uim_pluginLTLIBRARIES)
post-install:
- ${X11BASE}/bin/uim-module-manager --register m17nlib
+.if defined(WITHOUT_X11)
+ ${LOCALBASE}/bin/uim-module-manager --register anthy
+.else
+ ${X11BASE}/bin/uim-module-manager --register anthy
+.endif
.include "${MASTERDIR}/Makefile"
diff --git a/textproc/uim-qt/Makefile b/textproc/uim-qt/Makefile
index a7a6d96bf273..6e3ead0ac76b 100644
--- a/textproc/uim-qt/Makefile
+++ b/textproc/uim-qt/Makefile
@@ -30,6 +30,10 @@ CONFIGURE_ENV+= TMPDIR="${TMPDIR}"
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-qt_Makefile.in
+.if defined(WITHOUT_X11)
+IGNORE= requires X11
+.endif
+
do-build:
(cd ${WRKSRC}/qt && ${GMAKE} LIBS="-luim -luim-custom")
diff --git a/textproc/uim/Makefile b/textproc/uim/Makefile
index 0c6a892c736e..eccbb76e74d8 100644
--- a/textproc/uim/Makefile
+++ b/textproc/uim/Makefile
@@ -9,36 +9,53 @@ PORTNAME= uim
PORTVERSION= 1.1.1
CATEGORIES?= textproc
MASTER_SITES= http://uim.freedesktop.org/releases/
+.if !defined(UIM_SLAVE) && defined(WITHOUT_X11)
+PKGNAMESUFFIX= -nox11
+.endif
MAINTAINER= nobutaka@FreeBSD.org
COMMENT?= Input method library
-USE_X_PREFIX= yes
INSTALLS_SHLIB= yes
WANT_GNOME= yes
USE_GNOME+= gnometarget glib20
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
+USE_GETTEXT= yes
USE_ICONV= yes
GNU_CONFIGURE= yes
-.if !defined(UIM_SLAVE)
-USE_GNOME+= gtk20
-.endif
+.if !defined(WITHOUT_X11)
+USE_X_PREFIX= yes
LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/libXft
+CONFIGURE_ARGS+= --with-x --with-xft
+.endif
.if !defined(UIM_SLAVE)
-CONFIGURE_ARGS= --enable-emacs --with-gtk2
+.if !defined(WITHOUT_X11)
+USE_GNOME+= gtk20
+CONFIGURE_ARGS+= --with-gtk2
+.endif
+CONFIGURE_ARGS+= --enable-emacs
.endif
+
CONFIGURE_ENV+= CPPFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include" \
LDFLAGS="-L${X11BASE}/lib -L${LOCALBASE}/lib"
.if !defined(UIM_SLAVE)
+.if !defined(WITHOUT_X11)
MAN1= uim-xim.1
+.endif
DOCSDIR_JA= ${PREFIX}/share/doc/ja/uim
PLIST_SUB= DOCSDIR_JA="${DOCSDIR_JA:S,^${PREFIX}/,,}"
.endif
+.if defined(WITHOUT_X11)
+PLIST_SUB+= X11="@comment "
+.else
+PLIST_SUB+= X11=""
+.endif
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
@@ -52,7 +69,7 @@ BUILD_DEPENDS+= ${LOCALBASE}/bin/perl:${PORTSDIR}/lang/perl5
CONFIGURE_ENV+= INTLTOOL_PERL="${LOCALBASE}/bin/perl"
.endif
-.for _x in gtk2 qt gnome2 anthy canna m17nlib prime scim dict
+.for _x in x xft gtk2 qt gnome2 anthy canna m17nlib prime scim dict
.if ${CONFIGURE_ARGS:M--with-${_x}} == ""
CONFIGURE_ARGS+=--without-${_x}
.endif
diff --git a/textproc/uim/pkg-plist b/textproc/uim/pkg-plist
index 75a1ef6e7cfc..b672612753ff 100644
--- a/textproc/uim/pkg-plist
+++ b/textproc/uim/pkg-plist
@@ -4,7 +4,7 @@ bin/uim-fep
bin/uim-fep-tick
bin/uim-module-manager
bin/uim-sh
-bin/uim-xim
+%%X11%%bin/uim-xim
include/uim/plugin.h
include/uim/uim-compat-scm.h
include/uim/uim-custom.h
@@ -28,7 +28,7 @@ lib/uim/plugin/libuim-skk.a
lib/uim/plugin/libuim-skk.la
lib/uim/plugin/libuim-skk.so
libdata/pkgconfig/uim.pc
-libexec/uim-candwin-gtk
+%%X11%%libexec/uim-candwin-gtk
libexec/uim-helper-server
share/applications/uim.desktop
share/locale/fr/LC_MESSAGES/uim.mo