aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/n98-magerun/Makefile25
-rw-r--r--sysutils/n98-magerun/distinfo2
-rw-r--r--sysutils/n98-magerun/pkg-descr7
-rw-r--r--sysutils/n98-magerun/pkg-plist1
5 files changed, 36 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 2aeb645a9211..7354a51089ec 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -544,6 +544,7 @@
SUBDIR += munin-node
SUBDIR += muse
SUBDIR += mybashburn
+ SUBDIR += n98-magerun
SUBDIR += nagios-statd
SUBDIR += namefix
SUBDIR += nbosd
diff --git a/sysutils/n98-magerun/Makefile b/sysutils/n98-magerun/Makefile
new file mode 100644
index 000000000000..d29eaa232098
--- /dev/null
+++ b/sysutils/n98-magerun/Makefile
@@ -0,0 +1,25 @@
+# Created by: Melvyn Sopacua <melvyn@magemana.nl>
+# $FreeBSD$
+
+PORTNAME= n98-magerun
+PORTVERSION= 1.89.2
+CATEGORIES= sysutils www
+MASTER_SITES= GITHUB
+
+MAINTAINER= melvyn@magemana.nl
+COMMENT= CLI tool for inspection and control of Magento installations
+
+USE_PHP= phar bz2 simplexml pdo_mysql json zlib ctype dom posix
+USE_MYSQL= client
+
+USE_GITHUB= yes
+GH_ACCOUNT= netz98
+GH_PROJECT= n98-magerun
+GH_COMMIT= 37b1e5d
+NO_BUILD= yes
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.phar \
+ ${STAGEDIR}${PREFIX}/sbin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/sysutils/n98-magerun/distinfo b/sysutils/n98-magerun/distinfo
new file mode 100644
index 000000000000..f7e2832d2531
--- /dev/null
+++ b/sysutils/n98-magerun/distinfo
@@ -0,0 +1,2 @@
+SHA256 (n98-magerun-1.89.2.tar.gz) = e88a9ded44a6a0abcd52741d78765df07413a8da25826dd1404c5ad1b14eb98c
+SIZE (n98-magerun-1.89.2.tar.gz) = 1720706
diff --git a/sysutils/n98-magerun/pkg-descr b/sysutils/n98-magerun/pkg-descr
new file mode 100644
index 000000000000..55efd2edc257
--- /dev/null
+++ b/sysutils/n98-magerun/pkg-descr
@@ -0,0 +1,7 @@
+Provides some handy tools for magento developers like a quick database
+info from local.xml or a database dump feature, cache clearing, admin
+user password reset. You can also easily install a complete shop and
+sample data with buildin installer. For coders there are also many
+features like a module kickstarter (with modman support).
+
+WWW: http://magerun.net/
diff --git a/sysutils/n98-magerun/pkg-plist b/sysutils/n98-magerun/pkg-plist
new file mode 100644
index 000000000000..55827c3213ce
--- /dev/null
+++ b/sysutils/n98-magerun/pkg-plist
@@ -0,0 +1 @@
+sbin/n98-magerun