aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/mtpaint/Makefile6
-rw-r--r--misc/magicpoint/Makefile7
2 files changed, 8 insertions, 5 deletions
diff --git a/graphics/mtpaint/Makefile b/graphics/mtpaint/Makefile
index 1451be2337b8..c842addc5073 100644
--- a/graphics/mtpaint/Makefile
+++ b/graphics/mtpaint/Makefile
@@ -7,14 +7,14 @@
PORTNAME= mtpaint
PORTVERSION= 3.31
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple painting program
-LIB_DEPENDS= ungif.5:${PORTSDIR}/graphics/libungif \
+LIB_DEPENDS= gif.5:${PORTSDIR}/graphics/giflib \
jasper.4:${PORTSDIR}/graphics/jasper \
jpeg.10:${PORTSDIR}/graphics/jpeg \
openjpeg.2:${PORTSDIR}/graphics/openjpeg \
@@ -27,7 +27,7 @@ USE_GNOME= gtk20
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --mandir=${MAN1PREFIX}/man/man1 \
--locale=${PREFIX}/share/locale \
- gtk2 cflags slow asneeded gif jpeg jp2 tiff man
+ gtk2 cflags slow asneeded GIF jpeg jp2 tiff man
MANCOMPRESSED= yes
MAN1= ${PORTNAME}.1
diff --git a/misc/magicpoint/Makefile b/misc/magicpoint/Makefile
index 0258c946fc84..70ad56074631 100644
--- a/misc/magicpoint/Makefile
+++ b/misc/magicpoint/Makefile
@@ -7,7 +7,7 @@
PORTNAME= magicpoint
PORTVERSION= 1.13a
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES?= misc
MASTER_SITES= ftp://sh.wide.ad.jp/WIDE/free-ware/mgp/
@@ -62,7 +62,7 @@ CONFIGURE_ARGS+= --disable-xft2
.endif
.if defined(WITH_GIF)
-LIB_DEPENDS+= ungif.5:${PORTSDIR}/graphics/libungif
+LIB_DEPENDS+= gif.5:${PORTSDIR}/graphics/giflib
CONFIGURE_ARGS+= --enable-gif
.else
CONFIGURE_ARGS+= --disable-gif
@@ -75,6 +75,9 @@ CONFIGURE_ARGS+= --enable-imlib
CONFIGURE_ARGS+= --disable-imlib
.endif
+post-patch:
+ ${REINPLACE_CMD} -e 's|-lungif|-lgif|' ${WRKSRC}/configure
+
post-configure:
cd ${WRKSRC}/contrib/xmindpath && \
${SH} ${CONFIGURE_SCRIPT} --prefix=${PREFIX}