aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/lmon/Makefile39
-rw-r--r--sysutils/lmon/distinfo2
-rw-r--r--sysutils/lmon/pkg-descr9
-rw-r--r--sysutils/lmon/pkg-message8
-rw-r--r--sysutils/lmon/pkg-plist13
6 files changed, 72 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 42cd7080c36c..1824253292cb 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -249,6 +249,7 @@
SUBDIR += lire
SUBDIR += livecd
SUBDIR += lmmon
+ SUBDIR += lmon
SUBDIR += log_analysis
SUBDIR += logmon
SUBDIR += logrotate
diff --git a/sysutils/lmon/Makefile b/sysutils/lmon/Makefile
new file mode 100644
index 000000000000..7b597d614412
--- /dev/null
+++ b/sysutils/lmon/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: lmon
+# Date created: 15 Mar 2005
+# Whom: Anders Nordby <anders@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lmon
+PORTVERSION= 1.0
+CATEGORIES= sysutils
+MASTER_SITES= http://www.bsdconsulting.no/tools/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= anders@FreeBSD.org
+COMMENT= Near-realtime log monitoring tool, sends alerts on hits and misses
+
+RUN_DEPENDS= ${SITE_PERL}/Config/IniFiles.pm:${PORTSDIR}/devel/p5-Config-IniFiles \
+ ${SITE_PERL}/Mail/Sendmail.pm:${PORTSDIR}/mail/p5-Mail-Sendmail \
+ ${SITE_PERL}/File/Tail.pm:${PORTSDIR}/devel/p5-File-Tail
+
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL} -d -m 0755 ${PREFIX}/${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKSRC}/lmon.pl ${PREFIX}/${PORTNAME}/
+ ${INSTALL_SCRIPT} ${WRKSRC}/control.pl ${PREFIX}/${PORTNAME}/
+ ${INSTALL_DATA} ${WRKSRC}/examples/control.cfg ${PREFIX}/${PORTNAME}/control.cfg.sample
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/lmon.init ${PREFIX}/etc/rc.d/lmon.sh.sample
+.if !defined(NOPORTDOCS)
+ ${INSTALL} -d -m 0755 ${DOCSDIR}
+.for f in LICENSE README TODO
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
+.endif
+ ${INSTALL} -d -m 0755 ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/*.rules ${EXAMPLESDIR}/
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/sysutils/lmon/distinfo b/sysutils/lmon/distinfo
new file mode 100644
index 000000000000..8a8c86775d43
--- /dev/null
+++ b/sysutils/lmon/distinfo
@@ -0,0 +1,2 @@
+MD5 (lmon-1.0.tgz) = 8f929f1260fa8f48938f86cc089896fa
+SIZE (lmon-1.0.tgz) = 8308
diff --git a/sysutils/lmon/pkg-descr b/sysutils/lmon/pkg-descr
new file mode 100644
index 000000000000..d2ae92b282da
--- /dev/null
+++ b/sysutils/lmon/pkg-descr
@@ -0,0 +1,9 @@
+LMon is a package for near real-time monitoring of logs, sending email alerts
+upon known (rule hits) or unknown data (rule misses). It features buffering of
+multiple rule hits within a given interval, cap at a given maximum number of
+lines, wait for a given interval before sending next alert, and auto- discovery
+of log rotation. It can be run from the command line without configuration, or
+be controlled from a central configuration file with multiple instances
+monitoring different log files/sending alerts to different people.
+
+WWW: http://www.bsdconsulting.no/tools/
diff --git a/sysutils/lmon/pkg-message b/sysutils/lmon/pkg-message
new file mode 100644
index 000000000000..aff0e7517f8e
--- /dev/null
+++ b/sysutils/lmon/pkg-message
@@ -0,0 +1,8 @@
+================================================================================
+
+LMon is now installed in /usr/local/lmon. You need to create configuration and
+rulesets. See documentation under /usr/local/share/doc/lmon and examples under
+/usr/local/share/examples/lmon. Particularly, you need to set SMTP servers in
+in lmon.pl (plan to improve this soon).
+
+================================================================================
diff --git a/sysutils/lmon/pkg-plist b/sysutils/lmon/pkg-plist
new file mode 100644
index 000000000000..dcf4f7707e9d
--- /dev/null
+++ b/sysutils/lmon/pkg-plist
@@ -0,0 +1,13 @@
+etc/rc.d/lmon.sh.sample
+lmon/control.cfg.sample
+lmon/control.pl
+lmon/lmon.pl
+%%EXAMPLESDIR%%/ciss-messages.rules
+%%EXAMPLESDIR%%/squid-times.rules
+%%EXAMPLESDIR%%/jboss.rules
+%%EXAMPLESDIR%%/messages.rules
+@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%@dirrm %%DOCSDIR%%