aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/phpldapadmin/Makefile62
-rw-r--r--net/phpldapadmin/files/patch-tools__po__Makefile7
-rw-r--r--net/phpldapadmin/files/pkg-deinstall.in26
3 files changed, 20 insertions, 75 deletions
diff --git a/net/phpldapadmin/Makefile b/net/phpldapadmin/Makefile
index f33a492bdfec..68bbe36265f8 100644
--- a/net/phpldapadmin/Makefile
+++ b/net/phpldapadmin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= phpldapadmin
PORTVERSION= 1.2.3
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= net www
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-php5/${PORTVERSION}
@@ -19,24 +19,8 @@ NO_BUILD= yes
USE_PHP= gettext ldap openssl pcre session xml iconv hash
DEFAULT_PHP_VER= 5
-OPTIONS_DEFINE= SUPHP
-SUPHP_DESCR= suPHP support
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MSUPHP}
-
-PKGNAMESUFFIX+= -suphp
-RUN_DEPENDS+= ${LOCALBASE}/sbin/suphp:${PORTSDIR}/www/suphp
-WANT_PHP_CGI= yes
-
-.else
-
WANT_PHP_WEB= yes
-.endif
-
-# USERS is only used when SUPHP option selected
GROUPS?= ${WWWGRP}
CFGDIR= config
CFGFILE= config.php
@@ -44,16 +28,6 @@ CFGFILE= config.php
PLIST= ${WRKDIR}/plist
PLIST_SUB+= PLA_GRP=${GROUPS}
-.if ${PORT_OPTIONS:MSUPHP}
-
-USERS?= _pla
-
-SUB_LIST+= PLA_USR=${USERS} \
- PLA_GRP=${GROUPS}
-SUB_FILES+= pkg-install pkg-deinstall
-
-.endif
-
SUB_LIST+= PKGNAME=${PKGNAME}
SUB_FILES+= pkg-message
@@ -62,34 +36,24 @@ SUB_FILES+= pkg-message
post-patch:
cd ${WRKSRC} ; \
${FIND} . ! -type d ! -name ${CFGFILE}.example ! -name .cvsignore \
- ! -name .gitignore | ${SORT} | ${SED} -e "s!^\.!%%WWWDIR%%!" \
- >${PLIST} ; \
+ ! -name .gitignore ! -name *.orig | ${SORT} | \
+ ${SED} -e "s!^\.!%%WWWDIR%%!" >${PLIST} ; \
${CAT} ${PKGDIR}/pkg-plist-chunk >>${PLIST} ; \
${FIND} . -type d | ${SORT} -r | ${SED} \
-e 's!^\./${CFGDIR}$$!@dirrmtry %%WWWDIR%%/${CFGDIR}!' \
-e 's!^\.$$!@dirrmtry %%WWWDIR%%!' \
-e 's!^\.!@dirrm %%WWWDIR%%!' >>${PLIST}
-do-install: install-app install-conf
-
-install-app:
- cd ${WRKSRC} ; \
- for src in $$( ${FIND} . ! -name .cvsignore \
- ! -name .gitignore ) ; do \
- dst=${STAGEDIR}${WWWDIR}$${src#.} ; \
- if ${TEST} -d $$src ; then \
- ${MKDIR} $$dst ; \
- else \
- ${INSTALL_DATA} $$src $$dst ; \
- fi \
+do-install:
+ cd ${WRKSRC} ; \
+ for src in $$( ${FIND} . ! -name .cvsignore \
+ ! -name .gitignore ! -name *.orig ) ; do \
+ dst=${STAGEDIR}${WWWDIR}$${src#.} ; \
+ if ${TEST} -d $$src ; then \
+ ${MKDIR} $$dst ; \
+ else \
+ ${INSTALL_DATA} $$src $$dst ; \
+ fi \
done
-install-conf:
- cd ${STAGEDIR}${WWWDIR}/${CFGDIR} ; \
- ${CHMOD} 0640 ${CFGFILE}.example ; \
- ${CHGRP} ${GROUPS} ${CFGFILE}.example ; \
- if ${TEST} ! -f ${CFGFILE} ; then \
- ${CP} -p ${CFGFILE}.example ${CFGFILE} ; \
- fi
-
.include <bsd.port.mk>
diff --git a/net/phpldapadmin/files/patch-tools__po__Makefile b/net/phpldapadmin/files/patch-tools__po__Makefile
new file mode 100644
index 000000000000..cacbef161c54
--- /dev/null
+++ b/net/phpldapadmin/files/patch-tools__po__Makefile
@@ -0,0 +1,7 @@
+--- ./tools/po/Makefile.orig 2013-12-17 10:35:33.849229663 +0000
++++ ./tools/po/Makefile 2013-12-17 10:35:42.989230589 +0000
+@@ -1,4 +1,3 @@
+-#!/bin/bash
+ #
+ # Makefile Utility to manipulate PO and POT files
+ # Copyright (c) 2009 Alessandro De Zorzi - <lota@nonlontano.it>
diff --git a/net/phpldapadmin/files/pkg-deinstall.in b/net/phpldapadmin/files/pkg-deinstall.in
deleted file mode 100644
index abdf9fe5b5aa..000000000000
--- a/net/phpldapadmin/files/pkg-deinstall.in
+++ /dev/null
@@ -1,26 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD: /tmp/pcvs/ports/net/phpldapadmin/files/pkg-deinstall.in,v 1.3 2009-12-24 20:50:22 miwi Exp $
-#
-
-case $2 in
- POST-DEINSTALL)
- cat <<EOMSG
-The phpldapadmin-suphp port has been deleted.
-If you are not upgrading and don't intend to use
-phpldapadmin any more then you may wish to delete
-the %%PLA_USR%% account, which can be done with
-the following command:
-
- # pw userdel %%PLA_USR%%
-EOMSG
- if [ -d %%WWWDIR%% ] ; then
- echo " # rm -rf %%WWWDIR%%/"
- fi
- echo
- ;;
-esac
-
-#
-# That's All Folks!
-#